]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
- fix building with kernel 4.9.256 auto/th/VirtualBox-6.1.18-3
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 6 Feb 2021 21:14:18 +0000 (22:14 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 6 Feb 2021 21:14:18 +0000 (22:14 +0100)
- rel 3

VirtualBox-no-scrextend.patch
VirtualBox-warning_workaround.patch
VirtualBox.spec
kernel-4.9.256.patch [new file with mode: 0644]
lightdm-greeter-g++-link.patch
pld-guest.patch
x32.patch

index 4965612899600410b8cb56faf22e3e27d707ab75..a2fbf0ddd6aee5d9ee41cb17565be6273b62c0d9 100644 (file)
@@ -1,10 +1,10 @@
 --- VirtualBox-5.0.0/doc/manual/docbook2latex.xsl.orig 2015-07-09 22:40:10.126159489 +0200
 +++ VirtualBox-5.0.0/doc/manual/docbook2latex.xsl      2015-07-09 22:40:24.342836635 +0200
 @@ -117,7 +117,6 @@
 --- VirtualBox-5.0.0/doc/manual/docbook2latex.xsl.orig 2015-07-09 22:40:10.126159489 +0200
 +++ VirtualBox-5.0.0/doc/manual/docbook2latex.xsl      2015-07-09 22:40:24.342836635 +0200
 @@ -117,7 +117,6 @@
- \usepackage{fancyvrb}
+ \usepackage{fancybox}
  \usepackage{alltt}
  \usepackage{color}
 -\usepackage{scrextend}
  \definecolor{darkgreen}{rgb}{0,0.6,0}
  \usepackage{alltt}
  \usepackage{color}
 -\usepackage{scrextend}
  \definecolor{darkgreen}{rgb}{0,0.6,0}
+ \tymin=21pt
  
  
- </xsl:text>
index 06fe8363bb430207edb97532867456335a5c837e..37e700b500809b8faf09959e0d876179167893a3 100644 (file)
@@ -3,7 +3,7 @@ http://www.virtualbox.org/ticket/6715
 +++ VirtualBox-3.2.0_OSE/src/VBox/VMM/VMMAll/PGMAllGst.h       2010-05-19 14:07:31.690925013 +0200
 @@ -28,6 +28,11 @@ RT_C_DECLS_END
  
 +++ VirtualBox-3.2.0_OSE/src/VBox/VMM/VMMAll/PGMAllGst.h       2010-05-19 14:07:31.690925013 +0200
 @@ -28,6 +28,11 @@ RT_C_DECLS_END
  
+ #endif /* 32BIT, PAE, AMD64 */
  
 +#if defined(__GNUC__) && __GNUC__ == 4 && __GNUC_MINOR__ == 5
 +    // Work around gcc 4.5 producing warnings when a X86PDPE is constructed
  
 +#if defined(__GNUC__) && __GNUC__ == 4 && __GNUC_MINOR__ == 5
 +    // Work around gcc 4.5 producing warnings when a X86PDPE is constructed
index da35b369c0b4f67933bda3f72dfa1d0bef799be2..365177d86d72151cdb8b10c5c66263a30f58fb51 100644 (file)
@@ -47,7 +47,7 @@ exit 1
 
 %define                qtver   5.6.0
 
 
 %define                qtver   5.6.0
 
-%define                rel             2
+%define                rel             3
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
@@ -88,6 +88,7 @@ Patch15:      %{pname}-lightdm-1.19.2.patch
 Patch16:       %{pname}-no-vboxvideo.patch
 Patch17:       qt5-gl.patch
 Patch18:       32bit.patch
 Patch16:       %{pname}-no-vboxvideo.patch
 Patch17:       qt5-gl.patch
 Patch18:       32bit.patch
+Patch19:       kernel-4.9.256.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -568,6 +569,7 @@ tar -zxf guest-modules.tar.gz -C GuestDrivers
 ../src/VBox/HostDrivers/linux/export_modules.sh --file host-modules.tar.gz --without-hardening
 tar -zxf host-modules.tar.gz -C HostDrivers
 cd -
 ../src/VBox/HostDrivers/linux/export_modules.sh --file host-modules.tar.gz --without-hardening
 tar -zxf host-modules.tar.gz -C HostDrivers
 cd -
+%patch19 -p1
 %endif
 
 # using system kBuild package
 %endif
 
 # using system kBuild package
diff --git a/kernel-4.9.256.patch b/kernel-4.9.256.patch
new file mode 100644 (file)
index 0000000..751678b
--- /dev/null
@@ -0,0 +1,231 @@
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxguest/r0drv/linux/memobj-r0drv-linux.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxguest/r0drv/linux/memobj-r0drv-linux.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxguest/r0drv/linux/memobj-r0drv-linux.c   2021-02-06 22:09:20.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxguest/r0drv/linux/memobj-r0drv-linux.c       2021-02-06 22:08:19.038693668 +0100
+@@ -1174,7 +1174,7 @@
+ /* openSUSE Leap 42.3 detection :-/ */
+ #if RTLNX_VER_RANGE(4,4,0,  4,6,0) && defined(FAULT_FLAG_REMOTE)
+-# define GET_USER_PAGES_API     KERNEL_VERSION(4, 10, 0) /* no typo! */
++# define GET_USER_PAGES_API     KERNEL_VERSION(4, 11, 0) /* no typo! */
+ #else
+ # define GET_USER_PAGES_API     LINUX_VERSION_CODE
+ #endif
+@@ -1252,7 +1252,7 @@
+ # endif
+                                 &pMemLnx->apPages[0],   /* Page array. */
+                                 papVMAs                 /* vmas */
+-# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 10, 0)
++# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 11, 0)
+                                 , NULL                  /* locked */
+ # endif
+                                 );
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxguest/r0drv/linux/mpnotification-r0drv-linux.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxguest/r0drv/linux/mpnotification-r0drv-linux.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxguest/r0drv/linux/mpnotification-r0drv-linux.c   2021-02-06 22:09:20.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxguest/r0drv/linux/mpnotification-r0drv-linux.c       2021-02-06 21:54:24.869047375 +0100
+@@ -37,7 +37,7 @@
+ #include <iprt/thread.h>
+ #include "r0drv/mp-r0drv.h"
+-#if RTLNX_VER_MIN(4,10,0)
++#if RTLNX_VER_MIN(4,11,0)
+ static enum cpuhp_state g_rtR0MpOnline;
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/lnkops.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/lnkops.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/lnkops.c      2021-02-06 22:09:20.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/lnkops.c  2021-02-06 21:54:24.869047375 +0100
+@@ -286,7 +286,7 @@
+  * Symlink inode operations.
+  */
+ struct inode_operations vbsf_lnk_iops = {
+-#if RTLNX_VER_MAX(4,10,0)
++#if RTLNX_VER_MAX(4,11,0)
+ # if RTLNX_VER_MIN(2,6,8)
+     .readlink    = generic_readlink,
+ # else
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/regops.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/regops.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/regops.c      2021-02-06 22:09:20.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/regops.c  2021-02-06 21:54:24.869047375 +0100
+@@ -3335,7 +3335,7 @@
+ static int vbsf_vmlog_fault(struct vm_area_struct *vma, struct vm_fault *vmf)
+ {
+     int rc;
+-#  if RTLNX_VER_MIN(4,10,0)
++#  if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_fault: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->address));
+ #  else
+     SFLOGFLOW(("vbsf_vmlog_fault: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
+@@ -3384,7 +3384,7 @@
+ static int vbsf_vmlog_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
+ {
+     int rc;
+-#  if RTLNX_VER_MIN(4,10,0)
++#  if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->address));
+ #  else
+     SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
+@@ -3406,7 +3406,7 @@
+ /* Special page fault callback for mapping pages: */
+-# if RTLNX_VER_MIN(4,10,0)
++# if RTLNX_VER_MIN(4,11,0)
+ static void vbsf_vmlog_map_pages(struct vm_fault *vmf, pgoff_t start, pgoff_t end)
+ {
+     SFLOGFLOW(("vbsf_vmlog_map_pages: vmf=%p (flags=%#x addr=%p) start=%p end=%p\n", vmf, vmf->flags, vmf->address, start, end));
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/vfsmod.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/vfsmod.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/vfsmod.c      2021-02-06 22:09:20.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxsf/vfsmod.c  2021-02-06 21:54:24.869047375 +0100
+@@ -443,7 +443,7 @@
+                  trouches it after this point (we may screw up something).  */
+ # if RTLNX_VER_RANGE(4,0,0,  4,2,0)
+     sb->s_bdi = pSuperInfo->bdi_org; /* (noop_backing_dev_info is not exported) */
+-# elif RTLNX_VER_RANGE(2,6,34,  4,10,0)
++# elif RTLNX_VER_RANGE(2,6,34,  4,11,0)
+     sb->s_bdi = &noop_backing_dev_info;
+ # endif
+ #endif
+diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxvideo/vbox_ttm.c VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxvideo/vbox_ttm.c
+--- VirtualBox-6.1.18/kernel/GuestDrivers/vboxvideo/vbox_ttm.c 2021-02-06 22:09:21.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/GuestDrivers/vboxvideo/vbox_ttm.c     2021-02-06 21:54:24.872380697 +0100
+@@ -314,7 +314,7 @@
+ #if RTLNX_VER_MAX(5,10,0)
+       .init_mem_type = vbox_bo_init_mem_type,
+ #endif
+-#if RTLNX_VER_MIN(4,10,0) || RTLNX_RHEL_MAJ_PREREQ(7,4)
++#if RTLNX_VER_MIN(4,11,0) || RTLNX_RHEL_MAJ_PREREQ(7,4)
+       .eviction_valuable = ttm_bo_eviction_valuable,
+ #endif
+       .evict_flags = vbox_bo_evict_flags,
+diff -ur VirtualBox-6.1.18/kernel/HostDrivers/vboxdrv/r0drv/linux/memobj-r0drv-linux.c VirtualBox-6.1.18-256/kernel/HostDrivers/vboxdrv/r0drv/linux/memobj-r0drv-linux.c
+--- VirtualBox-6.1.18/kernel/HostDrivers/vboxdrv/r0drv/linux/memobj-r0drv-linux.c      2021-02-06 22:09:22.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/HostDrivers/vboxdrv/r0drv/linux/memobj-r0drv-linux.c  2021-02-06 22:08:40.515390291 +0100
+@@ -1174,7 +1174,7 @@
+ /* openSUSE Leap 42.3 detection :-/ */
+ #if RTLNX_VER_RANGE(4,4,0,  4,6,0) && defined(FAULT_FLAG_REMOTE)
+-# define GET_USER_PAGES_API     KERNEL_VERSION(4, 10, 0) /* no typo! */
++# define GET_USER_PAGES_API     KERNEL_VERSION(4, 11, 0) /* no typo! */
+ #else
+ # define GET_USER_PAGES_API     LINUX_VERSION_CODE
+ #endif
+@@ -1252,7 +1252,7 @@
+ # endif
+                                 &pMemLnx->apPages[0],   /* Page array. */
+                                 papVMAs                 /* vmas */
+-# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 10, 0)
++# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 11, 0)
+                                 , NULL                  /* locked */
+ # endif
+                                 );
+diff -ur VirtualBox-6.1.18/kernel/HostDrivers/vboxdrv/r0drv/linux/mpnotification-r0drv-linux.c VirtualBox-6.1.18-256/kernel/HostDrivers/vboxdrv/r0drv/linux/mpnotification-r0drv-linux.c
+--- VirtualBox-6.1.18/kernel/HostDrivers/vboxdrv/r0drv/linux/mpnotification-r0drv-linux.c      2021-02-06 22:09:22.000000000 +0100
++++ VirtualBox-6.1.18-256/kernel/HostDrivers/vboxdrv/r0drv/linux/mpnotification-r0drv-linux.c  2021-02-06 21:54:24.872380697 +0100
+@@ -37,7 +37,7 @@
+ #include <iprt/thread.h>
+ #include "r0drv/mp-r0drv.h"
+-#if RTLNX_VER_MIN(4,10,0)
++#if RTLNX_VER_MIN(4,11,0)
+ static enum cpuhp_state g_rtR0MpOnline;
+diff -ur VirtualBox-6.1.18/src/VBox/Additions/linux/drm/vbox_ttm.c VirtualBox-6.1.18-256/src/VBox/Additions/linux/drm/vbox_ttm.c
+--- VirtualBox-6.1.18/src/VBox/Additions/linux/drm/vbox_ttm.c  2021-01-07 16:34:24.000000000 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Additions/linux/drm/vbox_ttm.c      2021-02-06 21:54:24.869047375 +0100
+@@ -319,7 +319,7 @@
+ #if RTLNX_VER_MAX(5,10,0)
+       .init_mem_type = vbox_bo_init_mem_type,
+ #endif
+-#if RTLNX_VER_MIN(4,10,0) || RTLNX_RHEL_MAJ_PREREQ(7,4)
++#if RTLNX_VER_MIN(4,11,0) || RTLNX_RHEL_MAJ_PREREQ(7,4)
+       .eviction_valuable = ttm_bo_eviction_valuable,
+ #endif
+       .evict_flags = vbox_bo_evict_flags,
+diff -ur VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/lnkops.c VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/lnkops.c
+--- VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/lnkops.c  2021-01-07 16:34:26.000000000 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/lnkops.c      2021-02-06 21:54:24.869047375 +0100
+@@ -286,7 +286,7 @@
+  * Symlink inode operations.
+  */
+ struct inode_operations vbsf_lnk_iops = {
+-#if RTLNX_VER_MAX(4,10,0)
++#if RTLNX_VER_MAX(4,11,0)
+ # if RTLNX_VER_MIN(2,6,8)
+     .readlink    = generic_readlink,
+ # else
+diff -ur VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/regops.c VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/regops.c
+--- VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/regops.c  2021-01-07 16:34:26.000000000 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/regops.c      2021-02-06 21:54:24.869047375 +0100
+@@ -3335,7 +3335,7 @@
+ static int vbsf_vmlog_fault(struct vm_area_struct *vma, struct vm_fault *vmf)
+ {
+     int rc;
+-#  if RTLNX_VER_MIN(4,10,0)
++#  if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_fault: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->address));
+ #  else
+     SFLOGFLOW(("vbsf_vmlog_fault: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
+@@ -3384,7 +3384,7 @@
+ static int vbsf_vmlog_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
+ {
+     int rc;
+-#  if RTLNX_VER_MIN(4,10,0)
++#  if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->address));
+ #  else
+     SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
+@@ -3406,7 +3406,7 @@
+ /* Special page fault callback for mapping pages: */
+-# if RTLNX_VER_MIN(4,10,0)
++# if RTLNX_VER_MIN(4,11,0)
+ static void vbsf_vmlog_map_pages(struct vm_fault *vmf, pgoff_t start, pgoff_t end)
+ {
+     SFLOGFLOW(("vbsf_vmlog_map_pages: vmf=%p (flags=%#x addr=%p) start=%p end=%p\n", vmf, vmf->flags, vmf->address, start, end));
+diff -ur VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/vfsmod.c VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/vfsmod.c
+--- VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/vfsmod.c  2021-01-07 16:34:26.000000000 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Additions/linux/sharedfolders/vfsmod.c      2021-02-06 21:54:24.869047375 +0100
+@@ -443,7 +443,7 @@
+                  trouches it after this point (we may screw up something).  */
+ # if RTLNX_VER_RANGE(4,0,0,  4,2,0)
+     sb->s_bdi = pSuperInfo->bdi_org; /* (noop_backing_dev_info is not exported) */
+-# elif RTLNX_VER_RANGE(2,6,34,  4,10,0)
++# elif RTLNX_VER_RANGE(2,6,34,  4,11,0)
+     sb->s_bdi = &noop_backing_dev_info;
+ # endif
+ #endif
+diff -ur VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c VirtualBox-6.1.18-256/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
+--- VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c        2021-02-06 22:09:20.335448500 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c    2021-02-06 22:07:34.318634767 +0100
+@@ -1174,7 +1174,7 @@
+ /* openSUSE Leap 42.3 detection :-/ */
+ #if RTLNX_VER_RANGE(4,4,0,  4,6,0) && defined(FAULT_FLAG_REMOTE)
+-# define GET_USER_PAGES_API     KERNEL_VERSION(4, 10, 0) /* no typo! */
++# define GET_USER_PAGES_API     KERNEL_VERSION(4, 11, 0) /* no typo! */
+ #else
+ # define GET_USER_PAGES_API     LINUX_VERSION_CODE
+ #endif
+@@ -1252,7 +1252,7 @@
+ # endif
+                                 &pMemLnx->apPages[0],   /* Page array. */
+                                 papVMAs                 /* vmas */
+-# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 10, 0)
++# if GET_USER_PAGES_API >= KERNEL_VERSION(4, 11, 0)
+                                 , NULL                  /* locked */
+ # endif
+                                 );
+diff -ur VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/mpnotification-r0drv-linux.c VirtualBox-6.1.18-256/src/VBox/Runtime/r0drv/linux/mpnotification-r0drv-linux.c
+--- VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/mpnotification-r0drv-linux.c        2021-01-07 16:42:09.000000000 +0100
++++ VirtualBox-6.1.18-256/src/VBox/Runtime/r0drv/linux/mpnotification-r0drv-linux.c    2021-02-06 21:54:24.869047375 +0100
+@@ -37,7 +37,7 @@
+ #include <iprt/thread.h>
+ #include "r0drv/mp-r0drv.h"
+-#if RTLNX_VER_MIN(4,10,0)
++#if RTLNX_VER_MIN(4,11,0)
+ static enum cpuhp_state g_rtR0MpOnline;
index 4261c71451f5096f8ab67c0e92d371508906c5c4..26841318b9fc89f82c5358e1c7c8e35277fa70a7 100644 (file)
@@ -1,7 +1,7 @@
 --- VirtualBox-4.2.12/src/VBox/Additions/linux/lightdm-greeter/Makefile.kmk~   2013-06-01 11:13:40.000000000 +0300
 +++ VirtualBox-4.2.12/src/VBox/Additions/linux/lightdm-greeter/Makefile.kmk    2013-06-02 11:08:48.853803103 +0300
 @@ -82,4 +82,7 @@
 --- VirtualBox-4.2.12/src/VBox/Additions/linux/lightdm-greeter/Makefile.kmk~   2013-06-01 11:13:40.000000000 +0300
 +++ VirtualBox-4.2.12/src/VBox/Additions/linux/lightdm-greeter/Makefile.kmk    2013-06-02 11:08:48.853803103 +0300
 @@ -82,4 +82,7 @@
-  endif
+  vbox-greeter_LDFLAGS += -s
  endif
  
 +# as vbox build links this with gcc not g++, add -lsupc++
  endif
  
 +# as vbox build links this with gcc not g++, add -lsupc++
index 9ffa7619f1513bed1baaac4ac389bfee92d45494..22ce8da91aeeaf0e79ffab582e0bf15f4dcbd95a 100644 (file)
@@ -55,7 +55,7 @@
 --- VirtualBox-5.1.2/src/VBox/Main/src-all/Global.cpp.orig     2016-07-29 19:25:16.731328887 +0200
 +++ VirtualBox-5.1.2/src/VBox/Main/src-all/Global.cpp  2016-07-29 19:31:59.252427682 +0200
 @@ -321,6 +321,17 @@
 --- VirtualBox-5.1.2/src/VBox/Main/src-all/Global.cpp.orig     2016-07-29 19:25:16.731328887 +0200
 +++ VirtualBox-5.1.2/src/VBox/Main/src-all/Global.cpp  2016-07-29 19:31:59.252427682 +0200
 @@ -321,6 +321,17 @@
-        512,  16,  8 * _1G64, NetworkAdapterType_I82540EM, 0, StorageControllerType_PIIX4, StorageBus_IDE,
+        512,  16,  8 * _1G64, GraphicsControllerType_VMSVGA, NetworkAdapterType_I82540EM, 0, StorageControllerType_PIIX4, StorageBus_IDE,
          StorageControllerType_PIIX4, StorageBus_IDE, ChipsetType_PIIX3, AudioControllerType_AC97, AudioCodecType_STAC9700  },
  
 +    { "Linux",   "Linux",             "PLD",            "PLD Linux (32-bit)",
          StorageControllerType_PIIX4, StorageBus_IDE, ChipsetType_PIIX3, AudioControllerType_AC97, AudioCodecType_STAC9700  },
  
 +    { "Linux",   "Linux",             "PLD",            "PLD Linux (32-bit)",
@@ -71,7 +71,7 @@
 +
      { "Solaris", "Solaris",           "Solaris",            "Oracle Solaris 10 5/09 and earlier (32-bit)",
        VBOXOSTYPE_Solaris,         VBOXOSHINT_NONE,
 +
      { "Solaris", "Solaris",           "Solaris",            "Oracle Solaris 10 5/09 and earlier (32-bit)",
        VBOXOSTYPE_Solaris,         VBOXOSHINT_NONE,
-        768,  16, 16 * _1G64, NetworkAdapterType_I82540EM, 0, StorageControllerType_PIIX4, StorageBus_IDE,
+        768,  16, 16 * _1G64, GraphicsControllerType_VBoxVGA, NetworkAdapterType_I82540EM, 0, StorageControllerType_PIIX4, StorageBus_IDE,
 --- VirtualBox-4.3.8/src/VBox/Main/src-server/ApplianceImpl.cpp~       2014-02-25 19:09:15.000000000 +0200
 +++ VirtualBox-4.3.8/src/VBox/Main/src-server/ApplianceImpl.cpp        2014-02-28 09:52:48.663191185 +0200
 @@ -141,6 +141,8 @@
 --- VirtualBox-4.3.8/src/VBox/Main/src-server/ApplianceImpl.cpp~       2014-02-25 19:09:15.000000000 +0200
 +++ VirtualBox-4.3.8/src/VBox/Main/src-server/ApplianceImpl.cpp        2014-02-28 09:52:48.663191185 +0200
 @@ -141,6 +141,8 @@
index 6bc0631d4149c876fefdaa4526d6eeb717ff1fcd..6df9e3e97a97ac7b40724aaf08561a56e96626ba 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,7 +1,7 @@
 --- VirtualBox-4.3.26/configure~       2015-03-28 22:23:14.000000000 +0200
 +++ VirtualBox-4.3.26/configure        2015-03-28 22:26:31.627419402 +0200
 @@ -1943,7 +1943,7 @@
 --- VirtualBox-4.3.26/configure~       2015-03-28 22:23:14.000000000 +0200
 +++ VirtualBox-4.3.26/configure        2015-03-28 22:26:31.627419402 +0200
 @@ -1943,7 +1943,7 @@
-   fi
+   SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m"
    for p in $PYTHONDIR; do
      for d in $SUPPYTHONLIBS; do
 -      for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
    for p in $PYTHONDIR; do
      for d in $SUPPYTHONLIBS; do
 -      for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
This page took 0.224404 seconds and 4 git commands to generate.