don't build vboxguest module on kernel >= 4.16.0
authorJan Palus <atler@pld-linux.org>
Fri, 6 Apr 2018 14:55:46 +0000 (16:55 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 6 Apr 2018 14:55:46 +0000 (16:55 +0200)
vboxguest mainlined since 4.16.0

VirtualBox.spec

index 73ca976..ab74b28 100644 (file)
@@ -477,7 +477,9 @@ gospodarzem sprzętu PCI.\
 %files -n kernel%{_alt_kernel}-virtualbox-guest\
 %defattr(644,root,root,755)\
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/virtualbox-guest.conf\
+%if %{_kernel_version_code} < %{_kernel_version_magic 4 16 0}\
 /lib/modules/%{_kernel_ver}/misc/vboxguest.ko*\
+%endif\
 /lib/modules/%{_kernel_ver}/misc/vboxsf.ko*\
 %if %{_kernel_version_code} < %{_kernel_version_magic 4 13 0}\
 /lib/modules/%{_kernel_ver}/misc/vboxvideo.ko*\
This page took 0.067721 seconds and 4 git commands to generate.