]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
add patch to workaround sed 4.6 regression/changed behavior
authorJan Palus <atler@pld-linux.org>
Thu, 20 Dec 2018 17:56:24 +0000 (18:56 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 20 Dec 2018 17:56:24 +0000 (18:56 +0100)
sample input (include/VBox/Graphics/VBoxVideoGuest.h)

DECLHIDDEN(int) VBoxHGSMIGetModeHints(PHGSMIGUESTCOMMANDCONTEXT pCtx,
                                      unsigned cScreens, VBVAMODEHINT *paHints);

incorrect output:

LC_ALL=C sed -f ./src/VBox/Additions/linux/drm/indent.sed include/VBox/Graphics/VBoxVideoGuest.h
...
int hgsmi_get_mode_hints(PHGSMIGUESTCOMMANDCONTEXT ctx,
unsigned screens, struct vbva_modehint *hints);
...

correct output:

LC_ALL=C.UTF-8 sed -f ./src/VBox/Additions/linux/drm/indent.sed include/VBox/Graphics/VBoxVideoGuest.h
...
int hgsmi_get_mode_hints(struct gen_pool * ctx,
unsigned screens, struct vbva_modehint *hints);
...

PHGSMIGUESTCOMMANDCONTEXT -> struct gen_pool * is not done

VirtualBox-sed-4.6.patch [new file with mode: 0644]
VirtualBox.spec

diff --git a/VirtualBox-sed-4.6.patch b/VirtualBox-sed-4.6.patch
new file mode 100644 (file)
index 0000000..8b08e48
--- /dev/null
@@ -0,0 +1,11 @@
+--- VirtualBox-6.0.0/src/VBox/Additions/linux/export_modules.sh.orig   2018-12-20 18:52:22.251544899 +0100
++++ VirtualBox-6.0.0/src/VBox/Additions/linux/export_modules.sh        2018-12-20 18:52:43.561388418 +0100
+@@ -16,7 +16,7 @@
+ # hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+ #
+-export LC_ALL=C
++export LC_ALL=C.UTF-8
+ # The below is GNU-specific.  See VBox.sh for the longer Solaris/OS X version.
+ TARGET=`readlink -e -- "${0}"` || exit 1
index 56d9f01657520e5a372c775a1cb922ae432317c6..5f4dc883303feadc5cf8cb8877d4000bea727750 100644 (file)
@@ -81,6 +81,7 @@ Patch13:      %{pname}-no-scrextend.patch
 Patch14:       %{pname}-multipython.patch
 Patch15:       %{pname}-lightdm-1.19.2.patch
 Patch16:       %{pname}-no-vboxvideo.patch
+Patch17:       %{pname}-sed-4.6.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -549,6 +550,7 @@ cd ../..\
 %patch14 -p0
 %patch15 -p0
 %patch16 -p0
+%patch17 -p1
 
 %{__sed} -i -e 's,@VBOX_DOC_PATH@,%{_docdir}/%{name}-%{version},' \
        -e 's/Categories=.*/Categories=Utility;Emulator;/' src/VBox/Installer/common/virtualbox.desktop.in
This page took 0.047819 seconds and 4 git commands to generate.