]> git.pld-linux.org Git - packages/VirtualBox.git/commitdiff
up to 6.1.20 auto/th/VirtualBox-6.1.20-1
authorJan Palus <atler@pld-linux.org>
Wed, 21 Apr 2021 18:58:06 +0000 (20:58 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 21 Apr 2021 18:58:06 +0000 (20:58 +0200)
32bit.patch [deleted file]
VirtualBox.spec
kernel-4.9.256.patch
kernel-5.11.patch [deleted file]
x32.patch

diff --git a/32bit.patch b/32bit.patch
deleted file mode 100644 (file)
index c1ab2c0..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --color -ur VirtualBox-6.1.18.orig/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
---- VirtualBox-6.1.18.orig/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c   2021-01-07 16:42:09.000000000 +0100
-+++ VirtualBox-6.1.18/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c        2021-01-21 23:13:58.808360771 +0100
-@@ -536,7 +536,7 @@
-  * @param   uAddr               The address to apply the new protection to.
-  * @param   pvUser              The opaque user data.
-  */
--static DECLCALLBACK(int) rtR0MemObjLinuxApplyPageRange(pte_t *pPte, unsigned long uAddr, void *pvUser)
-+static int rtR0MemObjLinuxApplyPageRange(pte_t *pPte, unsigned long uAddr, void *pvUser)
- {
-     PCLNXAPPLYPGRANGE pArgs = (PCLNXAPPLYPGRANGE)pvUser;
-     PRTR0MEMOBJLNX pMemLnx = pArgs->pMemLnx;
index cd685968f3db23fc7323c1a85d7392aa437a1c5f..7c195b51e618430fc8f34b0fe837fca8a8e8b56e 100644 (file)
@@ -47,19 +47,19 @@ exit 1
 
 %define                qtver   5.6.0
 
-%define                rel             4
+%define                rel             1
 %define                pname           VirtualBox
 Summary:       VirtualBox - x86 hardware virtualizer
 Summary(pl.UTF-8):     VirtualBox - wirtualizator sprzętu x86
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       6.1.18
+Version:       6.1.20
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       https://download.virtualbox.org/virtualbox/%{version}/%{pname}-%{version}.tar.bz2
-# Source0-md5: c61001386eb3822ab8f06d688a82e84b
+# Source0-md5: f2fe05e72c37d40afb36b9fb3aa38b78
 Source1:       https://download.virtualbox.org/virtualbox/%{version}/VBoxGuestAdditions_%{version}.iso
-# Source1-md5: dc3c3f818d27a78f1accfcda05e13f85
+# Source1-md5: 59aa6c4a376e0b72a2e97be69169bad0
 Source2:       vboxservice.init
 Source3:       vboxservice.service
 Source4:       vboxservice.sysconfig
@@ -87,9 +87,7 @@ Patch14:      %{pname}-multipython.patch
 Patch15:       %{pname}-lightdm-1.19.2.patch
 Patch16:       %{pname}-no-vboxvideo.patch
 Patch17:       qt5-gl.patch
-Patch18:       32bit.patch
 Patch19:       kernel-4.9.256.patch
-Patch20:       kernel-5.11.patch
 URL:           http://www.virtualbox.org/
 %if %{with userspace}
 %ifarch %{x8664}
@@ -550,8 +548,6 @@ echo override vboxsf %{_kernel_ver} misc >> kernel/installed/etc/depmod.d/%{_ker
 %patch15 -p0
 %patch16 -p0
 %patch17 -p1
-%patch18 -p1
-%patch20 -p1
 
 %{__sed} -i -e 's,@VBOX_DOC_PATH@,%{_docdir}/%{name}-%{version},' \
        -e 's/Categories=.*/Categories=Utility;Emulator;/' src/VBox/Installer/common/virtualbox.desktop.in
index 751678b63e178bd97b558d9bb5bd368be888544d..f20b290b3701396ab8d75a78d6691563d14f6b92 100644 (file)
@@ -65,11 +65,11 @@ diff -ur VirtualBox-6.1.18/kernel/GuestDrivers/vboxsf/regops.c VirtualBox-6.1.18
  #  else
      SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
 @@ -3406,7 +3406,7 @@
- /* Special page fault callback for mapping pages: */
--# if RTLNX_VER_MIN(4,10,0)
-+# if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_map_pages: returns\n"));
+     return rc;
+ }
+-# elif RTLNX_VER_MIN(4,10,0)
++# elif RTLNX_VER_MIN(4,11,0)
  static void vbsf_vmlog_map_pages(struct vm_fault *vmf, pgoff_t start, pgoff_t end)
  {
      SFLOGFLOW(("vbsf_vmlog_map_pages: vmf=%p (flags=%#x addr=%p) start=%p end=%p\n", vmf, vmf->flags, vmf->address, start, end));
@@ -176,11 +176,11 @@ diff -ur VirtualBox-6.1.18/src/VBox/Additions/linux/sharedfolders/regops.c Virtu
  #  else
      SFLOGFLOW(("vbsf_vmlog_page_mkwrite: vma=%p vmf=%p flags=%#x addr=%p\n", vma, vmf, vmf->flags, vmf->virtual_address));
 @@ -3406,7 +3406,7 @@
- /* Special page fault callback for mapping pages: */
--# if RTLNX_VER_MIN(4,10,0)
-+# if RTLNX_VER_MIN(4,11,0)
+     SFLOGFLOW(("vbsf_vmlog_map_pages: returns\n"));
+     return rc;
+ }
+-# elif RTLNX_VER_MIN(4,10,0)
++# elif RTLNX_VER_MIN(4,11,0)
  static void vbsf_vmlog_map_pages(struct vm_fault *vmf, pgoff_t start, pgoff_t end)
  {
      SFLOGFLOW(("vbsf_vmlog_map_pages: vmf=%p (flags=%#x addr=%p) start=%p end=%p\n", vmf, vmf->flags, vmf->address, start, end));
diff --git a/kernel-5.11.patch b/kernel-5.11.patch
deleted file mode 100644 (file)
index 06a22df..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- VirtualBox-6.1.18/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c.orig    2021-01-07 16:41:28.000000000 +0100
-+++ VirtualBox-6.1.18/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c 2021-02-23 19:24:57.308526670 +0100
-@@ -39,6 +39,9 @@
- #endif
- #include <linux/netdevice.h>
- #include <linux/etherdevice.h>
-+#if RTLNX_VER_MIN(5,11,0)
-+#include <linux/ethtool.h>
-+#endif
- #include <linux/rtnetlink.h>
- #include <linux/miscdevice.h>
- #include <linux/inetdevice.h>
index 6df9e3e97a97ac7b40724aaf08561a56e96626ba..7e4e95f901e5da47253924db6be194a4385ffd6a 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,7 +1,7 @@
 --- VirtualBox-4.3.26/configure~       2015-03-28 22:23:14.000000000 +0200
 +++ VirtualBox-4.3.26/configure        2015-03-28 22:26:31.627419402 +0200
 @@ -1943,7 +1943,7 @@
-   SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m"
+   SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m"
    for p in $PYTHONDIR; do
      for d in $SUPPYTHONLIBS; do
 -      for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
This page took 0.050816 seconds and 4 git commands to generate.