]> git.pld-linux.org Git - packages/UFconfig.git/blobdiff - UFconfig-config.patch
- updated to kill optflags overrides
[packages/UFconfig.git] / UFconfig-config.patch
index 64a1044f393de8a0db4c30cd71650d0d0bda4cfb..8624a0b6c6b3b9c5bc2e27eeab8e9c430784e991 100644 (file)
@@ -1,25 +1,24 @@
-diff -burNp UFconfig/UFconfig.mk UFconfig-dud/UFconfig.mk
 --- UFconfig/UFconfig.mk       2008-09-22 20:19:37.000000000 +0200
 +++ UFconfig-dud/UFconfig.mk   2009-01-23 12:25:23.482152935 +0100
-@@ -48,7 +48,7 @@ RM = rm -f
- MV = mv -f
+@@ -53,7 +53,7 @@
+ # default make environment.
  
- # Fortran compiler (not normally required)
--F77 = f77
-+F77 = gfortran
- F77FLAGS = -O
- F77LIB =
+ # C and C++ compiler flags.  The first three are standard for *.c and *.cpp
+-CF = $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -O3 -fexceptions -fPIC
++CF = $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -fPIC
  
-@@ -89,7 +89,7 @@ MEX = mex -O -largeArrayDims -lmwlapack 
- # BLAS = -lgoto -lgfortran -lgfortranbegin -lg2c
+ # ranlib, and ar, for generating libraries.  If you don't need ranlib,
+ # just change it to RANLAB = echo
+@@ -67,7 +67,7 @@
  
- # This is probably slow ... it might connect to the Standard Reference BLAS:
--BLAS = -lblas -lgfortran -lgfortranbegin -lg2c
-+BLAS = -lblas
- LAPACK = -llapack
+ # Fortran compiler (not required for 'make' or 'make library')
+ F77 = gfortran
+-F77FLAGS = $(FFLAGS) -O
++F77FLAGS = $(FFLAGS)
+ F77LIB =
  
- # Using non-optimized versions:
-@@ -122,8 +122,8 @@ XERBLA = 
+ # C and Fortran libraries
+@@ -148,8 +148,8 @@
  # The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
  # You may wish to use an absolute path.  METIS is optional.  Compile
  # CHOLMOD with -DNPARTITION if you do not wish to use METIS.
@@ -28,5 +27,5 @@ diff -burNp UFconfig/UFconfig.mk UFconfig-dud/UFconfig.mk
 +METIS_PATH = /usr/include/metis
 +METIS = -lmetis
  
- # If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
- # options:
+ #------------------------------------------------------------------------------
+ # UMFPACK configuration:
This page took 0.392298 seconds and 4 git commands to generate.