]> git.pld-linux.org Git - packages/UFconfig.git/blobdiff - UFconfig-config.patch
- updated to 3.7.1
[packages/UFconfig.git] / UFconfig-config.patch
index 64a1044f393de8a0db4c30cd71650d0d0bda4cfb..242d16a1762d48797b6beff58ddc3adb1b7a9300 100644 (file)
@@ -1,25 +1,35 @@
-diff -burNp UFconfig/UFconfig.mk UFconfig-dud/UFconfig.mk
---- UFconfig/UFconfig.mk       2008-09-22 20:19:37.000000000 +0200
-+++ UFconfig-dud/UFconfig.mk   2009-01-23 12:25:23.482152935 +0100
-@@ -48,7 +48,7 @@ RM = rm -f
- MV = mv -f
+--- UFconfig/UFconfig.mk.orig  2011-12-08 20:19:48.000000000 +0100
++++ UFconfig/UFconfig.mk       2012-01-09 16:20:56.743005449 +0100
+@@ -53,7 +53,7 @@
+ # default make environment.
  
- # Fortran compiler (not normally required)
--F77 = f77
-+F77 = gfortran
- F77FLAGS = -O
+ # C and C++ compiler flags.  The first three are standard for *.c and *.cpp
+-CF = $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -O3 -fexceptions -fPIC
++CF = $(CFLAGS) $(CPPFLAGS) $(TARGET_ARCH) -fPIC
+ # ranlib, and ar, for generating libraries.  If you don't need ranlib,
+ # just change it to RANLAB = echo
+@@ -67,15 +67,16 @@
+ # Fortran compiler (not required for 'make' or 'make library')
+ F77 = gfortran
+-F77FLAGS = $(FFLAGS) -O
++F77FLAGS = $(FFLAGS)
  F77LIB =
  
-@@ -89,7 +89,7 @@ MEX = mex -O -largeArrayDims -lmwlapack 
- # BLAS = -lgoto -lgfortran -lgfortranbegin -lg2c
+ # C and Fortran libraries
+ LIB = -lm
  
- # This is probably slow ... it might connect to the Standard Reference BLAS:
--BLAS = -lblas -lgfortran -lgfortranbegin -lg2c
-+BLAS = -lblas
- LAPACK = -llapack
+ # For "make install"
+-INSTALL_LIB = /usr/local/lib
+-INSTALL_INCLUDE = /usr/local/include
++INSTALL_PREFIX = /usr
++INSTALL_LIB = $(INSTALL_PREFIX)/lib
++INSTALL_INCLUDE = $(INSTALL_PREFIX)/include
  
- # Using non-optimized versions:
-@@ -122,8 +122,8 @@ XERBLA = 
+ # For compiling MATLAB mexFunctions (MATLAB 7.5 or later)
+ MEX = mex -O -largeArrayDims -lmwlapack -lmwblas
+@@ -148,8 +149,8 @@
  # The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
  # You may wish to use an absolute path.  METIS is optional.  Compile
  # CHOLMOD with -DNPARTITION if you do not wish to use METIS.
@@ -28,5 +38,5 @@ diff -burNp UFconfig/UFconfig.mk UFconfig-dud/UFconfig.mk
 +METIS_PATH = /usr/include/metis
 +METIS = -lmetis
  
- # If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
- # options:
+ #------------------------------------------------------------------------------
+ # UMFPACK configuration:
This page took 0.083118 seconds and 4 git commands to generate.