]> git.pld-linux.org Git - packages/Togl.git/blob - Togl.spec
95187945ce6fe93a2d1d5ddb166006eddcf17f63
[packages/Togl.git] / Togl.spec
1 Summary:        Togl - Tk OpenGL Widget
2 Summary(pl):    Togl - Biblioteka widgetów dla Tk
3 Name:           Togl
4 Version:        1.6
5 Release:        2
6 License:        Open Source (see LICENSE file for details)
7 Group:          Libraries
8 #Source0:       http://prdownloads.sf.net/Togl/%{name}-%{version}.tar.gz
9 #...but there is only 1.5
10 Source0:        %{name}-%{version}beta2.tar.gz
11 Source1:        %{name}-Makefile.PLD
12 Patch0:         %{name}-tkInit.patch
13 URL:            http://togl.sf.net/
14 Requires:       OpenGL
15 BuildRequires:  tk >= 8.0
16 BuildRequires:  tcl >= 8.0
17 BuildRequires:  XFree86-OpenGL-devel >= 4.0.1
18 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
21
22 %description
23 Togl is a Tk widget for OpenGL rendering.
24
25 %description -l pl
26 Togl jest widgetem Tk do renderowania OpenGL.
27
28 %package devel
29 Summary:        Togl devel
30 Summary(pl):    Togl - czê¶æ dla programistów
31 Group:          Development/Libraries
32
33 %description devel
34 Header files and examples for Togl.
35
36 %description devel -l pl
37 Pliki nag³ówkowe i przyk³ady do Togl.
38
39 %prep
40 %setup -q
41 %patch -p0
42
43 %build
44 install %{SOURCE1} .
45 mv -f %{name}-Makefile.PLD Makefile
46 %{__make} RPM_OPT_FLAGS="%{rpmcflags}"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_examplesdir}/%{name}-%{version}}
51 #%{__make} prefix=$RPM_BUILD_ROOT%{_prefix} install
52
53 install libtogl.so.1.3 $RPM_BUILD_ROOT%{_libdir}
54 install double gears index overlay texture $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 install togl.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 install togl.o $RPM_BUILD_ROOT%{_libdir}
57 install togl.h $RPM_BUILD_ROOT%{_includedir}
58
59 gzip -9nf LICENSE README
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p /sbin/ldconfig
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(644,root,root,755)
69 %doc LICENSE.gz README.gz
70 %attr(755,root,root) %{_libdir}/libtogl.so.1.3
71 %attr(644,root,root) %{_libdir}/togl.o
72
73 %files devel
74 %defattr(644,root,root,755)
75 %attr(644,root,root) %{_includedir}/togl.h
76 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*[^togl.c]
77 %attr(644,root,root) %{_examplesdir}/%{name}-%{version}/*.c
This page took 0.04502 seconds and 2 git commands to generate.