]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- up to 4.18.10
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 %define         xfce_version    4.12.0
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        1.6.6
10 Release:        1
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://archive.xfce.org/src/xfce/thunar/1.6/%{name}-%{version}.tar.bz2
14 # Source0-md5:  27a5343174593dd0067906c922e6af96
15 Patch0:         %{name}-desktop.patch
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.8
19 BuildRequires:  dbus-glib-devel >= 0.62
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  exo-devel >= 0.10.0
22 BuildRequires:  gettext-tools
23 BuildRequires:  glib2-devel >= 1:2.30.0
24 BuildRequires:  gtk+2-devel >= 2:2.24.0
25 BuildRequires:  gtk-doc >= 1.7
26 BuildRequires:  intltool
27 BuildRequires:  libexif-devel >= 0.6.0
28 BuildRequires:  libnotify-devel >= 0.4.0
29 BuildRequires:  libtool
30 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
31 BuildRequires:  libxfce4util-devel >= %{xfce_version}
32 BuildRequires:  pcre-devel >= 6.0
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.601
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  udev-glib-devel >= 145
38 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
39 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
40 Requires(post,postun):  desktop-file-utils
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       exo >= 0.8.0
43 Requires:       gtk-update-icon-cache
44 Requires:       hicolor-icon-theme
45 Requires:       shared-mime-info >= 0.15
46 Requires:       xfconf >= %{xfce_version}
47 Suggests:       tumbler
48 Obsoletes:      Thunar-thumbnailers
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Thunar is a modern file manager, aiming to be easy-to-use and fast.
53
54 %description -l pl.UTF-8
55 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
56 szybkość użycia.
57
58 %package apidocs
59 Summary:        Thunar API documentation
60 Summary(pl.UTF-8):      Dokumentacja API Thunar
61 Group:          Documentation
62 Requires:       gtk-doc-common
63 Obsoletes:      thunar-vfs-apidocs
64 %if "%{_rpmversion}" >= "5"
65 BuildArch:      noarch
66 %endif
67
68 %description apidocs
69 Thunar API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API Thunar.
73
74 %package libs
75 Summary:        Thunar libraries
76 Summary(pl.UTF-8):      Biblioteki Thunar
77 Group:          X11/Libraries
78 Obsoletes:      thunar-vfs
79
80 %description libs
81 Thunar libraries.
82
83 %description libs -l pl.UTF-8
84 Biblioteki Thunar.
85
86 %package devel
87 Summary:        Header files for Thunar libraries
88 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-libs = %{version}-%{release}
91 Requires:       exo-devel >= 0.6.0
92 Requires:       gtk+2-devel >= 2:2.24.0
93 Obsoletes:      thunar-vfs-devel
94
95 %description devel
96 This is the package containing the header files for Thunar libraries.
97
98 %description devel -l pl.UTF-8
99 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
100
101 %package static
102 Summary:        Static Thunar libraries
103 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
104 Group:          X11/Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Obsoletes:      thunar-vfs-static
107
108 %description static
109 Static Thunar libraries.
110
111 %description static -l pl.UTF-8
112 Statyczne biblioteki Thunar.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 mkdir -p m4
119
120 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
121
122 %build
123 %{__gtkdocize}
124 %{__intltoolize}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__automake}
128 %{__autoheader}
129 %{__autoconf}
130 %configure \
131         --enable-dbus \
132         --enable-exif \
133         --enable-gtk-doc \
134         --enable-pcre \
135         --enable-startup-notification \
136         --with-html-dir=%{_gtkdocdir} \
137         %{?with_static_libs:--enable-static} \
138         --disable-silent-rules
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %{__rm} $RPM_BUILD_ROOT%{_libdir}/thunarx-2/*.{a,la}
148 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xfce4/panel/plugins/*.{a,la}
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151 # duplicate of ur
152 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
153
154 %find_lang %{name} --all-name
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 %update_desktop_database_post
161 %update_icon_cache hicolor
162
163 %postun
164 %update_desktop_database_postun
165 %update_icon_cache hicolor
166
167 %post   libs -p /sbin/ldconfig
168 %postun libs -p /sbin/ldconfig
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS ChangeLog NEWS README THANKS TODO
173 %attr(755,root,root) %{_bindir}/*
174 %dir %{_sysconfdir}/xdg/Thunar
175 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
176 %dir %{_libdir}/Thunar
177 %attr(755,root,root) %{_libdir}/Thunar/ThunarBulkRename
178 %attr(755,root,root) %{_libdir}/Thunar/thunar-sendto-email
179 %dir %{_libdir}/thunarx-2
180 %attr(755,root,root) %{_libdir}/thunarx-2/*.so
181 %attr(755,root,root) %{_libdir}/xfce4/panel/plugins/libthunar-tpa.so
182
183 %{_datadir}/appdata/thunar.appdata.xml
184 %{_datadir}/polkit-1/actions/org.xfce.thunar.policy
185 %{_datadir}/Thunar/sendto/*.desktop
186 %{_datadir}/xfce4/panel/plugins/*.desktop
187 %{_datadir}/dbus-1/services/*.service
188 %{_desktopdir}/*.desktop
189 %{_iconsdir}/hicolor/*/*/*
190 %{_pixmapsdir}/Thunar
191 %{_mandir}/man1/Thunar*
192
193 %dir %{_docdir}/Thunar
194 # move it to proper place
195 %{_docdir}/Thunar/README*
196
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/thunarx
200
201 %files libs
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libthunarx-2.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/libthunarx-2.so.0
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libthunarx-2.so
209 %{_includedir}/thunarx-2
210 %{_pkgconfigdir}/thunarx-2.pc
211
212 %if %{with static_libs}
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libthunarx-2.a
216 %endif
This page took 0.085484 seconds and 3 git commands to generate.