]> git.pld-linux.org Git - packages/SystemPreferences.git/commitdiff
- added master
authoraredridel <aredridel@pld-linux.org>
Thu, 20 Nov 2008 05:32:42 +0000 (05:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    SystemPreferences-initWithArgs.patch -> 1.1
    SystemPreferences.spec -> 1.1

SystemPreferences-initWithArgs.patch [new file with mode: 0644]
SystemPreferences.spec [new file with mode: 0644]

diff --git a/SystemPreferences-initWithArgs.patch b/SystemPreferences-initWithArgs.patch
new file mode 100644 (file)
index 0000000..8369f08
--- /dev/null
@@ -0,0 +1,14 @@
+diff -Nur SystemPreferences-1.0.2.orig/SystemPreferences/main.m SystemPreferences-1.0.2.initWithArgs/SystemPreferences/main.m
+--- SystemPreferences-1.0.2.orig/SystemPreferences/main.m      2007-11-04 13:25:08.000000000 -0700
++++ SystemPreferences-1.0.2.initWithArgs/SystemPreferences/main.m      2008-11-19 21:33:59.000000000 -0700
+@@ -7,6 +7,10 @@
+ int main(int argc, char **argv, char** env)
+ {
+       CREATE_AUTORELEASE_POOL (pool);
++#ifdef GS_PASS_ARGUMENTS
++  [NSProcessInfo initializeWithArguments: argv count: argc environment:
++env];
++#endif
+       NSApplication *theApp = [NSApplication sharedApplication];  
+       createMenu();  
+       [theApp setDelegate: [SystemPreferences systemPreferences]];  
diff --git a/SystemPreferences.spec b/SystemPreferences.spec
new file mode 100644 (file)
index 0000000..865e918
--- /dev/null
@@ -0,0 +1,106 @@
+Summary:       GNUstep System Preferences
+Name:          SystemPreferences
+Version:       1.0.2
+Release:       1
+License:       GPL
+Group:         X11/Applications
+Source0:       ftp://ftp.gnustep.org/pub/gnustep/usr-apps/%{name}-%{version}.tar.gz
+# Source0-md5: 15dad0ce0d07de79fecdcec26485bdc1
+Patch0:                %{name}-initWithArgs.patch
+URL:           http://www.gnustep.it/enrico/system-preferences/
+BuildRequires: gnustep-gui-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+GNUstep System Preferences.
+
+%package devel
+Summary:       Header files for PreferencesPane framework
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      gnustep-gui-devel
+
+%description devel
+Header files for PreferencesPane framework.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
+export GNUSTEP_FLATTENED=yes
+
+for I in PreferencePanes SystemPreferences Modules; do
+       cd $I
+       %{__make} -j1 \
+               OPTFLAG="%{rpmcflags}" \
+               messages=yes
+       cd ..
+done
+
+%install
+rm -rf $RPM_BUILD_ROOT
+export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
+export GNUSTEP_FLATTENED=yes
+
+for I in PreferencePanes SystemPreferences Modules; do
+       cd $I
+       %{__make} -j1 install \
+               GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+               DESTDIR=$RPM_BUILD_ROOT
+               messages=yes
+       cd ..
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/SystemPreferences
+%{_libdir}/GNUstep/Bundles/ColorSchemes.prefPane/ColorSchemes
+%{_libdir}/GNUstep/Bundles/Defaults.prefPane/Defaults
+%{_libdir}/GNUstep/Bundles/FileSystem.prefPane/FileSystem
+%{_libdir}/GNUstep/Bundles/FontModule.prefPane/FontModule
+%{_libdir}/GNUstep/Bundles/ModifierKeys.prefPane/ModifierKeys
+%{_libdir}/GNUstep/Bundles/TimeZone.prefPane/TimeZone
+%{_libdir}/GNUstep/Bundles/Volumes.prefPane/Volumes
+%{_libdir}/GNUstep/Colors/*.colorScheme
+%{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/PreferencePanes
+%{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/Versions/[0-9]*/PreferencePanes
+%{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/Versions/[0-9]*/libPreferencePanes.so
+%attr(755,root,root) %{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/Versions/[0-9]*/libPreferencePanes.so.1
+%attr(755,root,root) %{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/Versions/[0-9]*/libPreferencePanes.so.1.0.0
+%{_libdir}/GNUstep/Frameworks/PreferencePanes.framework/libPreferencePanes.so
+%{_libdir}/libPreferencePanes.so
+%attr(755,root,root) %{_libdir}/libPreferencePanes.so.1
+%attr(755,root,root) %{_libdir}/libPreferencePanes.so.1.0.0
+
+%dir %{_libdir}/GNUstep/Applications/*.app
+%dir %{_libdir}/GNUstep/Applications/*.app/Resources
+%{_libdir}/GNUstep/Applications/*.app/Resources/*.desktop
+%{_libdir}/GNUstep/Applications/*.app/Resources/*.plist
+%{_libdir}/GNUstep/Applications/*.app/Resources/*.tiff
+%{_libdir}/GNUstep/Applications/*.app/Resources/English.lproj
+%attr(755,root,root) %{_libdir}/GNUstep/Applications/SystemPreferences.app/SystemPreferences
+#%{_libdir}/GNUstep/Applications/*.app/Resources/*.openapp
+
+%dir %{_libdir}/GNUstep/Frameworks/*.framework
+%{_libdir}/GNUstep/Frameworks/*.framework/Resources
+%dir %{_libdir}/GNUstep/Frameworks/*.framework/Versions
+%dir %{_libdir}/GNUstep/Frameworks/*.framework/Versions/[0-9]*
+%{_libdir}/GNUstep/Frameworks/*.framework/Versions/[0-9]*/Resources
+%{_libdir}/GNUstep/Frameworks/*.framework/Versions/Current
+
+%dir %{_libdir}/GNUstep/Bundles/*.prefPane
+%{_libdir}/GNUstep/Bundles/*.prefPane/Resources
+
+%files devel
+%defattr(644,root,root,755)
+%{_libdir}/GNUstep/Frameworks/*.framework/Headers
+%{_libdir}/GNUstep/Frameworks/*.framework/Versions/[0-9]*/Headers
+%{_includedir}/*
This page took 0.097162 seconds and 4 git commands to generate.