]> git.pld-linux.org Git - packages/SysVinit.git/blobdiff - sysvinit-paths.patch
- updated to 3.04
[packages/SysVinit.git] / sysvinit-paths.patch
index 5e260c24bd12fb92305aadcd830bfab47e003b45..c60c742e9e4f70b8e5e888002114d5bee8932311 100644 (file)
@@ -1,61 +1,45 @@
---- sysvinit-2.86/src/Makefile.orig    2004-06-09 14:47:45.000000000 +0200
-+++ sysvinit-2.86/src/Makefile 2004-12-26 22:40:47.622737944 +0100
-@@ -9,7 +9,8 @@
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/Propaganda sysvinit-2.99/doc/Propaganda
+--- sysvinit-2.99.org/doc/Propaganda   2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/Propaganda       2021-02-25 08:10:45.835903318 +0100
+@@ -46,7 +46,7 @@ Some other general changes:
+   /var/run/utmp (it's also shown on the command line if you do a "ps").
+ - unreckognized options are silently ignored (such as the infamous
+   "ro" - mount root file system read only).
+-- if the file /etc/initscript is present it will be used to launch
++- if the file /etc/rc.d/rc.init is present it will be used to launch
+   all programs that init starts (so that you can set a generic
+   umask, ulimit eg for ALL processes - see initscript.sample).
+ - A "sulogin" program added that always asks for the root
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/initscript.sample sysvinit-2.99/doc/initscript.sample
+--- sysvinit-2.99.org/doc/initscript.sample    2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/initscript.sample        2021-02-25 08:10:45.835903318 +0100
+@@ -1,14 +1,14 @@
  #
- CC    = gcc
--CFLAGS        = -Wall -O2 -fomit-frame-pointer -D_GNU_SOURCE
-+OPTIMIZE = -O2 -fomit-frame-pointer
-+CFLAGS        = -Wall $(OPTIMIZE) -D_GNU_SOURCE
- LDFLAGS       = -s
- STATIC        =
-@@ -26,7 +27,7 @@
- ifeq ($(DISTRO),)
- BIN   += mountpoint
- SBIN  += sulogin bootlogd
--USRBIN        += utmpdump wall
-+USRBIN        += utmpx-dump wall
- MAN1  += mountpoint.1 wall.1
- MAN8  += sulogin.8 bootlogd.8
- endif
-@@ -71,7 +72,7 @@
- mountpoint:   mountpoint.o
-               $(CC) $(LDFLAGS) -o $@ mountpoint.o
--utmpdump:     utmpdump.o
-+utmpx-dump:   utmpdump.o
-               $(CC) $(LDFLAGS) -o $@ utmpdump.o
- runlevel:     runlevel.o
---- sysvinit-2.86/src/paths.h.orig     2004-06-09 14:47:45.000000000 +0200
-+++ sysvinit-2.86/src/paths.h  2004-12-26 22:41:21.122645184 +0100
-@@ -25,7 +25,7 @@
+-# initscript  If this script is intalled as /etc/initscript,
++# initscript  If this script is intalled as /etc/rc.d/rc.init,
+ #             it is executed by init(8) for every program it
+ #             wants to spawn like this:
+ #
+-#             /bin/sh /etc/initscript <id> <level> <action> <process>
++#             /bin/sh /etc/rc.d/rc.init <id> <level> <action> <process>
+ #
+ #             It can be used to set the default umask and ulimit
+ #             of all processes. By default this script is installed
+ #             as /etc/initscript.sample, so to enable it you must
+-#             rename this script first to /etc/initscript.
++#             rename this script first to /etc/rc.d/rc.init.
+ #
+ # Version:    @(#)initscript 1.10 10-Dec-1995 MvS.
+ #
+diff -urNp -x '*.orig' sysvinit-2.99.org/src/paths.h sysvinit-2.99/src/paths.h
+--- sysvinit-2.99.org/src/paths.h      2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/src/paths.h  2021-02-25 08:10:45.835903318 +0100
+@@ -35,7 +35,7 @@
  #define SDPID         "/var/run/shutdown.pid" /* PID of shutdown program */
  #define SHELL         "/bin/sh"               /* Default shell */
  #define SULOGIN               "/sbin/sulogin"         /* Sulogin */
 -#define INITSCRIPT    "/etc/initscript"       /* Initscript. */
 +#define INITSCRIPT    "/etc/rc.d/rc.init"     /* Initscript. */
- #define PWRSTAT               "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
- #if 0
-diff -Nru sysvinit-2.85.orig/src/utmpdump.c sysvinit-2.85/src/utmpdump.c
---- sysvinit-2.85.orig/src/utmpdump.c  Tue Sep 12 23:14:24 2000
-+++ sysvinit-2.85/src/utmpdump.c       Thu Apr 24 12:05:06 2003
-@@ -265,14 +265,14 @@
-       }
-       if (optind < argc) {
--              fprintf(stderr, "Utmp %sdump of %s\n", reverse ? "un" : "", argv[optind]);
-+              fprintf(stderr, "Utmpx %sdump of %s\n", reverse ? "un" : "", argv[optind]);
-               if ((fp = fopen(argv[optind], "r")) == NULL) {
-                       perror("Unable to open file");
-                       exit(1);
-               }
-       }
-       else {
--              fprintf(stderr, "Utmp %sdump of stdin\n", reverse ? "un" : "");
-+              fprintf(stderr, "Utmpx %sdump of stdin\n", reverse ? "un" : "");
-               fp = stdin;
-       }
+ #define PWRSTAT_OLD   "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define PWRSTAT               "/var/run/powerstatus"  /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define RUNLEVEL_LOG    "/var/run/runlevel"     /* neutral place to store run level */
This page took 0.041663 seconds and 4 git commands to generate.