]> git.pld-linux.org Git - packages/SysVinit.git/blobdiff - sysvinit-paths.patch
- updated to 3.04
[packages/SysVinit.git] / sysvinit-paths.patch
index 47f7ac1214651553f371e081cc8c32aa20882f58..c60c742e9e4f70b8e5e888002114d5bee8932311 100644 (file)
@@ -1,87 +1,45 @@
-diff -Nur sysvinit-2.76/src/Makefile sysvinit-2.76.pld/src/Makefile
---- sysvinit-2.76/src/Makefile Wed Sep  2 14:04:07 1998
-+++ sysvinit-2.76.pld/src/Makefile     Sun May 23 15:39:08 1999
-@@ -8,8 +8,9 @@
- # Version:    @(#)Makefile  2.75  30-Jul-1998  miquels@cistron.nl
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/Propaganda sysvinit-2.99/doc/Propaganda
+--- sysvinit-2.99.org/doc/Propaganda   2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/Propaganda       2021-02-25 08:10:45.835903318 +0100
+@@ -46,7 +46,7 @@ Some other general changes:
+   /var/run/utmp (it's also shown on the command line if you do a "ps").
+ - unreckognized options are silently ignored (such as the infamous
+   "ro" - mount root file system read only).
+-- if the file /etc/initscript is present it will be used to launch
++- if the file /etc/rc.d/rc.init is present it will be used to launch
+   all programs that init starts (so that you can set a generic
+   umask, ulimit eg for ALL processes - see initscript.sample).
+ - A "sulogin" program added that always asks for the root
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/initscript.sample sysvinit-2.99/doc/initscript.sample
+--- sysvinit-2.99.org/doc/initscript.sample    2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/initscript.sample        2021-02-25 08:10:45.835903318 +0100
+@@ -1,14 +1,14 @@
  #
--CC    = cc
--CFLAGS        = -Wall -O2 -D_GNU_SOURCE
-+CC     = gcc
-+OPTIMIZE = -O2
-+CFLAGS        = -Wall $(OPTIMIZE) -D_GNU_SOURCE
- LDFLAGS       = -s
- #CFLAGS       = -Wall -g -pg -D_GNU_SOURCE
- #LDFLAGS      = -pg
-@@ -89,7 +90,8 @@
-                       runlevel shutdown $(ROOT)/sbin
-               # These are not installed by default
- ifeq ($(DEBIAN),)
--              $(INSTALL) -m 555 utmpdump wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 utmpdump  $(ROOT)/usr/bin/utmpx-dump
- endif
-               # $(INSTALL) -m 755 etc/initscript.sample $(ROOT)/etc
-               $(INSTALL) -m 755 mesg last $(ROOT)/usr/bin
-@@ -97,15 +99,15 @@
-               cd $(ROOT)/sbin; ln -sf halt poweroff; chown $(BIN_COMBO) poweroff
-               cd $(ROOT)/sbin; ln -sf init telinit; chown $(BIN_COMBO) telinit
-               cd $(ROOT)/bin; ln -sf ../sbin/killall5 pidof; chown $(BIN_COMBO) pidof
--              cd $(ROOT)/usr/bin; ln -sf last lastb; chown $(BIN_COMBO) lastb
-+               cd $(ROOT)/usr/bin; ln -sf last lastb; chown $(BIN_COMBO) lastb
-               $(INSTALL) -m 644 initreq.h $(ROOT)/usr/include
--              $(INSTALL) -m 644 ../man/*.8 $(ROOT)/usr/man/man8
--              $(INSTALL) -m 644 ../man/*.5 $(ROOT)/usr/man/man5
-+              $(INSTALL) -m 644 ../man/*.8 $(ROOT)/usr/share/man/man8
-+              $(INSTALL) -m 644 ../man/*.5 $(ROOT)/usr/share/man/man5
- ifeq ($(DEBIAN),)
--              $(INSTALL) -m 644 ../man/wall.1 $(ROOT)/usr/man/man1
-+              $(INSTALL) -m 644 ../man/wall.1 $(ROOT)/usr/share/man/man1
- endif
--              $(INSTALL) -m 644 ../man/last.1 ../man/lastb.1 ../man/mesg.1 \
--                      $(ROOT)/usr/man/man1
-+              $(INSTALL) -m 644 ../man/last.1 ../man/mesg.1 \
-+                      $(ROOT)/usr/share/man/man1
-               #
-               # This part is skipped on debian systems, the
-               # debian.preinst script takes care of it.
-diff -Nur sysvinit-2.76/src/last.c sysvinit-2.76.pld/src/last.c
---- sysvinit-2.76/src/last.c   Fri May 29 15:02:58 1998
-+++ sysvinit-2.76.pld/src/last.c       Sun May 23 15:35:34 1999
-@@ -234,7 +234,7 @@
-  *    Try to be smart about the location of the BTMP file
-  */
- #ifndef BTMP_FILE
--#define BTMP_FILE getbtmp()
-+#define BTMP_FILE "/var/log/btmpx"
- char *getbtmp()
- {
-       static char btmp[128];
-diff -Nur sysvinit-2.76/src/paths.h sysvinit-2.76.pld/src/paths.h
---- sysvinit-2.76/src/paths.h  Wed Nov 26 15:23:12 1997
-+++ sysvinit-2.76.pld/src/paths.h      Sun May 23 15:23:48 1999
-@@ -28,7 +28,7 @@
+-# initscript  If this script is intalled as /etc/initscript,
++# initscript  If this script is intalled as /etc/rc.d/rc.init,
+ #             it is executed by init(8) for every program it
+ #             wants to spawn like this:
+ #
+-#             /bin/sh /etc/initscript <id> <level> <action> <process>
++#             /bin/sh /etc/rc.d/rc.init <id> <level> <action> <process>
+ #
+ #             It can be used to set the default umask and ulimit
+ #             of all processes. By default this script is installed
+ #             as /etc/initscript.sample, so to enable it you must
+-#             rename this script first to /etc/initscript.
++#             rename this script first to /etc/rc.d/rc.init.
+ #
+ # Version:    @(#)initscript 1.10 10-Dec-1995 MvS.
+ #
+diff -urNp -x '*.orig' sysvinit-2.99.org/src/paths.h sysvinit-2.99/src/paths.h
+--- sysvinit-2.99.org/src/paths.h      2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/src/paths.h  2021-02-25 08:10:45.835903318 +0100
+@@ -35,7 +35,7 @@
  #define SDPID         "/var/run/shutdown.pid" /* PID of shutdown program */
- #define IOSAVE                "/etc/ioctl.save"       /* termios settings for SU */
  #define SHELL         "/bin/sh"               /* Default shell */
+ #define SULOGIN               "/sbin/sulogin"         /* Sulogin */
 -#define INITSCRIPT    "/etc/initscript"       /* Initscript. */
-+#define INITSCRIPT    "/etc/sysconfig/initscript"     /* Initscript. */
- #if 0
- #define HALTSCRIPT1   "/etc/init.d/halt"      /* Called by "fast" shutdown */
- #define HALTSCRIPT2   "/etc/rc.d/rc.0"        /* Called by "fast" shutdown */
-diff -Nur sysvinit-2.76/src/utmpdump.c sysvinit-2.76.pld/src/utmpdump.c
---- sysvinit-2.76/src/utmpdump.c       Tue Aug 13 11:57:12 1996
-+++ sysvinit-2.76.pld/src/utmpdump.c   Sun May 23 15:23:48 1999
-@@ -48,10 +48,10 @@
-   for(f = 1; f < argc; f++) {
-       if (strcmp(argv[f], "-") == 0) {
--              printf("Utmp dump of stdin\n");
-+              printf("Utmpx dump of stdin\n");
-               dump(stdin);
-       } else if ((fp = fopen(argv[f], "r")) != NULL) {
--              printf("Utmp dump of %s\n", argv[f]);
-+              printf("Utmpx dump of %s\n", argv[f]);
-               dump(fp);
-               fclose(fp);
-       } else
++#define INITSCRIPT    "/etc/rc.d/rc.init"     /* Initscript. */
+ #define PWRSTAT_OLD   "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define PWRSTAT               "/var/run/powerstatus"  /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define RUNLEVEL_LOG    "/var/run/runlevel"     /* neutral place to store run level */
This page took 0.038383 seconds and 4 git commands to generate.