]> git.pld-linux.org Git - packages/SysVinit.git/blobdiff - sysvinit-paths.patch
- updated to 3.04
[packages/SysVinit.git] / sysvinit-paths.patch
index 19efea548d811db9cd185a51818120d4b79bed00..c60c742e9e4f70b8e5e888002114d5bee8932311 100644 (file)
@@ -1,57 +1,45 @@
-diff -Nru sysvinit-2.85.orig/src/Makefile sysvinit-2.85/src/Makefile
---- sysvinit-2.85.orig/src/Makefile    Tue Nov  6 12:58:16 2001
-+++ sysvinit-2.85/src/Makefile Thu Apr 24 12:05:06 2003
-@@ -8,8 +8,9 @@
- # Version:    @(#)Makefile  2.83-3  06-Nov-2001  miquels@cistron.nl
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/Propaganda sysvinit-2.99/doc/Propaganda
+--- sysvinit-2.99.org/doc/Propaganda   2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/Propaganda       2021-02-25 08:10:45.835903318 +0100
+@@ -46,7 +46,7 @@ Some other general changes:
+   /var/run/utmp (it's also shown on the command line if you do a "ps").
+ - unreckognized options are silently ignored (such as the infamous
+   "ro" - mount root file system read only).
+-- if the file /etc/initscript is present it will be used to launch
++- if the file /etc/rc.d/rc.init is present it will be used to launch
+   all programs that init starts (so that you can set a generic
+   umask, ulimit eg for ALL processes - see initscript.sample).
+ - A "sulogin" program added that always asks for the root
+diff -urNp -x '*.orig' sysvinit-2.99.org/doc/initscript.sample sysvinit-2.99/doc/initscript.sample
+--- sysvinit-2.99.org/doc/initscript.sample    2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/doc/initscript.sample        2021-02-25 08:10:45.835903318 +0100
+@@ -1,14 +1,14 @@
  #
--CC    = cc
--CFLAGS        = -Wall -O2 -D_GNU_SOURCE
-+CC     = gcc
-+OPTIMIZE = -O2
-+CFLAGS        = -Wall $(OPTIMIZE) -D_GNU_SOURCE
- LDFLAGS       = -s
- STATIC        =
-@@ -89,7 +90,8 @@
-                       runlevel shutdown $(ROOT)/sbin
-               # These are not installed by default
- ifeq ($(DEBIAN),)
--              $(INSTALL) -m 555 utmpdump wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 utmpdump  $(ROOT)/usr/bin/utmpx-dump
- endif
-               # $(INSTALL) -m 755 etc/initscript.sample $(ROOT)/etc
-               $(INSTALL) -m 755 mesg last $(ROOT)/usr/bin
-diff -Nru sysvinit-2.85.orig/src/paths.h sysvinit-2.85/src/paths.h
---- sysvinit-2.85.orig/src/paths.h     Mon Apr 14 13:37:01 2003
-+++ sysvinit-2.85/src/paths.h  Thu Apr 24 12:06:06 2003
-@@ -24,7 +24,7 @@
- #define FORCEFSCK     "/forcefsck"            /* Force fsck on boot */
+-# initscript  If this script is intalled as /etc/initscript,
++# initscript  If this script is intalled as /etc/rc.d/rc.init,
+ #             it is executed by init(8) for every program it
+ #             wants to spawn like this:
+ #
+-#             /bin/sh /etc/initscript <id> <level> <action> <process>
++#             /bin/sh /etc/rc.d/rc.init <id> <level> <action> <process>
+ #
+ #             It can be used to set the default umask and ulimit
+ #             of all processes. By default this script is installed
+ #             as /etc/initscript.sample, so to enable it you must
+-#             rename this script first to /etc/initscript.
++#             rename this script first to /etc/rc.d/rc.init.
+ #
+ # Version:    @(#)initscript 1.10 10-Dec-1995 MvS.
+ #
+diff -urNp -x '*.orig' sysvinit-2.99.org/src/paths.h sysvinit-2.99/src/paths.h
+--- sysvinit-2.99.org/src/paths.h      2021-02-21 19:02:25.000000000 +0100
++++ sysvinit-2.99/src/paths.h  2021-02-25 08:10:45.835903318 +0100
+@@ -35,7 +35,7 @@
  #define SDPID         "/var/run/shutdown.pid" /* PID of shutdown program */
  #define SHELL         "/bin/sh"               /* Default shell */
+ #define SULOGIN               "/sbin/sulogin"         /* Sulogin */
 -#define INITSCRIPT    "/etc/initscript"       /* Initscript. */
 +#define INITSCRIPT    "/etc/rc.d/rc.init"     /* Initscript. */
- #define PWRSTAT               "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
- #if 0
-diff -Nru sysvinit-2.85.orig/src/utmpdump.c sysvinit-2.85/src/utmpdump.c
---- sysvinit-2.85.orig/src/utmpdump.c  Tue Sep 12 23:14:24 2000
-+++ sysvinit-2.85/src/utmpdump.c       Thu Apr 24 12:05:06 2003
-@@ -265,14 +265,14 @@
-       }
-       if (optind < argc) {
--              fprintf(stderr, "Utmp %sdump of %s\n", reverse ? "un" : "", argv[optind]);
-+              fprintf(stderr, "Utmpx %sdump of %s\n", reverse ? "un" : "", argv[optind]);
-               if ((fp = fopen(argv[optind], "r")) == NULL) {
-                       perror("Unable to open file");
-                       exit(1);
-               }
-       }
-       else {
--              fprintf(stderr, "Utmp %sdump of stdin\n", reverse ? "un" : "");
-+              fprintf(stderr, "Utmpx %sdump of stdin\n", reverse ? "un" : "");
-               fp = stdin;
-       }
+ #define PWRSTAT_OLD   "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define PWRSTAT               "/var/run/powerstatus"  /* COMPAT: SIGPWR reason (OK/BAD) */
+ #define RUNLEVEL_LOG    "/var/run/runlevel"     /* neutral place to store run level */
This page took 0.032419 seconds and 4 git commands to generate.