]> git.pld-linux.org Git - packages/SysVinit.git/blobdiff - sysvinit-paths.patch
- does not require logrotate; rel 19
[packages/SysVinit.git] / sysvinit-paths.patch
index fc07aa961075b1ac02c10c59552baacfeefd4523..5e260c24bd12fb92305aadcd830bfab47e003b45 100644 (file)
@@ -1,75 +1,61 @@
-diff -Nur sysvinit-2.76/src/Makefile sysvinit-2.76.pld/src/Makefile
---- sysvinit-2.76/src/Makefile Wed Sep  2 14:04:07 1998
-+++ sysvinit-2.76.pld/src/Makefile     Sun May 23 10:03:41 1999
-@@ -8,8 +8,9 @@
- # Version:    @(#)Makefile  2.75  30-Jul-1998  miquels@cistron.nl
+--- sysvinit-2.86/src/Makefile.orig    2004-06-09 14:47:45.000000000 +0200
++++ sysvinit-2.86/src/Makefile 2004-12-26 22:40:47.622737944 +0100
+@@ -9,7 +9,8 @@
  #
  
--CC    = cc
--CFLAGS        = -Wall -O2 -D_GNU_SOURCE
-+CC     = gcc
-+OPTIMIZE = -O2
+ CC    = gcc
+-CFLAGS        = -Wall -O2 -fomit-frame-pointer -D_GNU_SOURCE
++OPTIMIZE = -O2 -fomit-frame-pointer
 +CFLAGS        = -Wall $(OPTIMIZE) -D_GNU_SOURCE
  LDFLAGS       = -s
- #CFLAGS       = -Wall -g -pg -D_GNU_SOURCE
- #LDFLAGS      = -pg
-@@ -89,7 +90,8 @@
-                       runlevel shutdown $(ROOT)/sbin
-               # These are not installed by default
- ifeq ($(DEBIAN),)
--              $(INSTALL) -m 555 utmpdump wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 wall $(ROOT)/usr/bin
-+              $(INSTALL) -m 755 utmpdump  $(ROOT)/usr/bin/utmpx-dump
- endif
-               # $(INSTALL) -m 755 etc/initscript.sample $(ROOT)/etc
-               $(INSTALL) -m 755 mesg last $(ROOT)/usr/bin
-@@ -97,15 +99,15 @@
-               cd $(ROOT)/sbin; ln -sf halt poweroff; chown $(BIN_COMBO) poweroff
-               cd $(ROOT)/sbin; ln -sf init telinit; chown $(BIN_COMBO) telinit
-               cd $(ROOT)/bin; ln -sf ../sbin/killall5 pidof; chown $(BIN_COMBO) pidof
--              cd $(ROOT)/usr/bin; ln -sf last lastb; chown $(BIN_COMBO) lastb
-+              # cd $(ROOT)/usr/bin; ln -sf last lastb; chown $(BIN_COMBO) lastb
-               $(INSTALL) -m 644 initreq.h $(ROOT)/usr/include
--              $(INSTALL) -m 644 ../man/*.8 $(ROOT)/usr/man/man8
--              $(INSTALL) -m 644 ../man/*.5 $(ROOT)/usr/man/man5
-+              $(INSTALL) -m 644 ../man/*.8 $(ROOT)/usr/share/man/man8
-+              $(INSTALL) -m 644 ../man/*.5 $(ROOT)/usr/share/man/man5
- ifeq ($(DEBIAN),)
--              $(INSTALL) -m 644 ../man/wall.1 $(ROOT)/usr/man/man1
-+              $(INSTALL) -m 644 ../man/wall.1 $(ROOT)/usr/share/man/man1
+ STATIC        =
+@@ -26,7 +27,7 @@
+ ifeq ($(DISTRO),)
+ BIN   += mountpoint
+ SBIN  += sulogin bootlogd
+-USRBIN        += utmpdump wall
++USRBIN        += utmpx-dump wall
+ MAN1  += mountpoint.1 wall.1
+ MAN8  += sulogin.8 bootlogd.8
  endif
--              $(INSTALL) -m 644 ../man/last.1 ../man/lastb.1 ../man/mesg.1 \
--                      $(ROOT)/usr/man/man1
-+              $(INSTALL) -m 644 ../man/last.1 ../man/mesg.1 \
-+                      $(ROOT)/usr/share/man/man1
-               #
-               # This part is skipped on debian systems, the
-               # debian.preinst script takes care of it.
-diff -Nur sysvinit-2.76/src/paths.h sysvinit-2.76.pld/src/paths.h
---- sysvinit-2.76/src/paths.h  Wed Nov 26 15:23:12 1997
-+++ sysvinit-2.76.pld/src/paths.h      Sun May 23 10:04:37 1999
-@@ -28,7 +28,7 @@
+@@ -71,7 +72,7 @@
+ mountpoint:   mountpoint.o
+               $(CC) $(LDFLAGS) -o $@ mountpoint.o
+-utmpdump:     utmpdump.o
++utmpx-dump:   utmpdump.o
+               $(CC) $(LDFLAGS) -o $@ utmpdump.o
+ runlevel:     runlevel.o
+--- sysvinit-2.86/src/paths.h.orig     2004-06-09 14:47:45.000000000 +0200
++++ sysvinit-2.86/src/paths.h  2004-12-26 22:41:21.122645184 +0100
+@@ -25,7 +25,7 @@
  #define SDPID         "/var/run/shutdown.pid" /* PID of shutdown program */
- #define IOSAVE                "/etc/ioctl.save"       /* termios settings for SU */
  #define SHELL         "/bin/sh"               /* Default shell */
+ #define SULOGIN               "/sbin/sulogin"         /* Sulogin */
 -#define INITSCRIPT    "/etc/initscript"       /* Initscript. */
-+#define INITSCRIPT    "/etc/sysconfig/initscript"     /* Initscript. */
++#define INITSCRIPT    "/etc/rc.d/rc.init"     /* Initscript. */
+ #define PWRSTAT               "/etc/powerstatus"      /* COMPAT: SIGPWR reason (OK/BAD) */
  #if 0
- #define HALTSCRIPT1   "/etc/init.d/halt"      /* Called by "fast" shutdown */
- #define HALTSCRIPT2   "/etc/rc.d/rc.0"        /* Called by "fast" shutdown */
-diff -Nur sysvinit-2.76/src/utmpdump.c sysvinit-2.76.pld/src/utmpdump.c
---- sysvinit-2.76/src/utmpdump.c       Tue Aug 13 11:57:12 1996
-+++ sysvinit-2.76.pld/src/utmpdump.c   Sun May 23 10:03:41 1999
-@@ -48,10 +48,10 @@
+diff -Nru sysvinit-2.85.orig/src/utmpdump.c sysvinit-2.85/src/utmpdump.c
+--- sysvinit-2.85.orig/src/utmpdump.c  Tue Sep 12 23:14:24 2000
++++ sysvinit-2.85/src/utmpdump.c       Thu Apr 24 12:05:06 2003
+@@ -265,14 +265,14 @@
+       }
+       if (optind < argc) {
+-              fprintf(stderr, "Utmp %sdump of %s\n", reverse ? "un" : "", argv[optind]);
++              fprintf(stderr, "Utmpx %sdump of %s\n", reverse ? "un" : "", argv[optind]);
+               if ((fp = fopen(argv[optind], "r")) == NULL) {
+                       perror("Unable to open file");
+                       exit(1);
+               }
+       }
+       else {
+-              fprintf(stderr, "Utmp %sdump of stdin\n", reverse ? "un" : "");
++              fprintf(stderr, "Utmpx %sdump of stdin\n", reverse ? "un" : "");
+               fp = stdin;
+       }
  
-   for(f = 1; f < argc; f++) {
-       if (strcmp(argv[f], "-") == 0) {
--              printf("Utmp dump of stdin\n");
-+              printf("Utmpx dump of stdin\n");
-               dump(stdin);
-       } else if ((fp = fopen(argv[f], "r")) != NULL) {
--              printf("Utmp dump of %s\n", argv[f]);
-+              printf("Utmpx dump of %s\n", argv[f]);
-               dump(fp);
-               fclose(fp);
-       } else
This page took 0.069102 seconds and 4 git commands to generate.