]> git.pld-linux.org Git - packages/SysVinit.git/blobdiff - SysVinit.spec
- use %useradd/%groupadd macros
[packages/SysVinit.git] / SysVinit.spec
index 4ced5d18e2c2b9d871770d91e463f38e0800316a..823d278372275404390b2108aa1ae27df0da96f9 100644 (file)
@@ -1,3 +1,8 @@
+#
+# Conditional build:
+%bcond_with    preconfigured
+%bcond_without selinux         # build without SELinux support
+#
 Summary:       System V initialization program
 Summary(de):   System V-Intialisierungsprogramm
 Summary(es):   Programa de inicialización System V
@@ -8,15 +13,15 @@ Summary(ru): 
 Summary(tr):   System V baþlatma programý
 Summary(uk):   ðÒÏÇÒÁÍÉ, ÝÏ ËÅÒÕÀÔØ ÂÁÚÏ×ÉÍÉ ÓÉÓÔÅÍÎÉÍÉ ÐÒÏÃÅÓÁÍÉ
 Name:          SysVinit
-Version:       2.85
-Release:       2
+Version:       2.86
+Release:       1
 License:       GPL
 Group:         Base
 Source0:       ftp://ftp.cistron.nl/pub/people/miquels/software/sysvinit-%{version}.tar.gz
-# Source0-md5: 8a2d8f1ed5a2909da04132fefa44905e
+# Source0-md5: 7d5d61c026122ab791ac04c8a84db967
 Source1:       sysvinit.logrotate
 Source2:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/sysvinit-non-english-man-pages.tar.bz2
-# Source2-md5: 9ae8a63a4685368fae19707f95475cca
+# Source2-md5: 9ae8a63a4685368fae19707f95475cca
 Patch0:                sysvinit-paths.patch
 Patch1:                sysvinit-bequiet.patch
 Patch2:                sysvinit-md5-bigendian.patch
@@ -24,17 +29,33 @@ Patch3:             sysvinit-wtmp.patch
 Patch4:                sysvinit-man.patch
 Patch5:                sysvinit-halt.patch
 Patch6:                sysvinit-blowfish.patch
-Patch7:                sysvinit-initctl.patch
-BuildRequires: glibc-devel
-PreReq:                shadow
+Patch7:                sysvinit-autofsck.patch
+Patch8:                sysvinit-pidof.patch
+Patch9:                sysvinit-killall5.patch
+# based on http://www.nsa.gov/selinux/patches/sysvinit-selinux.patch.gz
+Patch10:       sysvinit-selinux.patch
+%if %{with selinux}
+BuildRequires: libselinux-devel >= 1.18
+BuildRequires: libsepol-devel
+%endif
+BuildRequires: rpmbuild(macros) >= 1.202
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(post):        fileutils
+Requires(postun):      /usr/sbin/groupdel
 Requires:      /bin/awk
 Requires:      login
+%if %{with preconfigured}
 Requires:      logrotate
+%endif
 Requires:      mingetty
-Requires(post):        fileutils
+%{?with_selinux:Requires:      libselinux >= 1.18}
+Provides:      group(utmp)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
+# as in original flags
+%define                specflags       -fomit-frame-pointer
 
 %description
 The SysVinit package contains a group of processes that control the
@@ -96,16 +117,21 @@ sonlanmalar
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%{?with_selinux:%patch10 -p1}
 
 %build
 %{__make} -C src \
+       CC="%{__cc}" \
        LCRYPT="-lcrypt" \
-       OPTIMIZE="%{rpmcflags}"
+       OPTIMIZE="%{rpmcflags}" \
+       LDFLAGS="%{rpmldflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8}} \
-       $RPM_BUILD_ROOT{%{_sysconfdir},/etc/logrotate.d,/var/log}
+install -d $RPM_BUILD_ROOT{/bin,%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8}} \
+       $RPM_BUILD_ROOT{%{_includedir},%{_sysconfdir},/etc/logrotate.d,/var/log}
 
 %{__make} install -C src \
        ROOT=$RPM_BUILD_ROOT \
@@ -133,7 +159,7 @@ bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-groupadd -f -r -g 22 utmp
+%groupadd -g 22 utmp
 
 %post
 touch %{_sysconfdir}/ioctl.save /var/log/{fail,last}log
@@ -148,13 +174,14 @@ chmod 660 /var/log/lastlog
 
 %postun
 if [ "$1" = "0" ]; then
-       groupdel utmp
+       %groupremove utmp
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc doc/{Propaganda,Changelog,*.lsm}
 
+%attr(755,root,root) /bin/mountpoint
 %attr(755,root,root) %{_sbindir}/*
 %attr(755,root,root) %{_bindir}/last
 %attr(755,root,root) %{_bindir}/lastb
@@ -181,3 +208,6 @@ fi
 %lang(ja) %{_mandir}/ja/man[158]/*
 %lang(ko) %{_mandir}/ko/man[158]/*
 %lang(pl) %{_mandir}/pl/man[158]/*
+
+# devel?
+#%{_includedir}/initreq.h
This page took 0.104124 seconds and 4 git commands to generate.