]> git.pld-linux.org Git - packages/SoQt.git/commitdiff
- Seems to build.
authorMateusz Korniak <matkor@pld-linux.org>
Sat, 5 Jun 2010 20:30:46 +0000 (20:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    SoQt.spec -> 1.2

SoQt.spec

index b7f2f013c01cdcabde78c9fe74dc8c7e16bd12c9..7790d3b802ca344642d7a1a26489e9294f40a459 100644 (file)
--- a/SoQt.spec
+++ b/SoQt.spec
@@ -1,32 +1,18 @@
-# TODO:
-#      Needs Coin 
-# Conditional build:
-%bcond_with    tests           # build with tests
-%bcond_without tests           # build without tests
-#
-######         Unknown group!
+
 Summary:       Toolkit for multiplatform development of 2D user interfaces
-Summary(pl.UTF-8):     Wieloplatformowe narzędzia do rozwuju interfejsów urzytkownika 2D.
+Summary(pl.UTF-8):     Wieloplatformowe narzędzia do rozwoju interfejsów urzytkownika 2D.
 Name:          SoQt
 Version:       1.5.0
 Release:       0.1
 License:       GPL
-Group:         Productivity/Other
+Group:         X11/Libraries
 # http://ftp.coin3d.org/coin/src/all/SoQt-1.5.0.tar.gz
 Source0:       http://ftp.coin3d.org/coin/src/all/%{name}-%{version}.tar.gz
 # Source0-md5: 9f1e582373d66f556b1db113a93ac68e
-#Source1:      -
-# Source1-md5: -
-URL:           -
-#Patch0: %{name}-DESTDIR.patch
-%if %{with initscript}
-BuildRequires: rpmbuild(macros) >= 1.228
-Requires(post,preun):  /sbin/chkconfig
-Requires:      rc-scripts
-%endif
+URL:           http://www.coin3d.org/lib/soqt/
 BuildRequires: Coin-devel
 #BuildRequires:        autoconf
-#BuildRequires:        automake
+BuildRequires: automake
 #BuildRequires:        intltool
 #BuildRequires:        libtool
 #Requires(postun):     -
@@ -42,55 +28,30 @@ BuildRequires:      Coin-devel
 #ExclusiveArch:        %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# HAVE_GLX detection is broken in autocrap
+%define specflags -DHAVE_GLX
+
 %description
+Library which provides the glue between Systems in Motion's Coin
+high-level 3D visualization library and Troll Tech's Qt 2D user
+interface library
 
 %description -l pl.UTF-8
-
-%package subpackage
-######         Unknown group!
-Summary:       -
-Summary(pl.UTF-8):     -
-Group:         -
-
-%description subpackage
-
-%description subpackage -l pl.UTF-8
-
-%package libs
-Summary:       -
-Summary(pl.UTF-8):     -
-Group:         Libraries
-
-%description libs
-
-%description libs -l pl.UTF-8
+Biblioteka łącząca bibliotekę 3D wysokiego poziomu Coin z interfejsem
+Qt.
 
 %package devel
 Summary:       Header files for ... library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki ...
 Group:         Development/Libraries
-# if base package contains shared library for which these headers are
-#Requires:     %{name} = %{version}-%{release}
-# if -libs package contains shared library for which these headers are
-#Requires:     %{name}-libs = %{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files for ... library.
+Header files for SoQt library.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe biblioteki ....
+Pliki nagłówkowe biblioteki SoQt
 
-%package static
-Summary:       Static ... library
-Summary(pl.UTF-8):     Statyczna biblioteka ...
-Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-Static ... library.
-
-%description static -l pl.UTF-8
-Statyczna biblioteka ....
 
 %prep
 %setup -q
@@ -122,7 +83,8 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 # if not running libtool or automake, but config.sub is too old:
 #cp -f /usr/share/automake/config.sub .
 %configure
-%{__make}
+%{__make} \
+  LIBS="-lGL -lCoin -lQtGui -lQtCore -lQtOpenGL"
 
 #%{__make} \
 #      CFLAGS="%{rpmcflags}" \
@@ -132,9 +94,6 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 rm -rf $RPM_BUILD_ROOT
 # create directories if necessary
 #install -d $RPM_BUILD_ROOT
-%if %{with initscript}
-install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
-%endif
 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
@@ -143,60 +102,26 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%pre
-%groupadd -g xxx %{name}
-%useradd -u xxx -d /var/lib/%{name} -g %{name} -c "XXX User" %{name}
-
-%post
-
-%preun
 
-%postun
-if [ "$1" = "0" ]; then
-       %userremove %{name}
-       %groupremove %{name}
-fi
-
-%if %{with ldconfig}
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
-%endif
-
-%if %{with initscript}
-%post init
-/sbin/chkconfig --add %{name}
-%service %{name} restart
 
-%preun init
-if [ "$1" = "0" ]; then
-       %service -q %{name} stop
-       /sbin/chkconfig --del %{name}
-fi
-%endif
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
-
-%if 0
-# if _sysconfdir != %{_sysconfdir}:
-#%%dir %{_sysconfdir}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
-%attr(755,root,root) %{_bindir}/*
-%{_datadir}/%{name}
-%endif
-
-# initscript and its config
-%if %{with initscript}
-%attr(754,root,root) /etc/rc.d/init.d/%{name}
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
-%endif
-
-#%{_examplesdir}/%{name}-%{version}
-
-%if %{with subpackage}
-%files subpackage
+%attr(755,root,root) %{_bindir}/soqt-config
+%attr(755,root,root) %{_libdir}/libSoQt.so.*.*.*
+# %{_datadir}/%{name}
+%{_datadir}/Coin/conf/soqt-default.cfg
+%{_mandir}/man1/soqt-config.1*
+
+%doc AUTHORS ChangeLog NEWS README
+
+%files devel
 %defattr(644,root,root,755)
-#%doc extras/*.gz
-#%{_datadir}/%{name}-ext
-%endif
+# %doc devel-doc/*
+%{_libdir}/libSoQt.so
+%{_libdir}/libSoQt.la
+%{_includedir}/Inventor/Qt
+%{_aclocaldir}/*.m4
+%{_pkgconfigdir}/*.pc
This page took 0.115929 seconds and 4 git commands to generate.