]> git.pld-linux.org Git - packages/SoQt.git/commitdiff
- updated to 1.6.2, added qt6 bcond master auto/th/SoQt-1.6.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 10 Feb 2024 07:30:30 +0000 (08:30 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 10 Feb 2024 07:30:30 +0000 (08:30 +0100)
SoQt-pc.patch
SoQt.spec

index 48db77f94a771362d07b760d46066c8337e20f2e..460da6ae1b4273ab201378c7e3be906439b5d96c 100644 (file)
  htmldir=${docdir}/html
  
  Name: @PROJECT_NAME@
-@@ -15,7 +15,7 @@
- Version: @PROJECT_VERSION@
- Requires: Coin, @PACKAGE_ADDITIONAL_REQUIREMENTS@
- Conflicts:
--Libs: -L${libdir} @SOQT_EXTRA_LDFLAGS@ @SOQT_EXTRA_LIBS@
-+Libs: -L${libdir} -lSoQt @SOQT_EXTRA_LDFLAGS@ @SOQT_EXTRA_LIBS@
- Cflags: -I${includedir} @SOQT_EXTRA_CFLAGS@ @SOQT_EXTRA_CPPFLAGS@
- frameworkdir=@frameworkdir@
index ba43b801c2def2eb398b5a1075584db154881803..46cd84b3d5107573c11ff066a1d4b725b483054d 100644 (file)
--- a/SoQt.spec
+++ b/SoQt.spec
@@ -3,17 +3,26 @@
 %bcond_without apidocs         # API documentation
 %bcond_without static_libs     # static library
 %bcond_with    qt4             # Qt4 instead of Qt5
+%bcond_without qt5             # Qt5 (default)
+%bcond_with    qt6             # Qt6 instead of Qt5
+
+%if %{with qt4} || %{with qt6}
+%undefine      with_qt5
+%endif
+%if %{without qt4} && %{without qt5} && %{without qt6}
+%{error: at least one Qt version must be enabled}
+%endif
 
 Summary:       Qt GUI component toolkit library for Coin
 Summary(pl.UTF-8):     Biblioteka komponentu graficznego interfejsu Qt dla biblioteki Coin
 Name:          SoQt
-Version:       1.6.0
+Version:       1.6.2
 Release:       1
 License:       BSD
 Group:         X11/Libraries
 #Source0Download: https://github.com/coin3d/soqt/releases
-Source0:       https://github.com/coin3d/soqt/releases/download/SoQt-%{version}/soqt-%{version}-src.tar.gz
-# Source0-md5: 724996aedad2a33760dc36f08ceeda22
+Source0:       https://github.com/coin3d/soqt/releases/download/v%{version}/soqt-%{version}-src.tar.gz
+# Source0-md5: 70ef0990e009d806c59941d819a62c98
 Patch0:                %{name}-pc.patch
 URL:           https://github.com/coin3d/soqt
 BuildRequires: Coin-devel >= 4.0.0
@@ -22,21 +31,32 @@ BuildRequires:      OpenGL-GLX-devel
 BuildRequires: QtCore-devel >= 4
 BuildRequires: QtGui-devel >= 4
 BuildRequires: QtOpenGL-devel >= 4
-%else
+%endif
+%if %{with qt5}
 BuildRequires: Qt5Core-devel >= 5
 BuildRequires: Qt5Gui-devel >= 5
 BuildRequires: Qt5OpenGL-devel >= 5
 BuildRequires: Qt5Widgets-devel >= 5
 %endif
+%if %{with qt6}
+BuildRequires: Qt6Core-devel >= 6
+BuildRequires: Qt6Gui-devel >= 6
+BuildRequires: Qt6OpenGL-devel >= 6
+BuildRequires: Qt6Widgets-devel >= 6
+%endif
 BuildRequires: cmake >= 3.0
 %{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: libstdc++-devel
 BuildRequires: pkgconfig
 %if %{with qt4}
 BuildRequires: qt4-build >= 4
-%else
+%endif
+%if %{with qt5}
 BuildRequires: qt5-build >= 5
 %endif
+%if %{with qt6}
+BuildRequires: qt6-build >= 6
+%endif
 BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -64,12 +84,19 @@ Requires:   Coin-devel >= 4.0.0
 Requires:      QtCore-devel >= 4
 Requires:      QtGui-devel >= 4
 Requires:      QtOpenGL-devel >= 4
-%else
+%endif
+%if %{with qt5}
 Requires:      Qt5Core-devel >= 5
 Requires:      Qt5Gui-devel >= 5
 Requires:      Qt5OpenGL-devel >= 5
 Requires:      Qt5Widgets-devel >= 5
 %endif
+%if %{with qt6}
+Requires:      Qt6Core-devel >= 6
+Requires:      Qt6Gui-devel >= 6
+Requires:      Qt6OpenGL-devel >= 6
+Requires:      Qt6Widgets-devel >= 6
+%endif
 
 %description devel
 Header files for SoQt library.
@@ -113,7 +140,8 @@ cd builddir
        -DSOQT_BUILD_DOCUMENTATION=ON \
        -DSOQT_BUILD_DOC_MAN=ON \
 %endif
-       %{?with_qt4:-DSOQT_USE_QT5=OFF}
+       %{!?with_qt5:-DSOQT_USE_QT5=OFF} \
+       %{!?with_qt6:-DSOQT_USE_QT6=OFF}
 
 %{__make}
 cd ..
@@ -123,7 +151,8 @@ install -d builddir-static
 cd builddir-static
 %cmake .. \
        -DSOQT_BUILD_SHARED_LIBS=OFF \
-       %{?with_qt4:-DSOQT_USE_QT5=OFF}
+       %{!?with_qt5:-DSOQT_USE_QT5=OFF} \
+       %{!?with_qt6:-DSOQT_USE_QT6=OFF}
 
 %{__make}
 cd ..
@@ -146,8 +175,6 @@ rm -rf $RPM_BUILD_ROOT
 # to common names etc.
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{_*_,components,devices,misc,viewers}.3
 %endif
-# bogus location
-%{__rm} -r $RPM_BUILD_ROOT%{_infodir}/SoQt1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.088819 seconds and 4 git commands to generate.