]> git.pld-linux.org Git - packages/SoQt.git/blob - SoQt.spec
- updated to 1.6.2, added qt6 bcond
[packages/SoQt.git] / SoQt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Qt GUI component toolkit library for Coin
6 Summary(pl.UTF-8):      Biblioteka komponentu graficznego interfejsu Qt dla biblioteki Coin
7 Name:           SoQt
8 Version:        1.5.0
9 Release:        3
10 License:        GPL v2 or Coin PEL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  9f1e582373d66f556b1db113a93ac68e
14 Patch0:         %{name}-pc.patch
15 URL:            http://www.coin3d.org/lib/soqt/
16 BuildRequires:  Coin-devel
17 BuildRequires:  OpenGL-GLX-devel
18 BuildRequires:  QtCore-devel >= 4
19 BuildRequires:  QtGui-devel >= 4
20 BuildRequires:  QtOpenGL-devel >= 4
21 BuildRequires:  automake
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  qt4-build >= 4
25 BuildRequires:  sed >= 4.0
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  xorg-lib-libXext-devel
28 BuildRequires:  xorg-lib-libXmu-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 SoQt is a Qt GUI component toolkit library for Coin. It is also
33 compatible with SGI and TGS Open Inventor, and the API is based on the
34 API of the InventorXt GUI component toolkit.
35
36 %description -l pl.UTF-8
37 SoQt to biblioteka toolkitu komponentu graficznego interfejsu
38 użytkownika (GUI) Qt dla biblioteki Coin. Jest zgodna także z
39 biblioteką SGI i TGS Open Inventor, a API jest oparte na API toolkitu
40 komponentu graficznego interfejsu użytkownika InventorXt.
41
42 %package devel
43 Summary:        Header files for SoQt library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SoQt
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       Coin-devel
48 Requires:       OpenGL-GLX-devel
49 Requires:       QtCore-devel >= 4
50
51 %description devel
52 Header files for SoQt library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki SoQt.
56
57 %package static
58 Summary:        Static SoQt library
59 Summary(pl.UTF-8):      Statyczna biblioteka SoQt
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description static
64 Static SoQt library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka SoQt.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 # -DHAVE_GLX is not passed properly from configure
75 CXXFLAGS="%{rpmcxxflags} -DHAVE_GLX"
76 %configure \
77         %{?with_static_libs:--enable-static}
78
79 # GL is missing; cannot rebuild auto* because of missing m4 files
80 %{__sed} -i -e '/^LIBS =/s/$/ -lGL/' src/Inventor/Qt/Makefile
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # obsoleted by pkg-config
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libSoQt.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS BUGS.txt COPYING ChangeLog FAQ NEWS README
102 %attr(755,root,root) %{_libdir}/libSoQt.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libSoQt.so.20
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libSoQt.so
108 %attr(755,root,root) %{_bindir}/soqt-config
109 %{_includedir}/Inventor/Qt
110 %{_pkgconfigdir}/SoQt.pc
111 %{_aclocaldir}/soqt.m4
112 %{_datadir}/Coin/conf/soqt-default.cfg
113 %{_mandir}/man1/soqt-config.1*
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libSoQt.a
119 %endif
This page took 0.062378 seconds and 3 git commands to generate.