]> git.pld-linux.org Git - packages/SaWMan.git/commitdiff
- updated to 1.4.10
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 18 Nov 2010 20:14:03 +0000 (20:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added update patch to fix build with current DirectFB

Changed files:
    SaWMan-update.patch -> 1.1
    SaWMan.spec -> 1.3

SaWMan-update.patch [new file with mode: 0644]
SaWMan.spec

diff --git a/SaWMan-update.patch b/SaWMan-update.patch
new file mode 100644 (file)
index 0000000..3aca90d
--- /dev/null
@@ -0,0 +1,20 @@
+--- SaWMan-1.4.10/src/sawman.c.orig    2010-11-03 13:05:31.000000000 +0100
++++ SaWMan-1.4.10/src/sawman.c 2010-11-18 20:55:46.827104966 +0100
+@@ -139,7 +139,7 @@
+ #if !DIRECTFB_BUILD_PURE_VOODOO
+      if (dfb_config->remote.host)
+-          return CreateRemote( dfb_config->remote.host, dfb_config->remote.session, ret_sawman );
++          return CreateRemote( dfb_config->remote.host, dfb_config->session, ret_sawman );
+      CoreDFB *core;
+@@ -163,7 +163,7 @@
+      return DFB_OK;
+ #else
+-     return CreateRemote( dfb_config->remote.host ?: "", dfb_config->remote.session, ret_sawman );
++     return CreateRemote( dfb_config->remote.host ?: "", dfb_config->session, ret_sawman );
+ #endif
+ }
index fa9dc921a769089d01ca26280f4438d922559d4a..acd3cdaae4921efc048043bb4bc988b6c6cd098d 100644 (file)
@@ -1,19 +1,21 @@
 Summary:       Shared application and Window Manager
 Summary(pl.UTF-8):     Zarządca współdzielonych aplikacji i okien
 Name:          SaWMan
-Version:       1.2.0
-%define        subver  rc1
+Version:       1.4.10
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: 95dfb3bb0a588e486eed3fef28fa3644
+Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
+# Source0-md5: a56cb8a12246e041070d2ae87021e24d
+Patch0:                %{name}-update.patch
 URL:           http://www.directfb.org/index.php?path=Platform/SaWMan
-BuildRequires: DirectFB-devel >= 1:1.2.0
+BuildRequires: DirectFB-devel >= 1:1.4.0
 BuildRequires: pkgconfig >= 1:0.9
 %requires_eq   DirectFB
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                dfblibdir       %{_libdir}/directfb-1.4-5
+
 %description
 SaWMan is a new window manager module for use with DirectFB. Its main
 difference to the default module is that it allows one process to be
@@ -31,7 +33,7 @@ Summary:      Header files for sawman library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki sawman
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      DirectFB-devel >= 1:1.2.0
+Requires:      DirectFB-devel >= 1:1.4.0
 
 %description devel
 Header files for sawman library.
@@ -52,7 +54,8 @@ Static sawman library.
 Statyczna biblioteka sawman.
 
 %prep
-%setup -q -n %{name}-%{version}-%{subver}
+%setup -q
+%patch0 -p1
 
 %build
 %configure \
@@ -73,11 +76,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
+%doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/swmdump
-%attr(755,root,root) %{_libdir}/libsawman-1.2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsawman-1.2.so.0
-%attr(755,root,root) %{_libdir}/directfb-1.2-0/wm/libdirectfbwm_sawman.so
+%attr(755,root,root) %{_libdir}/libsawman-1.4.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsawman-1.4.so.5
+%attr(755,root,root) %{dfblibdir}/wm/libdirectfbwm_sawman.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -89,4 +92,4 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libsawman.a
-%{_libdir}/directfb-1.2-0/wm/libdirectfbwm_sawman.[aol]*
+%{dfblibdir}/wm/libdirectfbwm_sawman.[aol]*
This page took 0.121422 seconds and 4 git commands to generate.