]> git.pld-linux.org Git - packages/STonX.git/blob - STonX.spec
cd7f00142878f78caba3b909c222ca6508b684c4
[packages/STonX.git] / STonX.spec
1 #
2 # Conditional build:
3 %bcond_without  svga    # without svgalib support
4 #
5 %define         tosarchname     tos206us.zip
6 %define         tosfilename     Tos206.img
7
8 Summary:        Atari ST on Unix/X
9 Summary(pl):    Atari ST pod Uniksem/X
10 Name:           STonX
11 Version:        0.6.5
12 Release:        1
13 License:        GPL (except TOS image)
14 Group:          Applications/Emulators
15 Source0:        http://www.complang.tuwien.ac.at/nino/stonx/%{name}-%{version}.tar.gz
16 # Source0-md5:  54ce49f5a64f0e7779000245a9b903a6
17 # to use TOS image legally, one probably must own real Atari ST...
18 Source1:        %{tosarchname}
19 NoSource:       1
20 Patch0:         %{name}-nox.patch
21 Patch1:         %{name}-svga.patch
22 URL:            http://www.complang.tuwien.ac.at/nino/stonx.html
23 BuildRequires:  XFree86-devel
24 BuildRequires:  autoconf
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 %{?with_svga:BuildRequires:     svgalib-devel}
27 BuildRequires:  unzip
28 Requires(post,postun):  fontpostinst
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 STonX is a software emulator, which runs on Unix workstations with the
33 X Window system%{?with_svga: or svgalib}, and emulates an Atari ST
34 computer.
35
36 %description -l pl
37 STonX jest programowym emulatorem komputera Atari ST, dzia³aj±cym na
38 Uniksach z X Window System%{?with_svga: lub svgalib}.
39
40 %prep
41 %setup -q -a1
42 %patch0 -p1
43 %patch1 -p1
44
45 mv -f %{tosfilename} tos.img
46
47 %build
48 %{__autoconf}
49 %configure
50
51 %{__make} \
52         OPT="%{rpmcflags}" \
53         REGS="%{!?debug:-fomit-frame-pointer}" \
54         %{?with_svga:USE_SVGALIB=1}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_libdir}/STonX,%{_bindir},%{_fontsdir}/misc}
59
60 install stonx tos.img cartridge.img Keysyms $RPM_BUILD_ROOT%{_libdir}/STonX
61
62 gzip -9nf data/*.pcf
63 install data/*.pcf.gz $RPM_BUILD_ROOT%{_fontsdir}/misc
64
65 cat > $RPM_BUILD_ROOT%{_bindir}/stonx <<'EOF'
66 #!/bin/sh
67 cd %{_libdir}/STonX
68
69 %{?with_svga:if [ -z "$DISPLAY" ]; then exec ./stonx -svga ; fi}
70 exec ./stonx
71 EOF
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 fontpostinst misc
78
79 %postun
80 fontpostinst misc
81
82 %files
83 %defattr(644,root,root,755)
84 %doc docs/{PROGRAMS,README,RELEASE_NOTES,TOS-VERSIONS}
85 %attr(755,root,root) %{_bindir}/*
86 %dir %{_libdir}/STonX
87 %attr(755,root,root) %{_libdir}/STonX/stonx
88 %{_libdir}/STonX/*.img
89 %{_libdir}/STonX/Keysyms
90 %{_fontsdir}/misc/*.pcf.gz
This page took 0.032346 seconds and 2 git commands to generate.