]> git.pld-linux.org Git - packages/STonX.git/blob - STonX.spec
bc60de85f3eb5ef8afcb65e2da863f178c938417
[packages/STonX.git] / STonX.spec
1 #
2 # Conditional build:
3 # _without_svga         without svgalib support
4 #
5
6 %ifnarch %{ix86} alpha
7 %define _without_svga 1
8 %endif
9
10 %define         tosarchname     tos206us.zip
11 %define         tosfilename     Tos206.img
12
13 Summary:        Atari ST on Unix/X
14 Summary(pl):    Atari ST pod Uniksem/X
15 Name:           STonX
16 Version:        0.6.5
17 Release:        1
18 License:        GPL (except TOS image)
19 Group:          Applications/Emulators
20 Source0:        http://www.complang.tuwien.ac.at/nino/stonx/%{name}-%{version}.tar.gz
21 # Source0-md5:  54ce49f5a64f0e7779000245a9b903a6
22 # to use TOS image legally, one probably must own real Atari ST...
23 Source1:        %{tosarchname}
24 NoSource:       1
25 Patch0:         %{name}-nox.patch
26 Patch1:         %{name}-svga.patch
27 URL:            http://www.complang.tuwien.ac.at/nino/stonx.html
28 BuildRequires:  XFree86-devel
29 %{!?_without_svga:BuildRequires:        svgalib-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  unzip
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34
35 %description
36 STonX is a software emulator, which runs on Unix workstations with the
37 X Window system%{!?_without_svga: or svgalib}, and emulates an Atari ST computer.
38
39 %description -l pl
40 STonX jest programowym emulatorem komputera Atari ST, dzia³aj±cym na
41 Uniksach z X Window System%{!?_without_svga: lub svgalib}.
42
43 %prep
44 %setup -q -a1
45 %patch0 -p1
46 %patch1 -p1
47
48 mv -f %{tosfilename} tos.img
49
50 %build
51 %{__autoconf}
52 %configure
53
54 %{__make} \
55         OPT="%{rpmcflags}" \
56         REGS="%{!?debug:-fomit-frame-pointer}" \
57         %{!?_without_svga:USE_SVGALIB=1}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_libdir}/STonX,%{_bindir},%{_fontsdir}/misc}
62
63 install stonx tos.img cartridge.img Keysyms $RPM_BUILD_ROOT%{_libdir}/STonX
64
65 gzip -9nf data/*.pcf
66 install data/*.pcf.gz $RPM_BUILD_ROOT%{_fontsdir}/misc
67
68 cat > $RPM_BUILD_ROOT%{_bindir}/stonx <<EOF
69 #!/bin/sh
70 cd %{_libdir}/STonX
71
72 %{!?_without_svga:if [ -z "\$DISPLAY" ]; then exec ./stonx -svga ; fi}
73 exec ./stonx
74 EOF
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 if [ -x /usr/X11R6/bin/mkfontdir ]; then
81         (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
82 fi
83 if [ -f /var/lock/subsys/xfs ]; then
84         /etc/rc.d/init.d/xfs reload
85 fi
86
87 %postun
88 if [ -x /usr/X11R6/bin/mkfontdir ]; then
89         (cd /usr/share/fonts/misc; /usr/X11R6/bin/mkfontdir)
90 fi
91 if [ -f /var/lock/subsys/xfs ]; then
92         /etc/rc.d/init.d/xfs reload
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %doc docs/{PROGRAMS,README,RELEASE_NOTES,TOS-VERSIONS}
98 %attr(755,root,root) %{_bindir}/*
99 %dir %{_libdir}/STonX
100 %attr(755,root,root) %{_libdir}/STonX/stonx
101 %{_libdir}/STonX/*.img
102 %{_libdir}/STonX/Keysyms
103 %{_fontsdir}/misc/*
This page took 0.042653 seconds and 2 git commands to generate.