]> git.pld-linux.org Git - packages/STonX.git/blame_incremental - STonX.spec
- tabs in preamble
[packages/STonX.git] / STonX.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without svga # without svgalib support
4#
5%define tosarchname tos206us.zip
6%define tosfilename Tos206.img
7
8Summary: Atari ST on Unix/X
9Summary(pl.UTF-8): Atari ST pod Uniksem/X
10Name: STonX
11Version: 0.6.5
12Release: 2
13License: GPL (except TOS image)
14Group: Applications/Emulators
15Source0: http://www.complang.tuwien.ac.at/nino/stonx/%{name}-%{version}.tar.gz
16# Source0-md5: 54ce49f5a64f0e7779000245a9b903a6
17# to use TOS image legally, one probably must own real Atari ST...
18Source1: %{tosarchname}
19NoSource: 1
20Patch0: %{name}-nox.patch
21Patch1: %{name}-svga.patch
22Patch2: %{name}-link.patch
23Patch3: %{name}-segv.patch
24URL: http://www.complang.tuwien.ac.at/nino/stonx.html
25BuildRequires: autoconf >= 2.59-9
26BuildRequires: rpmbuild(macros) >= 1.268
27%{?with_svga:BuildRequires: svgalib-devel}
28BuildRequires: unzip
29BuildRequires: xorg-lib-libXext-devel
30Requires(post,postun): fontpostinst
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34STonX is a software emulator, which runs on Unix workstations with the
35X Window system%{?with_svga: or svgalib}, and emulates an Atari ST
36computer.
37
38%description -l pl.UTF-8
39STonX jest programowym emulatorem komputera Atari ST, działającym na
40Uniksach z X Window System%{?with_svga: lub svgalib}.
41
42%prep
43%setup -q -a1
44%patch0 -p1
45%patch1 -p1
46%patch2 -p1
47%patch3 -p1
48
49mv -f %{tosfilename} tos.img
50
51%build
52%{__autoconf}
53%configure
54
55%{__make} \
56 OPT="%{rpmcflags}" \
57 REGS="%{!?debug:-fomit-frame-pointer}" \
58 %{?with_svga:USE_SVGALIB=1}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62install -d $RPM_BUILD_ROOT{%{_libdir}/STonX,%{_bindir},%{_fontsdir}/misc}
63
64install stonx tos.img cartridge.img Keysyms $RPM_BUILD_ROOT%{_libdir}/STonX
65
66gzip -9nf data/*.pcf
67install data/*.pcf.gz $RPM_BUILD_ROOT%{_fontsdir}/misc
68
69cat > $RPM_BUILD_ROOT%{_bindir}/stonx <<'EOF'
70#!/bin/sh
71cd %{_libdir}/STonX
72
73%{?with_svga:if [ -z "$DISPLAY" ]; then exec ./stonx -svga ; fi}
74exec ./stonx
75EOF
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post
81fontpostinst misc
82
83%postun
84fontpostinst misc
85
86%files
87%defattr(644,root,root,755)
88%doc docs/{PROGRAMS,README,RELEASE_NOTES,TOS-VERSIONS}
89%attr(755,root,root) %{_bindir}/*
90%dir %{_libdir}/STonX
91%attr(755,root,root) %{_libdir}/STonX/stonx
92%{_libdir}/STonX/*.img
93%{_libdir}/STonX/Keysyms
94%{_fontsdir}/misc/*.pcf.gz
This page took 0.053542 seconds and 4 git commands to generate.