]> git.pld-linux.org Git - packages/SPQR.git/blob - SPQR.spec
- release 4 (by relup.sh)
[packages/SPQR.git] / SPQR.spec
1 Summary:        SuiteSparseQR: multithreaded multifrontal sparse QR factorization
2 Summary(pl.UTF-8):      SuiteSparseQR - wielowątkowy, wielofrontalny rozkład QR dla macierzy rzadkich
3 Name:           SPQR
4 Version:        1.3.3
5 Release:        4
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/SPQR/%{name}-%{version}.tar.gz
9 # Source0-md5:  bdd05fa144f68fe318510888a89e9906
10 Patch0:         %{name}-ufconfig.patch
11 Patch1:         %{name}-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/SPQR/
13 BuildRequires:  CHOLMOD-devel >= 2.0.0
14 BuildRequires:  SuiteSparse_config-devel >= 4.0.0
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 Requires:       CHOLMOD >= 2.0.0
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 SuiteSparseQR is an implementation of the multifrontal sparse QR
22 factorization method. Parallelism is exploited both in the BLAS and
23 across different frontal matrices using Intel's Threading Building
24 Blocks, a shared-memory programming model for modern multicore
25 architectures. It can obtain a substantial fraction of the theoretical
26 peak performance of a multicore computer. The package is written in
27 C++ with user interfaces for MATLAB, C, and C++.
28
29 %description -l pl.UTF-8
30 SuiteSparseQR to implementacja wielofrontalnej metody rozkładu QR dla
31 macierzy rzadkich. Równoległość jest wykorzystywna zarówno w BLAS, jak
32 i poprzez różne macierze frontalne przy użyciu Threading Building
33 Blocks Intela - model programowania ze współdzieloną pamięcią dla
34 architektur wielordzeniowych. Dzięki temu możliwe jest osiągnięcie
35 znaczącej części teoretycznej maksymalnej wydajności na komputerze
36 wielordzeniowym. Pakiet jest napisany w C++ z interfejsami dla
37 MATLAB-a, C i C++.
38
39 %package devel
40 Summary:        Header files for SPQR library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SPQR
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       CHOLMOD-devel >= 2.0.0
45 Requires:       SuiteSparse_config-devel >= 4.0.0
46 Requires:       libstdc++-devel
47
48 %description devel
49 Header files for SPQR library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki SPQR.
53
54 %package static
55 Summary:        Static SPQR library
56 Summary(pl.UTF-8):      Statyczna biblioteka SPQR
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static SPQR library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka SPQR.
65
66 %prep
67 %setup -q -n %{name}
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__make} \
73         CC="%{__cc}" \
74         CXX="%{__cxx}" \
75         CFLAGS="%{rpmcflags}" \
76         CXXFLAGS="%{rpmcxxflags}" \
77         LDFLAGS="%{rpmldflags}" \
78         libdir=%{_libdir}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_includedir}/spqr
83
84 %{__make} -C Lib install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         libdir=%{_libdir}
87
88 install Include/*.{h,hpp} $RPM_BUILD_ROOT%{_includedir}/spqr
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc README.txt Doc/ChangeLog
99 %attr(755,root,root) %{_libdir}/libspqr.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libspqr.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc Doc/{algo_spqr,spqr,spqr_user_guide}.pdf
105 %attr(755,root,root) %{_libdir}/libspqr.so
106 %{_libdir}/libspqr.la
107 %{_includedir}/spqr
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libspqr.a
This page took 0.056913 seconds and 3 git commands to generate.