]> git.pld-linux.org Git - packages/SDL.git/commitdiff
- removed obsolete ac25x,noobjc,am17 patches auto/ac/SDL-1_2_6-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 5 Sep 2003 20:29:21 +0000 (20:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added dlopen-acfix patch (AC_ARG_ENABLE(dlopen ) and AC_PROG_LIBTOOL conflict)
- switched to new-style bconds, added _with_directfb
- don't disable arts on alpha (qt builds OK using gcc 3.x)
- libesd and libartsc are dlopened now, so *-devel are no longer R: by -devel

Changed files:
    SDL-ac25x.patch -> 1.4
    SDL-am17.patch -> 1.2
    SDL-dlopen-acfix.patch -> 1.1
    SDL-noobjc.patch -> 1.3
    SDL.spec -> 1.116

SDL-ac25x.patch [deleted file]
SDL-am17.patch [deleted file]
SDL-dlopen-acfix.patch [new file with mode: 0644]
SDL-noobjc.patch [deleted file]
SDL.spec

diff --git a/SDL-ac25x.patch b/SDL-ac25x.patch
deleted file mode 100644 (file)
index 19e4289..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nru SDL-1.2.4.orig/configure.in SDL-1.2.4/configure.in
---- SDL-1.2.5.orig/configure.in        Sun Apr 14 01:57:24 2002
-+++ SDL-1.2.5/configure.in     Wed Jul 31 10:04:28 2002
-@@ -1414,6 +1414,7 @@
-     fi
- }
-+AM_CONDITIONAL(USE_DIRECTX,false)
- case "$target" in
-     *-*-linux*)
-         ARCH=linux
diff --git a/SDL-am17.patch b/SDL-am17.patch
deleted file mode 100644 (file)
index 9c96f21..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Nru SDL-1.2.5.orig/src/video/ggi/Makefile.am SDL-1.2.5/src/video/ggi/Makefile.am
---- SDL-1.2.5.orig/src/video/ggi/Makefile.am   Thu Apr 26 18:45:46 2001
-+++ SDL-1.2.5/src/video/ggi/Makefile.am        Thu Apr 24 19:32:11 2003
-@@ -13,4 +13,4 @@
-       SDL_ggimouse.c          \
-       SDL_ggivideo.c          \
-       SDL_ggievents_c.h       \
--              SDL_ggimouse_c.h        \
-+              SDL_ggimouse_c.h
diff --git a/SDL-dlopen-acfix.patch b/SDL-dlopen-acfix.patch
new file mode 100644 (file)
index 0000000..5dd35da
--- /dev/null
@@ -0,0 +1,47 @@
+--- SDL-1.2.6/configure.in.orig        2003-09-05 20:48:37.000000000 +0200
++++ SDL-1.2.6/configure.in     2003-09-05 21:10:36.881227832 +0200
+@@ -336,11 +336,11 @@
+             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
+             esd_lib=`ls $esd_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
+             echo "-- $esd_lib_spec -> $esd_lib"
+-            if test x$enable_dlopen != xyes && \
++            if test x$enable_sdlopen != xyes && \
+                test x$enable_esd_shared = xyes; then
+-                AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
++                AC_MSG_ERROR([You must have dlopen() support and use the --enable-sdlopen option])
+             fi
+-            if test x$enable_dlopen = xyes && \
++            if test x$enable_sdlopen = xyes && \
+                test x$enable_esd_shared = xyes && test x$esd_lib != x; then
+                 CFLAGS="$CFLAGS -DESD_SUPPORT -DESD_DYNAMIC=\$(esd_lib) $ESD_CFLAGS"
+                 AC_SUBST(esd_lib)
+@@ -386,11 +386,11 @@
+                 arts_lib_spec=`echo $ARTSC_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libartsc.so.*/'`
+                 arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
+                 echo "-- $arts_lib_spec -> $arts_lib"
+-                if test x$enable_dlopen != xyes && \
++                if test x$enable_sdlopen != xyes && \
+                    test x$enable_arts_shared = xyes; then
+-                    AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
++                    AC_MSG_ERROR([You must have dlopen() support and use the --enable-sdlopen option])
+                 fi
+-                if test x$enable_dlopen = xyes && \
++                if test x$enable_sdlopen = xyes && \
+                    test x$enable_arts_shared = xyes && test x$arts_lib != x; then
+                     CFLAGS="$CFLAGS -DARTSC_SUPPORT -DARTSC_DYNAMIC=\$(arts_lib) $ARTSC_CFLAGS"
+                     AC_SUBST(arts_lib)
+@@ -1557,10 +1557,10 @@
+ dnl Check for the dlfcn.h interface for dynamically loading objects
+ CheckDLOPEN()
+ {
+-    AC_ARG_ENABLE(dlopen,
+-[  --enable-dlopen         use dlopen for shared object loading [default=no]],
+-                  , enable_dlopen=yes)
+-    if test x$enable_dlopen = xyes; then
++    AC_ARG_ENABLE(sdlopen,
++[  --enable-sdlopen         use dlopen for shared object loading [default=no]],
++                  , enable_sdlopen=yes)
++    if test x$enable_sdlopen = xyes; then
+         AC_MSG_CHECKING(for dlopen)
+         use_dlopen=no
+         AC_TRY_COMPILE([
diff --git a/SDL-noobjc.patch b/SDL-noobjc.patch
deleted file mode 100644 (file)
index 7235241..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -aurN SDL-1.2.orig/configure.in SDL-1.2/configure.in
---- SDL-1.2.orig/configure.in  2003-05-29 07:05:06.000000000 +0200
-+++ SDL-1.2/configure.in       2003-07-21 23:21:20.000000000 +0200
-@@ -2570,18 +2570,6 @@
- CXXFLAGS="$CFLAGS"
--# Check for darwin at the very end and set up the Objective C compiler
--# We do this here so that we get the full CFLAGS into OBJCFLAGS
--case "$target" in
--    *-*-darwin*)
--        OBJC="cc"
--        OBJCFLAGS="$CFLAGS"
--        OBJCDEPMODE="$CCDEPMODE"
--        AC_SUBST(OBJC)
--        AC_SUBST(OBJCFLAGS)
--        AC_SUBST(OBJCDEPMODE)
--        ;;
--esac
- # Finally create all the generated files
- dnl Important: Any directory that you want to be in the distcheck should
-@@ -2638,7 +2626,6 @@
- src/video/picogui/Makefile
- src/video/ps2gs/Makefile
- src/video/qtopia/Makefile
--src/video/quartz/Makefile
- src/video/svga/Makefile
- src/video/vgl/Makefile
- src/video/wincommon/Makefile
-diff -aurN SDL-1.2.orig/src/main/Makefile.am SDL-1.2/src/main/Makefile.am
---- SDL-1.2.orig/src/main/Makefile.am  2002-05-19 22:06:01.000000000 +0200
-+++ SDL-1.2/src/main/Makefile.am       2003-07-21 23:20:21.000000000 +0200
-@@ -14,15 +14,11 @@
- # Build a separate library containing the main() entry point.
- lib_LIBRARIES = libSDLmain.a
--if TARGET_MACOSX
--MAINLIB_ARCH_SRCS = SDLMain.m SDLMain.h
--else
- if TARGET_QTOPIA
- MAINLIB_ARCH_SRCS = SDL_Qtopia_main.cc
- else
- MAINLIB_ARCH_SRCS = SDL_main.c
- endif
--endif
- libSDLmain_a_SOURCES = $(MAINLIB_ARCH_SRCS)
- # Build an internal library of any special app setup functions
index 8ff882e5cb37709ba67f07e9792e53486352e77b..181a53227109cb2d4fe31670dcb704cd63de1bfb 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
@@ -1,18 +1,14 @@
 #
 # Conditional build:
-# _with_aalib - with aalib support
-# _with_ggi - with GGI support
-# _with_nas - with NAS audio support
-# _with_svga - with svgalib support
+%bcond_with    aalib           # with aalib graphics support
+%bcond_with    directfb        # with DirectFB graphics support
+%bcond_with    ggi             # with GGI graphics support
+%bcond_with    nas             # with NAS audio support
+%bcond_with    svga            # with svgalib graphics support
+%bcond_without alsa            # without ALSA audio support
+%bcond_without arts            # without aRts audio support
+%bcond_without esound          # without EsounD audio support
 #
-# _without_alsa - without ALSA support
-# _without_arts - without arts support
-# _without_esound - without esound support
-#
-%ifarch        alpha
-%define        _without_arts 1
-%endif
-
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Summary(es):   Simple DirectMedia Layer
 Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediĆ³w
@@ -31,30 +27,33 @@ Patch0:             %{name}-byteorder.patch
 Patch1:                %{name}-fixlibs.patch
 Patch2:                %{name}-amfix.patch
 Patch3:                %{name}-lpthread.patch
-Patch4:                %{name}-ac25x.patch
-Patch5:                %{name}-no_rpath_in_sdl-config.patch
-Patch6:                %{name}-noobjc.patch
-Patch7:                %{name}-am17.patch
-Patch8:                %{name}-lt15.patch
+Patch4:                %{name}-no_rpath_in_sdl-config.patch
+Patch5:                %{name}-lt15.patch
+Patch6:                %{name}-dlopen-acfix.patch
+#Patch4:               %{name}-ac25x.patch
+#Patch6:               %{name}-noobjc.patch
+#Patch7:               %{name}-am17.patch
 URL:           http://www.libsdl.org/
+%{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.15}
 BuildRequires: OpenGL-devel
 BuildRequires: XFree86-devel >= 4.0.2
-%{?_with_aalib:BuildRequires:  aalib-devel}
+%{?with_aalib:BuildRequires:   aalib-devel}
 %ifnarch sparc sparc64
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
 %endif
-%{!?_without_arts:BuildRequires:       arts-devel >= 1.1}
+%{?with_arts:BuildRequires:    arts-devel >= 1.1}
 BuildRequires: autoconf
 BuildRequires: automake
-%{!?_without_esound:BuildRequires:     esound-devel}
-%{?_with_ggi:BuildRequires:    libggi-devel}
+%{?with_esound:BuildRequires:  esound-devel >= 0.2.8}
+%{?with_ggi:BuildRequires:     libggi-devel}
 BuildRequires: libtool >= 2:1.4d
-%{?_with_nas:BuildRequires:    nas-devel}
+%{?with_nas:BuildRequires:     nas-devel}
 %ifarch %{ix86}
 BuildRequires: nasm
 %endif
 BuildRequires: perl-modules
-%{?_with_svgalib:BuildRequires:        svgalib-devel}
+%{?with_directfb:BuildRequires:        pkgconfig >= 0.7}
+%{?with_svgalib:BuildRequires: svgalib-devel >= 1.4.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -88,11 +87,9 @@ Group:               X11/Development/Libraries
 Requires:      %{name} = %{version}
 Requires:      XFree86-devel >= 4.0.2
 %ifnarch sparc sparc64
-%{!?_without_alsa:Requires:    alsa-lib-devel}
+%{?with_alsa:Requires: alsa-lib-devel}
 %endif
-%{!?_without_arts:Requires:    arts-devel}
-%{!?_without_esound:Requires:  esound-devel}
-%{?_with_nas:Requires: nas-devel}
+%{?with_nas:Requires:  nas-devel}
 
 %description devel
 SDL - Header files.
@@ -158,9 +155,7 @@ SDL - przyk
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-#%%patch6 -p1
-#%%patch7 -p1
-%patch8 -p1
+%patch6 -p1
 
 # get COPY_ARCH_SRC, remove the rest
 head -n 16 acinclude.m4 > acinclude.tmp
@@ -184,22 +179,20 @@ rm -f missing libtool
        --enable-pthread-sem \
        --with-x \
        --enable-dga \
+       %{?with_aalib:--enable-video-aalib} \
        --enable-video-dga \
-       --disable-video-directfb \
+       %{?with_directfb:--enable-video-directfb} \
+       --enable-video-fbcon \
+       %{?with_ggi:--enable-video-ggi} \
+       --enable-video-opengl \
+       %{?with_svga:--enable-video-svga} \
        --enable-video-x11-dgamouse \
        --enable-video-x11-vm \
        --enable-video-x11-xv \
-       --enable-video-opengl \
-       --enable-video-fbcon \
-       %{?_with_aalib:--enable-video-aalib} \
-       %{?_with_ggi:--enable-video-ggi} \
-       %{!?_with_nas:--disable-nas} \
-       %{?_with_svga:--enable-video-svga} \
-       %{?_without_alsa:--disable-alsa} \
-       %{!?_without_esound:--enable-esd} \
-       %{?_without_esound:--disable-esd} \
-       %{!?_without_arts:--enable-arts} \
-       %{?_without_arts:--disable-arts}
+       %{!?with_alsa:--disable-alsa} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_esound:--disable-esd} \
+       %{!?with_nas:--disable-nas}
 
 %{__make}
 
@@ -223,11 +216,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%doc BUGS CREDITS README TODO WhatsNew
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc BUGS CREDITS README TODO WhatsNew docs.html docs
+%doc docs.html docs
 %attr(755,root,root) %{_bindir}/sdl-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
This page took 0.138045 seconds and 4 git commands to generate.