]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- quick workaround for gcc PR21398.
[packages/SDL.git] / SDL.spec
index fd52dc59372b6229d12362d75bb5f7b42cb2c59f..8f80f36278b5eea8edb13f47f759f0d7386d4555 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
@@ -1,38 +1,54 @@
 #
 # Conditional build:
-# bcond_off_alsa - without ALSA support
-# bcond_off_esound - without esound support
-# bcond_off_arts - without arts support
-# bcond_on_svgalib - with svgalib support
-# bcond_on_aalib - with aalib support
+%bcond_with    aalib           # with aalib graphics support
+%bcond_with    caca            # with caca graphics support
+%bcond_with    directfb        # with DirectFB graphics support
+%bcond_with    ggi             # with GGI graphics support
+%bcond_with    nas             # with NAS audio support
+%bcond_with    svga            # with svgalib graphics support
+%bcond_without alsa            # without ALSA audio support
+%bcond_without arts            # without aRts audio support
+%bcond_without esd             # without EsounD audio support
 #
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
+Summary(zh_CN):        SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
 Name:          SDL
-Version:       1.1.8
-Release:       3
+Version:       1.2.8
+Release:       2
 License:       LGPL
 Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(pl):     X11/Biblioteki
 Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
-Patch0:                SDL-svga.patch
+# Source0-md5: 37aaf9f069f9c2c18856022f35de9f8c
+Patch0:                %{name}-byteorder.patch
+Patch1:                %{name}-amfix.patch
+Patch2:                %{name}-lpthread.patch
+Patch3:                %{name}-no_rpath_in_sdl-config.patch
+Patch4:                %{name}-mmx-constraints.patch
+Patch5:                %{name}-caca.patch
+Patch6:                %{name}-gcc4.patch
+Patch7:                %{name}-gcc-pr21398-workaround.patch
 URL:           http://www.libsdl.org/
-%{!?bcond_off_esound:BuildRequires:    esound-devel}
-%{!?bcond_off_arts:BuildRequires:      arts-devel}
-BuildRequires: gtk+-devel >= 1.2.1
-BuildRequires: XFree86-devel
+%{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.15}
 BuildRequires: OpenGL-devel
-%ifnarch sparc sparc64
-%{!?bcond_off_alsa:BuildRequires:      alsa-lib-devel}
+%{?with_aalib:BuildRequires:   aalib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
+%{?with_arts:BuildRequires:    artsc-devel >= 1.1}
+BuildRequires: autoconf
+BuildRequires: automake
+%{?with_esd:BuildRequires:     esound-devel >= 0.2.8}
+%{?with_caca:BuildRequires:    libcaca-devel}
+%{?with_ggi:BuildRequires:     libggi-devel}
+BuildRequires: libtool >= 2:1.4d
+%{?with_nas:BuildRequires:     nas-devel}
+%ifarch %{ix86}
+BuildRequires: nasm
 %endif
-%{?bcond_on_svgalib:BuildRequires:     svgalib-devel}
-%{?bcond_on_aalib:BuildRequires:       aalib-devel}
+BuildRequires: perl-modules
+%{?with_directfb:BuildRequires:        pkgconfig >= 1:0.7}
+%{?with_svgalib:BuildRequires: svgalib-devel >= 1.4.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 SDL (Simple DirectMedia Layer) is a library that allows you portable,
 low level access to a video framebuffer, audio output, mouse, and
@@ -42,92 +58,184 @@ be built on Win32 and BeOS.
 
 %description -l pl
 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
-przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
-myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
+przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
+myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
-konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
+konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
+
+%description -l pt_BR
+Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
+baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
+
+Essa biblioteca é usada por alguns jogos.
 
 %package devel
 Summary:       SDL - Header files
 Summary(pl):   SDL - Pliki nag³ówkowe
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(pl):     X11/Biblioteki
-Requires:      %{name} = %{version}
+Summary(pt_BR):        Bibliotecas e arquivos de cabeçalho para aplicações SDL
+Summary(ru):   æÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ, ÉÓÐÏÌØÚÕÀÝÉÈ SDL
+Summary(uk):   æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
+Summary(zh_CN):        SDL (Simple DirectMedia Layer) ¿ª·¢¿â
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+%if %{with xlibs}
+Requires:      libX11-devel
+Requires:      libXext-devel
+%else
+Requires:      XFree86-devel >= 4.0.2
+%endif
+%{?with_alsa:Requires: alsa-lib-devel}
+%{?with_caca:Requires: libcaca-devel}
+%{?with_nas:Requires:  nas-devel}
 
 %description devel
 SDL - Header files.
 
-%description -l pl devel
+%description devel -l pl
 SDL - Pliki nag³ówkowe.
 
+%description devel -l pt_BR
+Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
+recursos para o desenvolvimento de aplicativos com SDL.
+
+%description devel -l ru
+üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
+ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
+
+%description devel -l uk
+ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
+×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
+
 %package static
 Summary:       SDL - static libraries
 Summary(pl):   SDL - biblioteki statyczne
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(pl):     X11/Biblioteki
-Requires:      %{name} = %{version}
+Summary(pt_BR):        Biblioteca estática para desenvolvimento de aplicações com a SDL
+Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
+Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
+Group:         X11/Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 SDL - static libraries.
 
-%description -l pl static
+%description static -l pl
 SDL - biblioteki statyczne.
 
+%description static -l pt_BR
+Biblioteca estática para desenvolvimento de aplicações com a SDL.
+
+%description static -l ru
+üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
+ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
+
+%description static -l uk
+ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
+×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
+
+%package examples
+Summary:       SDL - example programs
+Summary(pl):   SDL - programy przyk³adowe
+Group:         X11/Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description examples
+SDL - example programs.
+
+%description examples -l pl
+SDL - przyk³adowe programy.
+
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+
+# get COPY_ARCH_SRC, remove the rest
+head -n 20 acinclude.m4 > acinclude.tmp
+mv -f acinclude.tmp acinclude.m4
+
+find . -type d -name CVS -print | xargs rm -rf {} \;
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__automake}
+%{__autoconf}
+CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
 %configure \
-%ifnarch sparc sparc64
-       %{!?bcond_off_alsa:--enable-alsa} \
-%endif
+%ifarch %{ix86}
        --enable-nasm \
+%else
+       --disable-nasm \
+%endif
        --enable-pthreads \
+       --enable-pthread-sem \
        --with-x \
-       --enable-video-x11-dga \
-       --enable-video-x11-mtrr \
+       --enable-dga \
+       %{?with_aalib:--enable-video-aalib} \
+       %{?with_caca:--enable-video-caca} \
+       --enable-video-dga \
+       %{?with_directfb:--enable-video-directfb} \
+       --enable-video-fbcon \
+       %{?with_ggi:--enable-video-ggi} \
+       --enable-video-opengl \
+       %{?with_svga:--enable-video-svga} \
        --enable-video-x11-dgamouse \
-       %{!?bcond_off_esound:--enable-esd} \
-       %{!?bcond_off_arts:--enable-arts} \
-       --disable-alsa \
-       %{?bcond_on_svga:--enable-video-svga} \
-       %{?bcond_on_aalib:--enable-video-aalib}
+       --enable-video-x11-vm \
+       --enable-video-x11-xv \
+       %{!?with_alsa:--disable-alsa} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_esd:--disable-esd} \
+       %{!?with_nas:--disable-nas}
+
+# automake chooses to use CXXLINK because of seen unused C++ sources
+# (which are for BeOS and MacOS+QTopia, not Linux)
+%{__make} \
+       CXXLINK="\$(LINK)"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        m4datadir=%{_aclocaldir}
 
-rm -rf docs/man3
+install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-gzip -9nf BUGS README WhatsNew
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+rm -rf docs/man3 docs/{Makefile*,.cvsignore} docs/html/{Makefile*,.cvsignore}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
+%doc BUGS CREDITS README TODO WhatsNew
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc *gz docs.html docs
+%doc docs.html docs
 %attr(755,root,root) %{_bindir}/sdl-config
 %attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/lib*.la
 %{_libdir}/libSDLmain.a
 %{_includedir}/SDL
 %{_aclocaldir}/*
 %{_mandir}/man3/*
 
+%files examples
+%defattr(644,root,root,755)
+%{_examplesdir}/%{name}-%{version}
+
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libSDL.a
This page took 0.035678 seconds and 4 git commands to generate.