]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- quick workaround for gcc PR21398.
[packages/SDL.git] / SDL.spec
index c8200f5159bc3b6618f8533fe2a0737e8aed4583..8f80f36278b5eea8edb13f47f759f0d7386d4555 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
@@ -1,52 +1,54 @@
 #
 # Conditional build:
-# _without_alsa - without ALSA support
-# _without_esound - without esound support
-# _without_arts - without arts support
-# _with_svga - with svgalib support
-# _with_aalib - with aalib support
-# _with_ggi - with GGI support
+%bcond_with    aalib           # with aalib graphics support
+%bcond_with    caca            # with caca graphics support
+%bcond_with    directfb        # with DirectFB graphics support
+%bcond_with    ggi             # with GGI graphics support
+%bcond_with    nas             # with NAS audio support
+%bcond_with    svga            # with svgalib graphics support
+%bcond_without alsa            # without ALSA audio support
+%bcond_without arts            # without aRts audio support
+%bcond_without esd             # without EsounD audio support
 #
-%ifarch        alpha
-%define _without_arts 1
-%endif
-
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
-Summary(es):   Simple DirectMedia Layer
 Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
-Summary(pt_BR):        Simple DirectMedia Layer
+Summary(zh_CN):        SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
 Name:          SDL
-Version:       1.2.3
-Release:       7
+Version:       1.2.8
+Release:       2
 License:       LGPL
 Group:         X11/Libraries
 Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
+# Source0-md5: 37aaf9f069f9c2c18856022f35de9f8c
 Patch0:                %{name}-byteorder.patch
-Patch1:                %{name}-fixlibs.patch
-Patch2:                %{name}-amfix.patch
-Patch3:                %{name}-lpthread.patch
+Patch1:                %{name}-amfix.patch
+Patch2:                %{name}-lpthread.patch
+Patch3:                %{name}-no_rpath_in_sdl-config.patch
+Patch4:                %{name}-mmx-constraints.patch
+Patch5:                %{name}-caca.patch
+Patch6:                %{name}-gcc4.patch
+Patch7:                %{name}-gcc-pr21398-workaround.patch
 URL:           http://www.libsdl.org/
+%{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.15}
+BuildRequires: OpenGL-devel
+%{?with_aalib:BuildRequires:   aalib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
+%{?with_arts:BuildRequires:    artsc-devel >= 1.1}
 BuildRequires: autoconf
 BuildRequires: automake
-%{!?_without_esound:BuildRequires:     esound-devel}
-%{!?_without_arts:BuildRequires:       arts-devel}
-BuildRequires: XFree86-devel >= 4.0.2
-BuildRequires: OpenGL-devel
-BuildRequires: perl-modules
+%{?with_esd:BuildRequires:     esound-devel >= 0.2.8}
+%{?with_caca:BuildRequires:    libcaca-devel}
+%{?with_ggi:BuildRequires:     libggi-devel}
+BuildRequires: libtool >= 2:1.4d
+%{?with_nas:BuildRequires:     nas-devel}
 %ifarch %{ix86}
 BuildRequires: nasm
 %endif
-%ifnarch sparc sparc64
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
-%endif
-%{?_with_svgalib:BuildRequires:        svgalib-devel}
-%{?_with_aalib:BuildRequires:  aalib-devel}
-%{?_with_ggi:BuildRequires:    libggi-devel}
+BuildRequires: perl-modules
+%{?with_directfb:BuildRequires:        pkgconfig >= 1:0.7}
+%{?with_svgalib:BuildRequires: svgalib-devel >= 1.4.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 SDL (Simple DirectMedia Layer) is a library that allows you portable,
 low level access to a video framebuffer, audio output, mouse, and
@@ -56,10 +58,10 @@ be built on Win32 and BeOS.
 
 %description -l pl
 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
-przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
-myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
+przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
+myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
-konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
+konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
 
 %description -l pt_BR
 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
@@ -71,14 +73,20 @@ Essa biblioteca 
 Summary:       SDL - Header files
 Summary(pl):   SDL - Pliki nag³ówkowe
 Summary(pt_BR):        Bibliotecas e arquivos de cabeçalho para aplicações SDL
+Summary(ru):   æÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ, ÉÓÐÏÌØÚÕÀÝÉÈ SDL
+Summary(uk):   æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
+Summary(zh_CN):        SDL (Simple DirectMedia Layer) ¿ª·¢¿â
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-%ifnarch sparc sparc64
-%{!?_without_alsa:Requires:    alsa-lib-devel}
-%endif
-%{!?_without_esound:Requires:  esound-devel}
-%{!?_without_arts:Requires:    arts-devel}
+Requires:      %{name} = %{version}-%{release}
+%if %{with xlibs}
+Requires:      libX11-devel
+Requires:      libXext-devel
+%else
 Requires:      XFree86-devel >= 4.0.2
+%endif
+%{?with_alsa:Requires: alsa-lib-devel}
+%{?with_caca:Requires: libcaca-devel}
+%{?with_nas:Requires:  nas-devel}
 
 %description devel
 SDL - Header files.
@@ -90,12 +98,22 @@ SDL - Pliki nag
 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
 recursos para o desenvolvimento de aplicativos com SDL.
 
+%description devel -l ru
+üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
+ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
+
+%description devel -l uk
+ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
+×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
+
 %package static
 Summary:       SDL - static libraries
 Summary(pl):   SDL - biblioteki statyczne
 Summary(pt_BR):        Biblioteca estática para desenvolvimento de aplicações com a SDL
+Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
+Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 SDL - static libraries.
@@ -106,11 +124,19 @@ SDL - biblioteki statyczne.
 %description static -l pt_BR
 Biblioteca estática para desenvolvimento de aplicações com a SDL.
 
+%description static -l ru
+üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
+ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
+
+%description static -l uk
+ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
+×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
+
 %package examples
 Summary:       SDL - example programs
 Summary(pl):   SDL - programy przyk³adowe
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description examples
 SDL - example programs.
@@ -124,16 +150,23 @@ SDL - przyk
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+
+# get COPY_ARCH_SRC, remove the rest
+head -n 20 acinclude.m4 > acinclude.tmp
+mv -f acinclude.tmp acinclude.m4
+
+find . -type d -name CVS -print | xargs rm -rf {} \;
 
 %build
-rm -f missing
-libtoolize --copy --force
-aclocal
-autoconf
-# Another hack
-cp -f src/hermes/Makefile.in Makefile.in.ok
-automake -a -c --foreign
-cp -f Makefile.in.ok src/hermes/Makefile.in
+%{__libtoolize}
+%{__aclocal}
+%{__automake}
+%{__autoconf}
+CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
 %configure \
 %ifarch %{ix86}
        --enable-nasm \
@@ -144,57 +177,63 @@ cp -f Makefile.in.ok src/hermes/Makefile.in
        --enable-pthread-sem \
        --with-x \
        --enable-dga \
+       %{?with_aalib:--enable-video-aalib} \
+       %{?with_caca:--enable-video-caca} \
        --enable-video-dga \
+       %{?with_directfb:--enable-video-directfb} \
+       --enable-video-fbcon \
+       %{?with_ggi:--enable-video-ggi} \
+       --enable-video-opengl \
+       %{?with_svga:--enable-video-svga} \
        --enable-video-x11-dgamouse \
        --enable-video-x11-vm \
        --enable-video-x11-xv \
-       --enable-video-opengl \
-       --enable-video-fbcon \
-       %{?_with_svga:--enable-video-svga} \
-       %{?_with_aalib:--enable-video-aalib} \
-       %{?_with_ggi:--enable-video-ggi} \
-%ifnarch sparc sparc64
-       %{!?_without_alsa:--enable-alsa} \
-%endif
-       %{!?_without_esound:--enable-esd} \
-       %{!?_without_arts:--enable-arts}
+       %{!?with_alsa:--disable-alsa} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_esd:--disable-esd} \
+       %{!?with_nas:--disable-nas}
+
+# automake chooses to use CXXLINK because of seen unused C++ sources
+# (which are for BeOS and MacOS+QTopia, not Linux)
+%{__make} \
+       CXXLINK="\$(LINK)"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        m4datadir=%{_aclocaldir}
 
-rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-gzip -9nf BUGS CREDITS README TODO WhatsNew
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+rm -rf docs/man3 docs/{Makefile*,.cvsignore} docs/html/{Makefile*,.cvsignore}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
+%doc BUGS CREDITS README TODO WhatsNew
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
+%doc docs.html docs
 %attr(755,root,root) %{_bindir}/sdl-config
 %attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/lib*.la
 %{_libdir}/libSDLmain.a
 %{_includedir}/SDL
 %{_aclocaldir}/*
 %{_mandir}/man3/*
 
 %files examples
+%defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
 
 %files static
This page took 0.040441 seconds and 4 git commands to generate.