]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- quick workaround for gcc PR21398.
[packages/SDL.git] / SDL.spec
index a983f9f0e5af6d1af99a4ffa655be454d68083cf..8f80f36278b5eea8edb13f47f759f0d7386d4555 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
@@ -1,61 +1,52 @@
 #
 # Conditional build:
-# _with_aalib - with aalib support
-# _with_ggi - with GGI support
-# _with_nas - with NAS audio support
-# _with_svga - with svgalib support
+%bcond_with    aalib           # with aalib graphics support
+%bcond_with    caca            # with caca graphics support
+%bcond_with    directfb        # with DirectFB graphics support
+%bcond_with    ggi             # with GGI graphics support
+%bcond_with    nas             # with NAS audio support
+%bcond_with    svga            # with svgalib graphics support
+%bcond_without alsa            # without ALSA audio support
+%bcond_without arts            # without aRts audio support
+%bcond_without esd             # without EsounD audio support
 #
-# _without_alsa - without ALSA support
-# _without_arts - without arts support
-# _without_esound - without esound support
-#
-%ifarch        alpha
-%define _without_arts 1
-%endif
-
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
-Summary(es):   Simple DirectMedia Layer
 Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
-Summary(pt_BR):        Simple DirectMedia Layer
-Summary(ru):   Simple DirectMedia Layer
-Summary(uk):   Simple DirectMedia Layer
 Summary(zh_CN):        SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
 Name:          SDL
-Version:       1.2.5
-Release:       5
+Version:       1.2.8
+Release:       2
 License:       LGPL
 Group:         X11/Libraries
 Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
-# Source0-md5: cacacf4e4cca546de168fedc23b9b44b
+# Source0-md5: 37aaf9f069f9c2c18856022f35de9f8c
 Patch0:                %{name}-byteorder.patch
-Patch1:                %{name}-fixlibs.patch
-Patch2:                %{name}-amfix.patch
-Patch3:                %{name}-lpthread.patch
-Patch4:                %{name}-ac25x.patch
-Patch5:                %{name}-no_rpath_in_sdl-config.patch
-Patch6:                %{name}-noobjc.patch
-Patch7:                %{name}-refresh_rates.patch
-Patch8:                %{name}-am17.patch
-Patch9:                %{name}-gcc33.patch
+Patch1:                %{name}-amfix.patch
+Patch2:                %{name}-lpthread.patch
+Patch3:                %{name}-no_rpath_in_sdl-config.patch
+Patch4:                %{name}-mmx-constraints.patch
+Patch5:                %{name}-caca.patch
+Patch6:                %{name}-gcc4.patch
+Patch7:                %{name}-gcc-pr21398-workaround.patch
 URL:           http://www.libsdl.org/
+%{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.15}
 BuildRequires: OpenGL-devel
-BuildRequires: XFree86-devel >= 4.0.2
-%{?_with_aalib:BuildRequires:  aalib-devel}
-%ifnarch sparc sparc64
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
-%endif
-%{!?_without_arts:BuildRequires:       arts-devel >= 1.1}
+%{?with_aalib:BuildRequires:   aalib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
+%{?with_arts:BuildRequires:    artsc-devel >= 1.1}
 BuildRequires: autoconf
 BuildRequires: automake
-%{!?_without_esound:BuildRequires:     esound-devel}
-%{?_with_ggi:BuildRequires:    libggi-devel}
-BuildRequires: libtool
-%{?_with_nas:BuildRequires:    nas-devel}
+%{?with_esd:BuildRequires:     esound-devel >= 0.2.8}
+%{?with_caca:BuildRequires:    libcaca-devel}
+%{?with_ggi:BuildRequires:     libggi-devel}
+BuildRequires: libtool >= 2:1.4d
+%{?with_nas:BuildRequires:     nas-devel}
 %ifarch %{ix86}
 BuildRequires: nasm
 %endif
 BuildRequires: perl-modules
-%{?_with_svgalib:BuildRequires:        svgalib-devel}
+%{?with_directfb:BuildRequires:        pkgconfig >= 1:0.7}
+%{?with_svgalib:BuildRequires: svgalib-devel >= 1.4.0}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -86,14 +77,16 @@ Summary(ru):        
 Summary(uk):   æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
 Summary(zh_CN):        SDL (Simple DirectMedia Layer) ¿ª·¢¿â
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+%if %{with xlibs}
+Requires:      libX11-devel
+Requires:      libXext-devel
+%else
 Requires:      XFree86-devel >= 4.0.2
-%ifnarch sparc sparc64
-%{!?_without_alsa:Requires:    alsa-lib-devel}
 %endif
-%{!?_without_arts:Requires:    arts-devel}
-%{!?_without_esound:Requires:  esound-devel}
-%{?_with_nas:Requires: nas-devel}
+%{?with_alsa:Requires: alsa-lib-devel}
+%{?with_caca:Requires: libcaca-devel}
+%{?with_nas:Requires:  nas-devel}
 
 %description devel
 SDL - Header files.
@@ -120,7 +113,7 @@ Summary(pt_BR):     Biblioteca est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 SDL - static libraries.
@@ -143,7 +136,7 @@ Biblioteca est
 Summary:       SDL - example programs
 Summary(pl):   SDL - programy przyk³adowe
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description examples
 SDL - example programs.
@@ -161,16 +154,19 @@ SDL - przyk
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p1
+
+# get COPY_ARCH_SRC, remove the rest
+head -n 20 acinclude.m4 > acinclude.tmp
+mv -f acinclude.tmp acinclude.m4
+
+find . -type d -name CVS -print | xargs rm -rf {} \;
 
 %build
-rm -f missing libtool
 %{__libtoolize}
 %{__aclocal}
 %{__automake}
 %{__autoconf}
-SED=sed ; export SED
+CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
 %configure \
 %ifarch %{ix86}
        --enable-nasm \
@@ -181,52 +177,53 @@ SED=sed ; export SED
        --enable-pthread-sem \
        --with-x \
        --enable-dga \
+       %{?with_aalib:--enable-video-aalib} \
+       %{?with_caca:--enable-video-caca} \
        --enable-video-dga \
-       --disable-video-directfb \
+       %{?with_directfb:--enable-video-directfb} \
+       --enable-video-fbcon \
+       %{?with_ggi:--enable-video-ggi} \
+       --enable-video-opengl \
+       %{?with_svga:--enable-video-svga} \
        --enable-video-x11-dgamouse \
        --enable-video-x11-vm \
        --enable-video-x11-xv \
-       --enable-video-opengl \
-       --enable-video-fbcon \
-       %{?_with_aalib:--enable-video-aalib} \
-       %{?_with_ggi:--enable-video-ggi} \
-       %{!?_with_nas:--disable-nas} \
-       %{?_with_svga:--enable-video-svga} \
-%ifnarch sparc sparc64
-       %{!?_without_alsa:--enable-alsa} \
-%endif
-       %{!?_without_esound:--enable-esd} \
-       %{!?_without_arts:--enable-arts} \
-       %{?_without_arts:--disable-arts}
+       %{!?with_alsa:--disable-alsa} \
+       %{!?with_arts:--disable-arts} \
+       %{!?with_esd:--disable-esd} \
+       %{!?with_nas:--disable-nas}
 
-%{__make}
+# automake chooses to use CXXLINK because of seen unused C++ sources
+# (which are for BeOS and MacOS+QTopia, not Linux)
+%{__make} \
+       CXXLINK="\$(LINK)"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-SED=sed ; export SED
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        m4datadir=%{_aclocaldir}
 
 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
+rm -rf docs/man3 docs/{Makefile*,.cvsignore} docs/html/{Makefile*,.cvsignore}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
+%doc BUGS CREDITS README TODO WhatsNew
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc BUGS CREDITS README TODO WhatsNew docs.html docs
+%doc docs.html docs
 %attr(755,root,root) %{_bindir}/sdl-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
This page took 0.039491 seconds and 4 git commands to generate.