]> git.pld-linux.org Git - packages/SDL.git/blobdiff - SDL.spec
- gcc 3.4 fixes.
[packages/SDL.git] / SDL.spec
index c1b618a67efca433b223a5c594834da14f9f3605..8efefb7a79eb93b8953fa780713862719d5b35bd 100644 (file)
--- a/SDL.spec
+++ b/SDL.spec
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 %bcond_with    aalib           # with aalib graphics support
+%bcond_with    caca            # with caca graphics support
 %bcond_with    directfb        # with DirectFB graphics support
 %bcond_with    ggi             # with GGI graphics support
 %bcond_with    nas             # with NAS audio support
@@ -8,7 +9,7 @@
 %bcond_without alsa            # without ALSA audio support
 %bcond_without arts            # without aRts audio support
 %bcond_without esd             # without EsounD audio support
-
+#
 Summary:       SDL (Simple DirectMedia Layer) - Game/Multimedia Library
 Summary(es):   Simple DirectMedia Layer
 Summary(pl):   SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
@@ -17,32 +18,30 @@ Summary(ru):        Simple DirectMedia Layer
 Summary(uk):   Simple DirectMedia Layer
 Summary(zh_CN):        SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
 Name:          SDL
-Version:       1.2.6
-Release:       3
+Version:       1.2.7
+Release:       1
 License:       LGPL
 Group:         X11/Libraries
 Source0:       http://www.libsdl.org/release/%{name}-%{version}.tar.gz
-# Source0-md5: 9011f147f23ec535515291d0c9c6904c
+# Source0-md5: d29b34b6ba3ed213893fc9d8d35e357a
 Patch0:                %{name}-byteorder.patch
-Patch1:                %{name}-fixlibs.patch
-Patch2:                %{name}-amfix.patch
-Patch3:                %{name}-lpthread.patch
-Patch4:                %{name}-no_rpath_in_sdl-config.patch
-Patch5:                %{name}-lt15.patch
-Patch6:                %{name}-dlopen-acfix.patch
-Patch7:                %{name}-mmx-constraints.patch
+Patch1:                %{name}-amfix.patch
+Patch2:                %{name}-lpthread.patch
+Patch3:                %{name}-no_rpath_in_sdl-config.patch
+Patch4:                %{name}-mmx-constraints.patch
+Patch5:                %{name}-caca.patch
+Patch6:                %{name}-gcc34.patch
 URL:           http://www.libsdl.org/
 %{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.15}
 BuildRequires: OpenGL-devel
-BuildRequires: XFree86-devel >= 4.0.2
+#BuildRequires:        XFree86-devel >= 4.0.2
 %{?with_aalib:BuildRequires:   aalib-devel}
-%ifnarch sparc sparc64
 %{?with_alsa:BuildRequires:    alsa-lib-devel >= 0.9.0}
-%endif
-%{?with_arts:BuildRequires:    arts-devel >= 1.1}
+%{?with_arts:BuildRequires:    artsc-devel >= 1.1}
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_esd:BuildRequires:     esound-devel >= 0.2.8}
+%{?with_caca:BuildRequires:    libcaca-devel}
 %{?with_ggi:BuildRequires:     libggi-devel}
 BuildRequires: libtool >= 2:1.4d
 %{?with_nas:BuildRequires:     nas-devel}
@@ -82,11 +81,10 @@ Summary(ru):        
 Summary(uk):   æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
 Summary(zh_CN):        SDL (Simple DirectMedia Layer) ¿ª·¢¿â
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      XFree86-devel >= 4.0.2
-%ifnarch sparc sparc64
 %{?with_alsa:Requires: alsa-lib-devel}
-%endif
+%{?with_caca:Requires: libcaca-devel}
 %{?with_nas:Requires:  nas-devel}
 
 %description devel
@@ -114,7 +112,7 @@ Summary(pt_BR):     Biblioteca est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 SDL - static libraries.
@@ -137,7 +135,7 @@ Biblioteca est
 Summary:       SDL - example programs
 Summary(pl):   SDL - programy przyk³adowe
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description examples
 SDL - example programs.
@@ -154,20 +152,19 @@ SDL - przyk
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
 
 # get COPY_ARCH_SRC, remove the rest
-head -n 16 acinclude.m4 > acinclude.tmp
+head -n 20 acinclude.m4 > acinclude.tmp
 mv -f acinclude.tmp acinclude.m4
 
 find . -type d -name CVS -print | xargs rm -rf {} \;
 
 %build
-rm -f missing libtool
 %{__libtoolize}
 %{__aclocal}
 %{__automake}
 %{__autoconf}
+CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
 %configure \
 %ifarch %{ix86}
        --enable-nasm \
@@ -179,6 +176,7 @@ rm -f missing libtool
        --with-x \
        --enable-dga \
        %{?with_aalib:--enable-video-aalib} \
+       %{?with_caca:--enable-video-caca} \
        --enable-video-dga \
        %{?with_directfb:--enable-video-directfb} \
        --enable-video-fbcon \
This page took 0.216349 seconds and 4 git commands to generate.