]> git.pld-linux.org Git - packages/RealPlayer.git/blobdiff - RealPlayer.spec
- added
[packages/RealPlayer.git] / RealPlayer.spec
index 35646b043e780495a4b51876038142bf156513b8..ad6f6cf9c76b9fa7b46b52167beb7203fbf2a861 100644 (file)
@@ -1,19 +1,42 @@
+#
+# Todo:
+#      - replace mozilla-* plugins with browser-plugins
+#      - add the licence agreement mechanism
+#
 %define                _name   realplay
-Summary:       Welcome to RealPlayer 10!
+Summary:       RealPlayer - RealAudio and RealVideo player
 Summary(pl):   RealPlayer - odtwarzacz RealAudio i RealVideo
 Name:          RealPlayer
-Version:       10
-Release:       2
+%ifarch        %{ix86}
+%define                minor_ver       6
+%else
+%define                minor_ver       5
+%endif
+Version:       10.0.%{minor_ver}
+Release:       0.1
 License:       Helix DNA Technology Binary Research Use License (not distributable, see LICENSE)
 Group:         X11/Applications/Multimedia
+# download from https://helixcommunity.org/project/showfiles.php?group_id=154
+%ifarch %{ix86}
+Source0:       https://helixcommunity.org/download.php/1589/%{name}-%{version}.776-20050929.i586.rpm
+# NoSource0-md5:       870215a8ed4f50c76bbc42212511e8e7
+NoSource:      0
+%endif
+%ifarch ppc
+Source1:       https://helixcommunity.org/download.php/1346/realplay-%{version}.756-linux-2.2-libc6-gcc32-powerpc.bin
+# NoSource1-md5:       d87d35617f07ab9435341f37229dd3ae
+NoSource:      1
+%endif
 URL:           http://www.real.com/
-Source0:       http://software-dl.real.com/06c1f73fd206f3264217/unix/%{name}%{version}GOLD.bin
-# NoSource0-md5:       1e6435241bfb0ea6c015ec717fbf141a
-Conflicts:     realplayer
+BuildRequires: cpio
+BuildRequires: sed >= 4.0
+Provides:      helix-core
+Requires:      sed >= 4.0
 Obsoletes:     G2player
+Obsoletes:     RealPlayer-gnome
+Conflicts:     realplayer
+ExclusiveArch: %{ix86} ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-NoSource:      0
-ExclusiveArch: %{ix86} 
 
 %description
 Streaming audio/video/flash/pix/text player.
@@ -25,8 +48,8 @@ Odtwarzacz strumieni audio/video/flash/pix/tekst.
 Summary:       RealPlayer Mozilla plugin
 Summary(pl):   Wtyczka Mozilli RealPlayer
 Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}
-Prereq:                mozilla-embedded
+PreReq:                mozilla-embedded
+Requires:      %{name} = %{version}-%{release}
 
 %description -n mozilla-plugin-%{name}
 RealPlayer Mozilla plugin
@@ -35,11 +58,11 @@ RealPlayer Mozilla plugin
 Wtyczka Mozilli RealPlayer
 
 %package -n mozilla-firefox-plugin-%{name}
-Summary:        RealPlayer Mozilla Firefox plugin
-Summary(pl):    Wtyczka Mozilli Firefox RealPlayer
-Group:          X11/Applications/Multimedia
-Requires:       %{name} = %{version}
-Prereq:         mozilla-firefox
+Summary:       RealPlayer Mozilla Firefox plugin
+Summary(pl):   Wtyczka Mozilli Firefox RealPlayer
+Group:         X11/Applications/Multimedia
+PreReq:                mozilla-firefox
+Requires:      %{name} = %{version}-%{release}
 
 %description -n mozilla-firefox-plugin-%{name}
 RealPlayer Mozilla plugin
@@ -47,34 +70,24 @@ RealPlayer Mozilla plugin
 %description -n mozilla-firefox-plugin-%{name} -l pl
 Wtyczka Mozilli RealPlayer
 
-%package gnome
-Summary:       GNOME data for Realplayer
-Summary(pl):   Dane Realplayera dla GNOME
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}
-Requires:      gnome-libs
-
-%description gnome
-Mime information and application registry data for GNOME.
-
-%description gnome -l pl
-Dane MIME oraz wpisy do rejestru aplikacji dla GNOME.
-
-
 %prep
 %setup -q -c -T
-dd if=%{SOURCE0} skip=1 bs=129460| %{__bzip2} -d | %{__tar} xvf -
+%ifarch %{ix86}
+rpm2cpio %{SOURCE0} | cpio -dimu
+mv -f usr/local/RealPlayer/* .
+%endif
+%ifarch ppc
+dd if=%{SOURCE1} bs=1 skip=158895 | tar xjf -
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_desktopdir} \
        $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins \
        $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins \
-       $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name},%{_datadir}/{locale}} \
+       $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name},%{_datadir}/locale} \
        $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{48x48,128x128}/mimetypes \
-       $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,32x32,48x48,128x128}/apps \
-       $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES \
-       $RPM_BUILD_ROOT%{_datadir}/{application-registry,mime-info}
+       $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,32x32,48x48,128x128}/apps
 
 cp -a codecs common plugins lib $RPM_BUILD_ROOT%{_libdir}/%{_name}
 
@@ -112,18 +125,14 @@ install realplay_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/realpl
 install realplay_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/apps/realplay.png
 cd -
 
-install share/locale/fr.mo $RPM_BUILD_ROOT%{_datadir}/locale/fr/LC_MESSAGES/realplay.mo
+cp -rf share/locale/* $RPM_BUILD_ROOT%{_datadir}/locale
 
-install mozilla/*.so $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
-install mozilla/*.so $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
+install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
+install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
 
-install realplay*  $RPM_BUILD_ROOT%{_libdir}/%{_name}
+install realplay* $RPM_BUILD_ROOT%{_libdir}/%{_name}
 ln -sf ../lib/%{_name}/realplay $RPM_BUILD_ROOT%{_bindir}/realplay
 
-install share/realplay.applications $RPM_BUILD_ROOT%{_datadir}/application-registry
-install share/realplay.mime $RPM_BUILD_ROOT%{_datadir}/mime-info
-install share/realplay.keys $RPM_BUILD_ROOT%{_datadir}/mime-info
-
 install share/realplay.desktop $RPM_BUILD_ROOT%{_desktopdir}
 
 install -d $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/{default,realplay}
@@ -132,10 +141,12 @@ install share/realplay/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/realplay
 install share/default/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/default
 install share/*.html $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
 install share/*.css $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
+
 %{__sed} -i -e 's&#[ \t]*HELIX_LIBS[ \t]*=.*$&HELIX_LIBS=%{_libdir}/%{_name} ; export HELIX_LIBS&' \
        $RPM_BUILD_ROOT%{_libdir}/realplay/realplay
 
-%find_lang realplay
+# "player" and "widget" domains
+%find_lang %{name} --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -148,19 +159,18 @@ umask 022
 umask 022
 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
 
-%files -f realplay.lang
+%files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc LICENSE README 
 %attr(755,root,root) %{_bindir}/realplay
 %dir %{_libdir}/%{_name}
 %dir %{_libdir}/%{_name}/codecs
-%dir %{_libdir}/%{_name}/common
-%dir %{_libdir}/%{_name}/lib
-%dir %{_libdir}/%{_name}/plugins
-
 %attr(755,root,root) %{_libdir}/%{_name}/codecs/*.so*
+%dir %{_libdir}/%{_name}/common
 %attr(755,root,root) %{_libdir}/%{_name}/common/*.so*
+%dir %{_libdir}/%{_name}/lib
 %attr(755,root,root) %{_libdir}/%{_name}/lib/*.so*
+%dir %{_libdir}/%{_name}/plugins
 %attr(755,root,root) %{_libdir}/%{_name}/plugins/*.so*
 %attr(755,root,root) %{_libdir}/%{_name}/realplay
 %attr(755,root,root) %{_libdir}/%{_name}/realplay.bin
@@ -170,15 +180,12 @@ umask 022
 %{_iconsdir}/hicolor/*/*/*.png
 %{_desktopdir}/*.desktop
 
-%files gnome
-%defattr(644,root,root,755)
-%{_datadir}/application-registry
-%{_datadir}/mime-info
-
 %files -n mozilla-plugin-%{name}
 %defattr(644,root,root,755)
-%{_libdir}/mozilla/plugins/*
+%attr(755,root,root) %{_libdir}/mozilla/plugins/*.so
+%{_libdir}/mozilla/plugins/*.xpt
 
 %files -n mozilla-firefox-plugin-%{name}
 %defattr(644,root,root,755)
-%{_libdir}/mozilla-firefox/plugins/*
+%attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
+%{_libdir}/mozilla-firefox/plugins/*.xpt
This page took 0.062742 seconds and 4 git commands to generate.