]> git.pld-linux.org Git - packages/RealPlayer.git/blame - RealPlayer.spec
- Requires(post,postun): gtk-update-icon-cache
[packages/RealPlayer.git] / RealPlayer.spec
CommitLineData
9716270d 1# TODO:
a028da92 2# - add the licence agreement mechanism
1c020b50 3# - check if this works in opera/konqueror
763d996e
JB
4# NOTE: there are partial sources available
5# (https://helixcommunity.org/frs/download.php/2153/realplay-10.0.8-source.tar.bz2)
6# but included binary blobs are only for x86
39c6c127
JB
7#
8# Conditional build:
9%bcond_without autodeps # don't BR packages needed only for resolving deps
a028da92 10#
f90f6c15 11%define _name realplay
98414f97 12Summary: RealPlayer - RealAudio and RealVideo player
4e485034 13Summary(pl.UTF-8): RealPlayer - odtwarzacz RealAudio i RealVideo
f90f6c15 14Name: RealPlayer
a028da92 15%ifarch %{ix86}
763d996e 16%define minor_ver 8
a028da92 17%else
18%define minor_ver 5
19%endif
20Version: 10.0.%{minor_ver}
8b17147d 21Release: 2
f90f6c15 22License: Helix DNA Technology Binary Research Use License (not distributable, see LICENSE)
23Group: X11/Applications/Multimedia
23c0c990
JB
24# download from https://helixcommunity.org/project/showfiles.php?group_id=154
25%ifarch %{ix86}
763d996e
JB
26Source0: https://helixcommunity.org/frs/download.php/2151/realplay-%{version}.805-linux-2.2-libc6-gcc32-i586.bin
27# NoSource0-md5: d28b31261059231a3e93c7466f8153e6
f90f6c15 28NoSource: 0
23c0c990
JB
29%endif
30%ifarch ppc
763d996e 31Source1: https://helixcommunity.org/frs/download.php/1346/realplay-%{version}.756-linux-2.2-libc6-gcc32-powerpc.bin
c350d3d8 32# NoSource1-md5: d87d35617f07ab9435341f37229dd3ae
23c0c990
JB
33NoSource: 1
34%endif
39c6c127 35Patch0: realplayer-desktop.patch
8655142d 36URL: http://www.real.com/linux/
8655142d 37BuildRequires: rpmbuild(macros) >= 1.312
d784466a 38BuildRequires: sed >= 4.0
39c6c127
JB
39%if %{with autodeps}
40BuildRequires: atk
41BuildRequires: glib2
42BuildRequires: gtk+2
43BuildRequires: libgcc
44BuildRequires: libstdc++
45BuildRequires: pango
46%endif
8b17147d 47Requires(post,postun): gtk-update-icon-cache
ca48914b 48Requires(post,postun): hicolor-icon-theme
39c71e17 49Requires: sed >= 4.0
39c6c127 50Provides: helix-core
a26fe8d8 51Obsoletes: G2player
d6ee24cf 52Obsoletes: RealPlayer-gnome
39c6c127 53Obsoletes: realplayer
23c0c990 54ExclusiveArch: %{ix86} ppc
39c6c127 55ExcludeArch: i386 i486
a26fe8d8 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
f90f6c15 57
8655142d 58%define _plugindir %{_libdir}/browser-plugins
59%define browsers mozilla, mozilla-firefox, netscape, seamonkey
39c6c127 60%define _noautocompressdoc LICENSE README
8655142d 61
f90f6c15 62%description
63Streaming audio/video/flash/pix/text player.
39c6c127
JB
64%ifarch ppc
65
66WARNING: this package is vulnerable - see CVE-2006-0323!
67%endif
f90f6c15 68
de16ce7f 69%description -l pl.UTF-8
f90f6c15 70Odtwarzacz strumieni audio/video/flash/pix/tekst.
39c6c127
JB
71%ifarch ppc
72
de16ce7f 73UWAGA: ten pakiet jest niebezpieczny - szczegóły w CVE-2006-0323!
39c6c127 74%endif
f90f6c15 75
8655142d 76%package -n browser-plugin-%{name}
77Summary: RealPlayer plugin for WWW browsers
4e485034 78Summary(pl.UTF-8): Wtyczka RealPlayer do przeglądarek WWW
f90f6c15 79Group: X11/Applications/Multimedia
a26fe8d8 80Requires: %{name} = %{version}-%{release}
8655142d 81Requires: browser-plugins(%{_target_base_arch})
f90f6c15 82
8655142d 83%description -n browser-plugin-%{name}
84RealPlayer plugin for WWW browsers.
f90f6c15 85
8655142d 86Supported browsers: %{browsers}.
f90f6c15 87
de16ce7f
JR
88%description -n browser-plugin-%{name} -l pl.UTF-8
89Wtyczka RealPlayer dla przeglądarek WWW.
f90f6c15 90
de16ce7f 91Obsługiwane przeglądarki: %{browsers}.
f90f6c15 92
f90f6c15 93%prep
94%setup -q -c -T
23c0c990 95%ifarch %{ix86}
763d996e 96dd if=%{SOURCE0} bs=1 skip=143273 | tar xjf -
23c0c990
JB
97%endif
98%ifarch ppc
c2511e91 99dd if=%{SOURCE1} bs=1 skip=158895 | tar xjf -
23c0c990 100%endif
763d996e 101%patch0 -p1
f90f6c15 102
103%install
104rm -rf $RPM_BUILD_ROOT
105install -d $RPM_BUILD_ROOT%{_desktopdir} \
8655142d 106 $RPM_BUILD_ROOT%{_plugindir} \
763d996e 107 $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{_name}} \
f90f6c15 108 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{48x48,128x128}/mimetypes \
d6ee24cf 109 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,32x32,48x48,128x128}/apps
f90f6c15 110
111cp -a codecs common plugins lib $RPM_BUILD_ROOT%{_libdir}/%{_name}
112
113icons="mime-application-generic \
114mime-application-ogg \
115mime-application-ram \
116mime-application-rpm \
117mime-application-smil \
118mime-audio-aiff \
119mime-audio-au \
120mime-audio-generic \
121mime-audio-mp3 \
122mime-audio-mp4 \
123mime-audio-ogg \
124mime-audio-ra \
125mime-audio-wav \
126mime-text-realtext \
127mime-video-avi \
128mime-video-generic \
129mime-video-mov \
130mime-video-ogg \
131mime-video-rv \
132mime-video-swf"
133
134cd share/icons
8b17147d 135for i in $icons;
f90f6c15 136do
137install ${i}_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/mimetypes/${i}.png
138# SIC! there is no 192 size defined in hicolor, therefore use 128
139install ${i}_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/mimetypes/${i}.png
140done
141install realplay_16x16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/realplay.png
142install realplay_32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/realplay.png
143install realplay_48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/realplay.png
144install realplay_192x192.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/128x128/apps/realplay.png
145cd -
146
763d996e
JB
147# install locales in proper domains
148cd share/locale
149for LC in *; do
150 install -d $RPM_BUILD_ROOT%{_datadir}/locale/${LC}/LC_MESSAGES
151 cp -a ${LC}/player.mo $RPM_BUILD_ROOT%{_datadir}/locale/${LC}/LC_MESSAGES/realplay.mo
152 cp -a ${LC}/widget.mo $RPM_BUILD_ROOT%{_datadir}/locale/${LC}/LC_MESSAGES/libgtkhx.mo
153done
154cd ../..
f90f6c15 155
8655142d 156install mozilla/*.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
f90f6c15 157
3b5a0f61 158install realplay* $RPM_BUILD_ROOT%{_libdir}/%{_name}
39c6c127 159ln -sf ../%{_lib}/%{_name}/realplay $RPM_BUILD_ROOT%{_bindir}/realplay
f90f6c15 160
f90f6c15 161install share/realplay.desktop $RPM_BUILD_ROOT%{_desktopdir}
f90f6c15 162
296bac0a 163install -d $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/{default,realplay}
f90f6c15 164
296bac0a 165install share/realplay/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/realplay
f90f6c15 166install share/default/* $RPM_BUILD_ROOT%{_libdir}/%{_name}/share/default
167install share/*.html $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
168install share/*.css $RPM_BUILD_ROOT%{_libdir}/%{_name}/share
763d996e 169cp -a README LICENSE $RPM_BUILD_ROOT%{_libdir}/%{_name}
39c6c127
JB
170rm -rf docs
171install -d docs
172ln -s %{_libdir}/%{_name}/README docs
173ln -s %{_libdir}/%{_name}/LICENSE docs
a028da92 174
8c77c61a 175%{__sed} -i -e 's&#[ \t]*HELIX_LIBS[ \t]*=.*$&HELIX_LIBS=%{_libdir}/%{_name} ; export HELIX_LIBS&' \
296bac0a 176 $RPM_BUILD_ROOT%{_libdir}/realplay/realplay
f90f6c15 177
763d996e 178# "realplay" and "libgtkhx" domains
ccb7ac22 179%find_lang %{name} --all-name
f90f6c15 180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
489205c4 184%post
185umask 022
186[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
8655142d 187%update_icon_cache hicolor
489205c4 188
189%postun
190umask 022
191[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
8655142d 192%update_icon_cache hicolor
193
4a80ffbb 194%triggerin -n browser-plugin-%{name} -- mozilla-firefox
8655142d 195%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
196
4a80ffbb 197%triggerun -n browser-plugin-%{name} -- mozilla-firefox
8655142d 198%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
199
4a80ffbb 200%triggerin -n browser-plugin-%{name} -- mozilla
8655142d 201%nsplugin_install -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
202
4a80ffbb 203%triggerun -n browser-plugin-%{name} -- mozilla
8655142d 204%nsplugin_uninstall -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
205
4a80ffbb 206#triggerin -n browser-plugin-%{name} -- konqueror
1c020b50 207#nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nphelix.so
8655142d 208
4a80ffbb 209#triggerun -n browser-plugin-%{name} -- konqueror
1c020b50 210#nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nphelix.so
8655142d 211
4a80ffbb 212#triggerin -n browser-plugin-%{name} -- opera
1c020b50 213#nsplugin_install -d %{_libdir}/opera/plugins nphelix.so
8655142d 214
4a80ffbb 215#triggerun -n browser-plugin-%{name} -- opera
1c020b50 216#nsplugin_uninstall -d %{_libdir}/opera/plugins nphelix.so
8655142d 217
4a80ffbb 218%triggerin -n browser-plugin-%{name} -- seamonkey
8655142d 219%nsplugin_install -d %{_libdir}/seamonkey/plugins nphelix.so nphelix.xpt
220
4a80ffbb 221%triggerun -n browser-plugin-%{name} -- seamonkey
8655142d 222%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nphelix.so nphelix.xpt
223
224# as rpm removes the old obsoleted package files after the triggers
225# above are ran, add another trigger to make the links there.
4a80ffbb 226%triggerpostun -n browser-plugin-%{name} -- mozilla-firefox-plugin-RealPlaer
8655142d 227%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins nphelix.so nphelix.xpt
228
4a80ffbb 229%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-RealPlayer
8655142d 230%nsplugin_install -f -d %{_libdir}/mozilla/plugins nphelix.so nphelix.xpt
489205c4 231
ccb7ac22 232%files -f %{name}.lang
f90f6c15 233%defattr(644,root,root,755)
39c6c127 234%doc docs/{LICENSE,README}
f90f6c15 235%attr(755,root,root) %{_bindir}/realplay
236%dir %{_libdir}/%{_name}
237%dir %{_libdir}/%{_name}/codecs
f90f6c15 238%attr(755,root,root) %{_libdir}/%{_name}/codecs/*.so*
ccb7ac22 239%dir %{_libdir}/%{_name}/common
f90f6c15 240%attr(755,root,root) %{_libdir}/%{_name}/common/*.so*
ccb7ac22 241%dir %{_libdir}/%{_name}/lib
f90f6c15 242%attr(755,root,root) %{_libdir}/%{_name}/lib/*.so*
ccb7ac22 243%dir %{_libdir}/%{_name}/plugins
f90f6c15 244%attr(755,root,root) %{_libdir}/%{_name}/plugins/*.so*
296bac0a 245%attr(755,root,root) %{_libdir}/%{_name}/realplay
246%attr(755,root,root) %{_libdir}/%{_name}/realplay.bin
f90f6c15 247%{_libdir}/%{_name}/share
39c6c127
JB
248%{_libdir}/%{_name}/LICENSE
249%{_libdir}/%{_name}/README
f90f6c15 250%{_iconsdir}/hicolor/*/*/*.png
251%{_desktopdir}/*.desktop
252
8655142d 253%files -n browser-plugin-%{name}
f90f6c15 254%defattr(644,root,root,755)
8655142d 255%attr(755,root,root) %{_plugindir}/*.so
256%{_plugindir}/*.xpt
This page took 0.12129 seconds and 4 git commands to generate.