]> git.pld-linux.org Git - packages/RakNet.git/blame - RakNet.spec
- BR: gcc-c++ (those are c++ files, but they don't use libstdc++)
[packages/RakNet.git] / RakNet.spec
CommitLineData
a2164dd8
ER
1# NOTE
2# - RakNet 3.x is available, but it is not under GPL License
5042561b 3# - fix linking
9f5a11ac 4# - SONAME lost?
a0fdb1cd 5#
6%define ver %(echo %{version} | tr . _)
7Summary: Networking engine for game programmers
8Summary(pl.UTF-8): Silnik sieciowy dla programistów gier
9Name: RakNet
10Version: 2.0
9f5a11ac 11Release: 0.1
a0fdb1cd 12License: GPL v2
13Group: Libraries
14Source0: http://www.sumwars.org/data/Raknet%{ver}.tar.gz
15# Source0-md5 bfdc95cf31d1381fb97631a3f07bc6c8
16Patch0: %{name}-destdir.patch
17Patch1: %{name}-flags.patch
18URL: http://www.jenkinssoftware.com/
5042561b 19BuildRequires: gcc-c++
a0fdb1cd 20BuildRequires: pkgconfig
a2164dd8
ER
21BuildRequires: rpmbuild(macros) >= 1.553
22BuildRequires: sed >= 4.0
a0fdb1cd 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26RakNet is open source, networking engine for game programmers.
27
28%description -l pl.UTF-8
29RakNet jest otwartym, sieciowym silnikiem dla programistów gier.
30
31%package devel
32Summary: Header files for RakNet library
33Summary(pl.UTF-8): Pliki nagłówkowe biblioteki RakNet
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36
37%description devel
38Header files for RakNet library.
39
40%description devel -l pl.UTF-8
41Pliki nagłówkowe biblioteki RakNet.
42
43%prep
44%setup -q -n Raknet%{ver}
a2164dd8 45%undos Makefile Source/Makefile Source/RakVoice/Makefile
a0fdb1cd 46%patch0 -p1
47%patch1 -p1
48
49%build
5042561b 50%{__make} -j1 \
a0fdb1cd 51 CC="%{__cc}" \
52 CFLAGS="%{rpmcflags} -fPIC" \
53 LDFLAGS="%{rpmldflags}"
54
55%install
56rm -rf $RPM_BUILD_ROOT
5042561b 57%{__make} -j1 install \
58 LIBS_DIR="%{_libdir}" \
a0fdb1cd 59 DESTDIR=$RPM_BUILD_ROOT
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
9f5a11ac
ER
64%post -p /sbin/ldconfig
65%postun -p /sbin/ldconfig
66
a0fdb1cd 67%files
68%defattr(644,root,root,755)
a0fdb1cd 69%attr(755,root,root) %{_libdir}/libraknet.so.*.*.*
9f5a11ac 70#%attr(755,root,root) %ghost %{_libdir}/libraknet.so.2
a0fdb1cd 71%attr(755,root,root) %{_libdir}/librakvoice.so.*.*.*
9f5a11ac 72#%attr(755,root,root) %ghost %{_libdir}/librakvoice.so.2
a0fdb1cd 73
74%files devel
75%defattr(644,root,root,755)
9f5a11ac 76%{_includedir}/raknet
a0fdb1cd 77%{_libdir}/libraknet.so
78%{_libdir}/librakvoice.so
79%{_pkgconfigdir}/RakNet.pc
This page took 0.072263 seconds and 4 git commands to generate.