]> git.pld-linux.org Git - packages/RBio.git/commitdiff
- updated to 2.1.0; switched to SuiteSparse_config
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Jun 2012 19:52:51 +0000 (19:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated ufconfig,shared patches

Changed files:
    RBio-shared.patch -> 1.2
    RBio-ufconfig.patch -> 1.2
    RBio.spec -> 1.4

RBio-shared.patch
RBio-ufconfig.patch
RBio.spec

index ab445e63bc6b117128d9a1e4dcc3226e8b0208aa..f81835f5289bded4fafefb9b9cdcd19314cb3ef7 100644 (file)
@@ -42,7 +42,7 @@
 -      $(ARCHIVE)  librbio.a $(OBJ)
 -      - $(RANLIB) librbio.a
 +librbio.la: $(OBJ)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -o librbio.la -rpath $(libdir) $(OBJ:.o=.lo) -lufconfig
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -o librbio.la -rpath $(libdir) $(OBJ:.o=.lo) -lsuitesparseconfig
 +
 +install: librbio.la
 +      install -d $(DESTDIR)$(libdir)
 -      $(C) -c -DINT $(I) $<
 +      libtool --tag=CC --mode=compile $(C) -c -DINT $(I) $< -o RBio_i.lo
  
---- RBio/Demo/Makefile.orig    2012-01-09 17:15:23.029781482 +0100
-+++ RBio/Demo/Makefile 2012-01-09 17:51:37.443187623 +0100
+--- RBio/Demo/Makefile.orig    2012-06-27 21:43:09.000000000 +0200
++++ RBio/Demo/Makefile 2012-06-27 21:43:50.571402567 +0200
 @@ -6,7 +6,7 @@
  
- include /usr/share/misc/UFconfig.mk
+ include /usr/share/misc/SuiteSparse_config.mk
  
--LIB = ../Lib/librbio.a -lufconfig
-+LIB = ../Lib/librbio.la -lufconfig
+-CLIB = ../Lib/librbio.a -lsuitesparseconfig $(LIB)
++CLIB = ../Lib/librbio.la -lsuitesparseconfig $(LIB)
  
  C = $(CC) $(CF)
  
@@ -76,6 +76,6 @@
  I = -I../Include
  
  RBdemo: library RBdemo.c
--      $(C) -o RBdemo $(I) RBdemo.c $(LIB)
-+      libtool --tag=CC --mode=link $(C) -o RBdemo $(I) RBdemo.c $(LIB)
+-      $(C) -o RBdemo $(I) RBdemo.c $(CLIB)
++      libtool --tag=CC --mode=link $(C) $(LDFLAGS) -o RBdemo $(I) RBdemo.c $(CLIB)
  
index 88423445e47a4b6f0b5fba473f14b2f829ab7c2b..4f473e8e3a7df380125fea69d72479a5278011e1 100644 (file)
@@ -4,8 +4,8 @@
  
  default: all
  
--include ../UFconfig/UFconfig.mk
-+include /usr/share/misc/UFconfig.mk
+-include ../SuiteSparse_config/SuiteSparse_config.mk
++include /usr/share/misc/SuiteSparse_config.mk
  
  # Compile the C-callable libraries and the Demo programs.
  all:
@@ -15,8 +15,8 @@
  
  ccode: all
  
--include ../../UFconfig/UFconfig.mk
-+include /usr/share/misc/UFconfig.mk
+-include ../../SuiteSparse_config/SuiteSparse_config.mk
++include /usr/share/misc/SuiteSparse_config.mk
  
  C = $(CC) $(CF)
  
  
  $(OBJ): $(INC)
  
--I = -I../Include -I../../UFconfig
+-I = -I../Include -I../../SuiteSparse_config
 +I = -I../Include
  
  #-------------------------------------------------------------------------------
  
---- RBio/Demo/Makefile.orig    2011-12-08 20:17:08.000000000 +0100
-+++ RBio/Demo/Makefile 2012-01-08 14:39:56.876576218 +0100
+--- RBio/Demo/Makefile.orig    2012-05-27 03:17:26.000000000 +0200
++++ RBio/Demo/Makefile 2012-06-27 21:42:48.921405153 +0200
 @@ -4,9 +4,9 @@
  
  default: all
  
--include ../../UFconfig/UFconfig.mk
-+include /usr/share/misc/UFconfig.mk
+-include ../../SuiteSparse_config/SuiteSparse_config.mk
++include /usr/share/misc/SuiteSparse_config.mk
  
--LIB = ../Lib/librbio.a ../../UFconfig/libufconfig.a
-+LIB = ../Lib/librbio.a -lufconfig
+-CLIB = ../Lib/librbio.a ../../SuiteSparse_config/libsuitesparseconfig.a $(LIB)
++CLIB = ../Lib/librbio.a -lsuitesparseconfig $(LIB)
  
  C = $(CC) $(CF)
  
  
  #-------------------------------------------------------------------------------
  library:
--      ( cd ../../UFconfig ; $(MAKE) )
+-      ( cd ../../SuiteSparse_config ; $(MAKE) )
        ( cd ../Lib ; $(MAKE) )
  #-------------------------------------------------------------------------------
  
--I = -I../Include -I../../UFconfig
+-I = -I../Include -I../../SuiteSparse_config
 +I = -I../Include
  
  RBdemo: library RBdemo.c
-       $(C) -o RBdemo $(I) RBdemo.c $(LIB)
+       $(C) -o RBdemo $(I) RBdemo.c $(CLIB)
index f1cd52a195c12e16196b2ae2ccab3325b1eee32e..14c7996639b9a6f09968cacf8d891dc8b4047111 100644 (file)
--- a/RBio.spec
+++ b/RBio.spec
@@ -1,16 +1,16 @@
 Summary:       RBio: read/write matrices in Rutherford/Boeing format
 Summary(pl.UTF-8):     RBio: odczyt/zapis macierzy zapisanych w formacie Rutherforda-Boeinga
 Name:          RBio
-Version:       2.0.2
+Version:       2.1.0
 Release:       1
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/RBio/%{name}-%{version}.tar.gz
-# Source0-md5: fd469b4ccac07c771c10c3046d593791
+# Source0-md5: 78fd49bbadaaeac5001aa56202173e47
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 URL:           http://www.cise.ufl.edu/research/sparse/RBio/
-BuildRequires: UFconfig-devel >= 3.7.0
+BuildRequires: SuiteSparse_config-devel >= 4.0.0
 BuildRequires: libtool >= 2:1.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -32,7 +32,7 @@ Summary:      Header files for RBio library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki RBio
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      UFconfig-devel >= 3.7.0
+Requires:      SuiteSparse_config-devel >= 4.0.0
 
 %description devel
 Header files for RBio library.
This page took 0.102643 seconds and 4 git commands to generate.