]> git.pld-linux.org Git - packages/QtKeychain.git/commitdiff
- up to 0.12.0 auto/th/QtKeychain-0.12.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 14 May 2021 20:20:00 +0000 (22:20 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 14 May 2021 20:20:00 +0000 (22:20 +0200)
- qt4 support removed upstream (no deps in PLD)

QtKeychain-qt4.patch [deleted file]
QtKeychain.spec

diff --git a/QtKeychain-qt4.patch b/QtKeychain-qt4.patch
deleted file mode 100644 (file)
index 164bdec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- qtkeychain-0.9.1/keychain_unix.cpp.orig    2018-08-20 08:23:34.000000000 +0200
-+++ qtkeychain-0.9.1/keychain_unix.cpp 2019-08-03 14:50:14.322137534 +0200
-@@ -91,7 +91,7 @@
-     // a wallet can be opened.
-     iface.setTimeout(500);
--    QDBusMessage reply = iface.call(QStringLiteral("networkWallet"));
-+    QDBusMessage reply = iface.call(QLatin1String("networkWallet"));
-     return reply.type() == QDBusMessage::ReplyMessage;
- }
index 4bbea11de101e91f2b6f0ed80a5507e76396a9ff..c62a695b1eaa9f54384ef85e88e8845cfd851549 100644 (file)
@@ -1,40 +1,24 @@
-#
-# Conditional build:
-%bcond_without qt4     # Qt4 library
-%bcond_without qt5     # Qt5 library
-
 Summary:       Qt API to store passwords and other secret data securely
 Summary(pl.UTF-8):     API Qt do bezpiecznego przechowywania haseł i innych tajnych danych
 Name:          QtKeychain
-Version:       0.9.1
+Version:       0.12.0
 Release:       1
 License:       Modified BSD License
 Group:         Libraries
 #Source0Download: https://github.com/frankosterfeld/qtkeychain/releases
 Source0:       https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: e6921de6f256259784f2a9edd1eeb8f5
-Patch0:                %{name}-qt4.patch
+# Source0-md5: 474f172b42017872dd50eec6c9981fed
 URL:           https://github.com/frankosterfeld/qtkeychain
 BuildRequires: cmake >= 2.8.11
 BuildRequires: libsecret-devel
 BuildRequires: libstdc++-devel
 BuildRequires: rpmbuild(find_lang) >= 1.37
 BuildRequires: rpmbuild(macros) >= 1.605
-%if %{with qt4}
-BuildRequires: QtCore-devel >= 4
-BuildRequires: QtDBus-devel >= 4
-BuildRequires: qt4-build >= 4
-BuildRequires: qt4-linguist >= 4
-BuildRequires: qt4-qmake >= 4
-%endif
-%if %{with qt5}
 BuildRequires: Qt5Core-devel >= 5
 BuildRequires: Qt5DBus-devel >= 5
 BuildRequires: qt5-build >= 5
 BuildRequires: qt5-linguist >= 5
 BuildRequires: qt5-qmake >= 5
-%endif
-Requires:      QtKeychain-common = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -58,37 +42,10 @@ Sposób przechowywania danych zależy od platformy:
 - Windows: system nie udostępnia usługi do bezpiecznego przechowywania
   danych; QtKeychain używa funkcji Windows API
 
-%package devel
-Summary:       Development files for QtKeychain
-Summary(pl.UTF-8):     Pliki programistyczne biblioteki QtKeychain
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description devel
-This package contains the header files for developing applications
-that use QtKeychain.
-
-%description devel -l pl.UTF-8
-Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
-wykorzystujących bibliotekę QtKeychain.
-
-%package common
-Summary:       Common data for QtKeychain libraries
-Summary(pl.UTF-8):     Wspólne dane dla bibliotek QtKeychain
-Group:         Libraries
-Conflicts:     QtKeychain < 0.9.1-1
-
-%description common
-Common data for QtKeychain libraries (both Qt 4 and Qt 5).
-
-%description common -l pl.UTF-8
-Wspólne dane dla bibliotek QtKeychain (zarówno dla Qt 4, jak i Qt 5).
-
 %package -n Qt5Keychain
 Summary:       Qt 5 API to store passwords and other secret data securely
 Summary(pl.UTF-8):     API Qt 5 do bezpiecznego przechowywania haseł i innych tajnych danych
 Group:         Libraries
-Requires:      QtKeychain-common = %{version}-%{release}
 
 %description -n Qt5Keychain
 QtKeychain a Qt API to store passwords and other secret data securely.
@@ -127,72 +84,32 @@ wykorzystujących bibliotekę Qt5Keychain.
 
 %prep
 %setup -q -n qtkeychain-%{version}
-%patch0 -p1
 
 %build
-%if %{with qt4}
-install -d build-qt4
-cd build-qt4
-%cmake .. \
-       -DBUILD_WITH_QT4:BOOL=ON \
-       -DECM_MKSPECS_INSTALL_DIR=%{_datadir}/qt4/mkspecs/modules
-
-%{__make}
-cd ..
-%endif
-
-%if %{with qt5}
 install -d build-qt5
 cd build-qt5
 %cmake .. \
        -DBUILD_WITH_QT4:BOOL=OFF \
        -DECM_MKSPECS_INSTALL_DIR=%{_libdir}/qt5/mkspecs/modules
 %{__make}
-%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with qt4}
-%{__make} -C build-qt4 install \
-       DESTDIR=$RPM_BUILD_ROOT
-%endif
-
-%if %{with qt5}
 %{__make} -C build-qt5 install \
        DESTDIR=$RPM_BUILD_ROOT
-%endif
 
 %find_lang qtkeychain --with-qm
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
-%if %{with qt4}
-%files
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.1
-
-%files devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libqtkeychain.so
-%{_includedir}/qtkeychain
-%{_libdir}/cmake/QtKeychain
-%{_datadir}/qt4/mkspecs/modules/qt_QtKeychain.pri
-%endif
-
-%files common -f qtkeychain.lang
-%defattr(644,root,root,755)
-%doc COPYING ChangeLog ReadMe.txt
+%post -n Qt5Keychain -p /sbin/ldconfig
+%postun -n Qt5Keychain -p /sbin/ldconfig
 
-%if %{with qt5}
 %files -n Qt5Keychain
 %defattr(644,root,root,755)
-%doc COPYING ChangeLog ReadMe.txt
+%doc COPYING ChangeLog ReadMe.md
 %attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libqt5keychain.so.1
 
@@ -202,4 +119,3 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/qt5keychain
 %{_libdir}/cmake/Qt5Keychain
 %{_libdir}/qt5/mkspecs/modules/qt_Qt5Keychain.pri
-%endif
This page took 0.126105 seconds and 4 git commands to generate.