]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
- move libqtkeychain.so to devel subpackage and fix its attribute
[packages/QtKeychain.git] / QtKeychain.spec
1 Summary:        Qt API to store passwords and other secret data securely
2 Name:           QtKeychain
3 Version:        0.3.0
4 Release:        0.1
5 License:        Modified BSD License
6 Group:          Libraries
7 URL:            https://github.com/frankosterfeld/qtkeychain
8 # Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
9 Source0:        %{name}-%{version}.tar.bz2
10 # Source0-md5:  a9de9be0cae568c03b152009d24ff170
11 BuildRequires:  QtCore-devel
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  qt4-build
14 BuildRequires:  qt4-linguist
15 BuildRequires:  qt4-qmake
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _qt4_datadir    %{_datadir}/qt4
19
20 %description
21
22 %in is a Qt API to store passwords and other secret data securely.
23 How the data is stored depends on the platform:
24 - Mac OS X: Passwords are stored in the OS X Keychain.
25 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
26   tries to use KWallet (via D-Bus), if available.
27 - Windows: Windows does not provide a service for secure storage.
28   QtKeychain uses the Windows API function
29
30 %package devel
31
32 Summary:        Development files for QtKeychain
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       qt4-build
36 Requires:       qt4-qmake
37
38 %description devel
39 This package contains libraries and header files for developing
40 applications that use QKeychain.
41
42 %prep
43 %setup -q
44
45 %build
46 install -d build
47 cd build
48 %cmake \
49                 ../
50
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %{__make} -C build install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post   -p /sbin/ldconfig
62 %postun -p /sbin/ldconfig
63
64 %files
65 %defattr(644,root,root,755)
66 %doc COPYING ReadMe.txt ChangeLog
67 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
68 %attr(755,root,root) %ghost %{_libdir}/libqtkeychain.so.0
69
70 %files devel
71 %defattr(644,root,root,755)
72 #%doc doc examples
73 %dir %{_includedir}/qtkeychain
74 %{_includedir}/qtkeychain/keychain.h
75 %{_includedir}/qtkeychain/qkeychain_export.h
76 %dir %{_libdir}/cmake/QtKeychain
77 %attr(755,root,root) %{_libdir}/libqtkeychain.so
78 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
79 %{_libdir}/cmake/QtKeychain/QtKeychainLibraryDepends-pld.cmake
80 %{_libdir}/cmake/QtKeychain/QtKeychainConfig.cmake
81 %{_libdir}/cmake/QtKeychain/QtKeychainConfigVersion.cmake
This page took 0.091296 seconds and 3 git commands to generate.