]> git.pld-linux.org Git - packages/QtKeychain.git/blob - QtKeychain.spec
0ae90273f4c8fceb9a35474e4bd1e2c01fde8586
[packages/QtKeychain.git] / QtKeychain.spec
1 #
2 # Conditional build:
3 %bcond_without  qt4             # build Qt4
4 %bcond_without  qt5             # build Qt5
5
6 Summary:        Qt API to store passwords and other secret data securely
7 Name:           QtKeychain
8 Version:        0.4.0
9 Release:        2
10 License:        Modified BSD License
11 Group:          Libraries
12 Source0:        https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  e4e48d8742a9fd2664425d58be236424
14 URL:            https://github.com/frankosterfeld/qtkeychain
15 BuildRequires:  cmake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  rpmbuild(find_lang) >= 1.37
18 %if %{with qt4}
19 BuildRequires:  QtCore-devel
20 BuildRequires:  QtDBus-devel
21 BuildRequires:  qt4-build
22 BuildRequires:  qt4-linguist
23 BuildRequires:  qt4-qmake
24 %endif
25 %if %{with qt5}
26 BuildRequires:  Qt5Core-devel
27 BuildRequires:  Qt5DBus-devel
28 BuildRequires:  qt5-build
29 BuildRequires:  qt5-linguist
30 BuildRequires:  qt5-qmake
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 QtKeychain a Qt API to store passwords and other secret data securely.
36
37 How the data is stored depends on the platform:
38 - Mac OS X: Passwords are stored in the OS X Keychain.
39 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
40   tries to use KWallet (via D-Bus), if available.
41 - Windows: Windows does not provide a service for secure storage.
42   QtKeychain uses the Windows API function
43
44 %package devel
45 Summary:        Development files for QtKeychain
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       qt4-build
49 Requires:       qt4-qmake
50
51 %description devel
52 This package contains libraries and header files for developing
53 applications that use QKeychain.
54
55 %package -n Qt5Keychain
56 Summary:        Qt API to store passwords and other secret data securely
57 Group:          Libraries
58
59 %description -n Qt5Keychain
60 QtKeychain a Qt API to store passwords and other secret data securely.
61
62 How the data is stored depends on the platform:
63 - Mac OS X: Passwords are stored in the OS X Keychain.
64 - Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
65   tries to use KWallet (via D-Bus), if available.
66 - Windows: Windows does not provide a service for secure storage.
67   QtKeychain uses the Windows API function
68
69 %package -n Qt5Keychain-devel
70 Summary:        Development files for QtKeychain
71 Group:          Development/Libraries
72 Requires:       Qt5Keychain = %{version}-%{release}
73 Requires:       qt5-build
74 Requires:       qt5-qmake
75
76 %description -n Qt5Keychain-devel
77 This package contains libraries and header files for developing
78 applications that use QKeychain.
79
80 %prep
81 %setup -q -n qtkeychain-%{version}
82
83 %build
84 %if %{with qt4}
85 install -d build-qt4
86 cd build-qt4
87 %cmake \
88         -DBUILD_WITH_QT4=ON \
89         ..
90 %{__make}
91 cd ..
92 %endif
93
94 %if %{with qt5}
95 install -d build-qt5
96 cd build-qt5
97 %cmake \
98         -DBUILD_WITH_QT4=OFF \
99         ..
100 %{__make}
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %if %{with qt4}
106 %{__make} -C build-qt4 install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %find_lang qtkeychain --with-qm
110 %endif
111
112 %if %{with qt5}
113 %{__make} -C build-qt5 install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %find_lang qtkeychain --with-qm
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %if %{with qt4}
126 %files -f qtkeychain.lang
127 %defattr(644,root,root,755)
128 %doc COPYING ReadMe.txt ChangeLog
129 %attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
130 %ghost %{_libdir}/libqtkeychain.so.0
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_includedir}/qtkeychain
135 %{_libdir}/libqtkeychain.so
136 %{_libdir}/cmake/QtKeychain
137 %endif
138
139 %if %{with qt5}
140 %files -n Qt5Keychain
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
143 %ghost %{_libdir}/libqt5keychain.so.0
144
145 %files -n Qt5Keychain-devel
146 %defattr(644,root,root,755)
147 %{_includedir}/qt5keychain
148 %{_libdir}/libqt5keychain.so
149 %{_libdir}/cmake/Qt5Keychain
150 %endif
This page took 0.072336 seconds and 2 git commands to generate.