]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
up to 0.4.0 (release 2014-09-01)
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
2e1a2913
ER
1#
2# Conditional build:
3%bcond_without qt4 # build Qt4
4%bcond_without qt5 # build Qt5
5
8f55f1bc
LM
6Summary: Qt API to store passwords and other secret data securely
7Name: QtKeychain
fbb6061a 8Version: 0.4.0
d72e11a6 9Release: 1
8f55f1bc
LM
10License: Modified BSD License
11Group: Libraries
fbb6061a
ER
12Source0: https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: e4e48d8742a9fd2664425d58be236424
07788830 14URL: https://github.com/frankosterfeld/qtkeychain
2e1a2913
ER
15BuildRequires: cmake
16BuildRequires: gettext-tools
8f55f1bc 17BuildRequires: libstdc++-devel
2e1a2913
ER
18%if %{with qt4}
19BuildRequires: QtCore-devel
8f55f1bc 20BuildRequires: qt4-build
97e26aaa 21BuildRequires: qt4-linguist
8f55f1bc 22BuildRequires: qt4-qmake
2e1a2913
ER
23%endif
24%if %{with qt5}
25BuildRequires: Qt5Core-devel
26BuildRequires: qt5-build
27BuildRequires: qt5-linguist
28BuildRequires: qt5-qmake
29%endif
8f55f1bc
LM
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
8f55f1bc 32%description
07788830 33QtKeychain a Qt API to store passwords and other secret data securely.
d72e11a6 34
8f55f1bc
LM
35How the data is stored depends on the platform:
36- Mac OS X: Passwords are stored in the OS X Keychain.
37- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
38 tries to use KWallet (via D-Bus), if available.
39- Windows: Windows does not provide a service for secure storage.
40 QtKeychain uses the Windows API function
41
42%package devel
8f55f1bc
LM
43Summary: Development files for QtKeychain
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: qt4-build
47Requires: qt4-qmake
48
49%description devel
50This package contains libraries and header files for developing
51applications that use QKeychain.
52
2e1a2913
ER
53%package -n Qt5Keychain
54Summary: Qt API to store passwords and other secret data securely
55Group: Libraries
56Requires: qt5-build
57Requires: qt5-qmake
58
59%description -n Qt5Keychain
60QtKeychain a Qt API to store passwords and other secret data securely.
61
62How the data is stored depends on the platform:
63- Mac OS X: Passwords are stored in the OS X Keychain.
64- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
65 tries to use KWallet (via D-Bus), if available.
66- Windows: Windows does not provide a service for secure storage.
67 QtKeychain uses the Windows API function
68
69%package -n Qt5Keychain-devel
70Summary: Development files for QtKeychain
71Group: Development/Libraries
72Requires: Qt5Keychain = %{version}-%{release}
73Requires: qt5-build
74Requires: qt5-qmake
75
76%description -n Qt5Keychain-devel
77This package contains libraries and header files for developing
78applications that use QKeychain.
79
8f55f1bc 80%prep
fbb6061a 81%setup -q -n qtkeychain-%{version}
8f55f1bc
LM
82
83%build
2e1a2913
ER
84%if %{with qt4}
85install -d build-qt4
86cd build-qt4
8f55f1bc 87%cmake \
d72e11a6
ER
88 -DBUILD_WITH_QT4=ON \
89 ..
8f55f1bc 90%{__make}
2e1a2913
ER
91cd ..
92%endif
93
94%if %{with qt5}
95install -d build-qt5
96cd build-qt5
97%cmake \
98 -DBUILD_WITH_QT4=OFF \
99 ..
100%{__make}
101%endif
8f55f1bc
LM
102
103%install
104rm -rf $RPM_BUILD_ROOT
2e1a2913
ER
105%if %{with qt4}
106%{__make} -C build-qt4 install \
07788830 107 DESTDIR=$RPM_BUILD_ROOT
8f55f1bc 108
d72e11a6 109%find_lang qtkeychain --with-qm
2e1a2913
ER
110%endif
111
112%if %{with qt5}
113%{__make} -C build-qt5 install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%find_lang qtkeychain --with-qm
117%endif
d72e11a6 118
8f55f1bc
LM
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
07788830 123%postun -p /sbin/ldconfig
8f55f1bc 124
2e1a2913 125%if %{with qt4}
d72e11a6 126%files -f qtkeychain.lang
8f55f1bc
LM
127%defattr(644,root,root,755)
128%doc COPYING ReadMe.txt ChangeLog
129%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
2e1a2913 130%ghost %{_libdir}/libqtkeychain.so.0
8f55f1bc
LM
131
132%files devel
133%defattr(644,root,root,755)
2e1a2913
ER
134%{_includedir}/qtkeychain
135%{_libdir}/libqtkeychain.so
136%{_libdir}/cmake/QtKeychain
137%endif
138
139%if %{with qt5}
140%files -n Qt5Keychain
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
143%ghost %{_libdir}/libqt5keychain.so.0
144
145%files -n Qt5Keychain-devel
146%defattr(644,root,root,755)
147%{_includedir}/qt5keychain
148%{_libdir}/libqt5keychain.so
149%{_libdir}/cmake/Qt5Keychain
150%endif
This page took 0.07928 seconds and 4 git commands to generate.