]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
cleanup bogus requires in qt5 package
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
2e1a2913
ER
1#
2# Conditional build:
3%bcond_without qt4 # build Qt4
4%bcond_without qt5 # build Qt5
5
8f55f1bc
LM
6Summary: Qt API to store passwords and other secret data securely
7Name: QtKeychain
fbb6061a 8Version: 0.4.0
883931bf 9Release: 2
8f55f1bc
LM
10License: Modified BSD License
11Group: Libraries
fbb6061a
ER
12Source0: https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: e4e48d8742a9fd2664425d58be236424
07788830 14URL: https://github.com/frankosterfeld/qtkeychain
2e1a2913 15BuildRequires: cmake
8f55f1bc 16BuildRequires: libstdc++-devel
f3986110 17BuildRequires: rpmbuild(find_lang) >= 1.37
2e1a2913
ER
18%if %{with qt4}
19BuildRequires: QtCore-devel
f3986110 20BuildRequires: QtDBus-devel
8f55f1bc 21BuildRequires: qt4-build
97e26aaa 22BuildRequires: qt4-linguist
8f55f1bc 23BuildRequires: qt4-qmake
2e1a2913
ER
24%endif
25%if %{with qt5}
26BuildRequires: Qt5Core-devel
f3986110 27BuildRequires: Qt5DBus-devel
2e1a2913
ER
28BuildRequires: qt5-build
29BuildRequires: qt5-linguist
30BuildRequires: qt5-qmake
31%endif
8f55f1bc
LM
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
8f55f1bc 34%description
07788830 35QtKeychain a Qt API to store passwords and other secret data securely.
d72e11a6 36
8f55f1bc
LM
37How the data is stored depends on the platform:
38- Mac OS X: Passwords are stored in the OS X Keychain.
39- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
40 tries to use KWallet (via D-Bus), if available.
41- Windows: Windows does not provide a service for secure storage.
42 QtKeychain uses the Windows API function
43
44%package devel
8f55f1bc
LM
45Summary: Development files for QtKeychain
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: qt4-build
49Requires: qt4-qmake
50
51%description devel
52This package contains libraries and header files for developing
53applications that use QKeychain.
54
2e1a2913
ER
55%package -n Qt5Keychain
56Summary: Qt API to store passwords and other secret data securely
57Group: Libraries
2e1a2913
ER
58
59%description -n Qt5Keychain
60QtKeychain a Qt API to store passwords and other secret data securely.
61
62How the data is stored depends on the platform:
63- Mac OS X: Passwords are stored in the OS X Keychain.
64- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
65 tries to use KWallet (via D-Bus), if available.
66- Windows: Windows does not provide a service for secure storage.
67 QtKeychain uses the Windows API function
68
69%package -n Qt5Keychain-devel
70Summary: Development files for QtKeychain
71Group: Development/Libraries
72Requires: Qt5Keychain = %{version}-%{release}
73Requires: qt5-build
74Requires: qt5-qmake
75
76%description -n Qt5Keychain-devel
77This package contains libraries and header files for developing
78applications that use QKeychain.
79
8f55f1bc 80%prep
fbb6061a 81%setup -q -n qtkeychain-%{version}
8f55f1bc
LM
82
83%build
2e1a2913
ER
84%if %{with qt4}
85install -d build-qt4
86cd build-qt4
8f55f1bc 87%cmake \
d72e11a6
ER
88 -DBUILD_WITH_QT4=ON \
89 ..
8f55f1bc 90%{__make}
2e1a2913
ER
91cd ..
92%endif
93
94%if %{with qt5}
95install -d build-qt5
96cd build-qt5
97%cmake \
98 -DBUILD_WITH_QT4=OFF \
99 ..
100%{__make}
101%endif
8f55f1bc
LM
102
103%install
104rm -rf $RPM_BUILD_ROOT
2e1a2913
ER
105%if %{with qt4}
106%{__make} -C build-qt4 install \
07788830 107 DESTDIR=$RPM_BUILD_ROOT
8f55f1bc 108
d72e11a6 109%find_lang qtkeychain --with-qm
2e1a2913
ER
110%endif
111
112%if %{with qt5}
113%{__make} -C build-qt5 install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%find_lang qtkeychain --with-qm
117%endif
d72e11a6 118
8f55f1bc
LM
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
07788830 123%postun -p /sbin/ldconfig
8f55f1bc 124
2e1a2913 125%if %{with qt4}
d72e11a6 126%files -f qtkeychain.lang
8f55f1bc
LM
127%defattr(644,root,root,755)
128%doc COPYING ReadMe.txt ChangeLog
129%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
2e1a2913 130%ghost %{_libdir}/libqtkeychain.so.0
8f55f1bc
LM
131
132%files devel
133%defattr(644,root,root,755)
2e1a2913
ER
134%{_includedir}/qtkeychain
135%{_libdir}/libqtkeychain.so
136%{_libdir}/cmake/QtKeychain
137%endif
138
139%if %{with qt5}
140%files -n Qt5Keychain
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
143%ghost %{_libdir}/libqt5keychain.so.0
144
145%files -n Qt5Keychain-devel
146%defattr(644,root,root,755)
147%{_includedir}/qt5keychain
148%{_libdir}/libqt5keychain.so
149%{_libdir}/cmake/Qt5Keychain
150%endif
This page took 0.090778 seconds and 4 git commands to generate.