]> git.pld-linux.org Git - packages/QtKeychain.git/blame - QtKeychain.spec
build qt5 version as well
[packages/QtKeychain.git] / QtKeychain.spec
CommitLineData
2e1a2913
ER
1#
2# Conditional build:
3%bcond_without qt4 # build Qt4
4%bcond_without qt5 # build Qt5
5
8f55f1bc
LM
6Summary: Qt API to store passwords and other secret data securely
7Name: QtKeychain
8Version: 0.3.0
d72e11a6 9Release: 1
8f55f1bc
LM
10License: Modified BSD License
11Group: Libraries
8f55f1bc
LM
12# Repackaged from https://github.com/frankosterfeld/qtkeychain/archive/master.zip
13Source0: %{name}-%{version}.tar.bz2
14# Source0-md5: a9de9be0cae568c03b152009d24ff170
07788830 15URL: https://github.com/frankosterfeld/qtkeychain
2e1a2913
ER
16BuildRequires: cmake
17BuildRequires: gettext-tools
8f55f1bc 18BuildRequires: libstdc++-devel
2e1a2913
ER
19%if %{with qt4}
20BuildRequires: QtCore-devel
8f55f1bc 21BuildRequires: qt4-build
97e26aaa 22BuildRequires: qt4-linguist
8f55f1bc 23BuildRequires: qt4-qmake
2e1a2913
ER
24%endif
25%if %{with qt5}
26BuildRequires: Qt5Core-devel
27BuildRequires: qt5-build
28BuildRequires: qt5-linguist
29BuildRequires: qt5-qmake
30%endif
8f55f1bc
LM
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
8f55f1bc 33%description
07788830 34QtKeychain a Qt API to store passwords and other secret data securely.
d72e11a6 35
8f55f1bc
LM
36How the data is stored depends on the platform:
37- Mac OS X: Passwords are stored in the OS X Keychain.
38- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
39 tries to use KWallet (via D-Bus), if available.
40- Windows: Windows does not provide a service for secure storage.
41 QtKeychain uses the Windows API function
42
43%package devel
8f55f1bc
LM
44Summary: Development files for QtKeychain
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: qt4-build
48Requires: qt4-qmake
49
50%description devel
51This package contains libraries and header files for developing
52applications that use QKeychain.
53
2e1a2913
ER
54%package -n Qt5Keychain
55Summary: Qt API to store passwords and other secret data securely
56Group: Libraries
57Requires: qt5-build
58Requires: qt5-qmake
59
60%description -n Qt5Keychain
61QtKeychain a Qt API to store passwords and other secret data securely.
62
63How the data is stored depends on the platform:
64- Mac OS X: Passwords are stored in the OS X Keychain.
65- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
66 tries to use KWallet (via D-Bus), if available.
67- Windows: Windows does not provide a service for secure storage.
68 QtKeychain uses the Windows API function
69
70%package -n Qt5Keychain-devel
71Summary: Development files for QtKeychain
72Group: Development/Libraries
73Requires: Qt5Keychain = %{version}-%{release}
74Requires: qt5-build
75Requires: qt5-qmake
76
77%description -n Qt5Keychain-devel
78This package contains libraries and header files for developing
79applications that use QKeychain.
80
8f55f1bc
LM
81%prep
82%setup -q
83
84%build
2e1a2913
ER
85%if %{with qt4}
86install -d build-qt4
87cd build-qt4
8f55f1bc 88%cmake \
d72e11a6
ER
89 -DBUILD_WITH_QT4=ON \
90 ..
8f55f1bc 91%{__make}
2e1a2913
ER
92cd ..
93%endif
94
95%if %{with qt5}
96install -d build-qt5
97cd build-qt5
98%cmake \
99 -DBUILD_WITH_QT4=OFF \
100 ..
101%{__make}
102%endif
8f55f1bc
LM
103
104%install
105rm -rf $RPM_BUILD_ROOT
2e1a2913
ER
106%if %{with qt4}
107%{__make} -C build-qt4 install \
07788830 108 DESTDIR=$RPM_BUILD_ROOT
8f55f1bc 109
d72e11a6 110%find_lang qtkeychain --with-qm
2e1a2913
ER
111%endif
112
113%if %{with qt5}
114%{__make} -C build-qt5 install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117%find_lang qtkeychain --with-qm
118%endif
d72e11a6 119
8f55f1bc
LM
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
07788830 124%postun -p /sbin/ldconfig
8f55f1bc 125
2e1a2913 126%if %{with qt4}
d72e11a6 127%files -f qtkeychain.lang
8f55f1bc
LM
128%defattr(644,root,root,755)
129%doc COPYING ReadMe.txt ChangeLog
130%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
2e1a2913 131%ghost %{_libdir}/libqtkeychain.so.0
8f55f1bc
LM
132
133%files devel
134%defattr(644,root,root,755)
2e1a2913
ER
135%{_includedir}/qtkeychain
136%{_libdir}/libqtkeychain.so
137%{_libdir}/cmake/QtKeychain
138%endif
139
140%if %{with qt5}
141%files -n Qt5Keychain
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
144%ghost %{_libdir}/libqt5keychain.so.0
145
146%files -n Qt5Keychain-devel
147%defattr(644,root,root,755)
148%{_includedir}/qt5keychain
149%{_libdir}/libqt5keychain.so
150%{_libdir}/cmake/Qt5Keychain
151%endif
This page took 0.101494 seconds and 4 git commands to generate.