]> git.pld-linux.org Git - packages/QCustomPlot.git/commitdiff
- initial release
authorBartek Szady <bszx@bszx.eu>
Fri, 20 Mar 2015 21:29:09 +0000 (22:29 +0100)
committerBartek Szady <bszx@bszx.eu>
Fri, 20 Mar 2015 21:29:09 +0000 (22:29 +0100)
QCustomPlot.cmake [new file with mode: 0644]
QCustomPlot.spec [new file with mode: 0644]

diff --git a/QCustomPlot.cmake b/QCustomPlot.cmake
new file mode 100644 (file)
index 0000000..7479a50
--- /dev/null
@@ -0,0 +1,25 @@
+project(QCustomPlot)
+cmake_minimum_required(VERSION 2.8.0)
+
+find_package ( Qt4 REQUIRED QtCore QtGui)
+include ( ${QT_USE_FILE} )
+
+set (QCustomPlot_SRCS
+  qcustomplot.cpp
+)
+
+set (QCustomPlot_HDRS
+  qcustomplot.h
+)
+
+set (QCustomPlot_MOCS
+  ${QCustomPlot_HDRS}
+)
+
+QT4_WRAP_CPP(MOCS ${QCustomPlot_MOCS})
+
+add_library(qcustomplot SHARED ${QCustomPlot_SRCS} ${MOCS})
+set_target_properties(qcustomplot PROPERTIES VERSION 1.0.0 SOVERSION 1)
+target_link_libraries(qcustomplot ${QT_LIBRARIES})
+install(TARGETS qcustomplot LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install(FILES ${QCustomPlot_HDRS} DESTINATION include)
diff --git a/QCustomPlot.spec b/QCustomPlot.spec
new file mode 100644 (file)
index 0000000..7f4cdf9
--- /dev/null
@@ -0,0 +1,86 @@
+Summary:       Qt widget for plotting and data visualization
+Summary(pl.UTF-8):     Widget do rysowania wykresów i wizualizacji danych dla Qt
+Name:          QCustomPlot
+Version:       1.3.0
+Release:       0.1
+License:       GPL v3
+Group:         X11/Libraries
+Source0:       http://www.qcustomplot.com/release/%{version}/%{name}.tar.gz
+# Source0-md5: 03b6d97cf8f0d4eb2902c0805a72e8bd
+Source1:       %{name}.cmake
+URL:           http://www.qcustomplot.com/
+BuildRequires: QtCore-devel
+BuildRequires: QtGui-devel
+BuildRequires: qt4-build
+BuildRequires: cmake >= 2.8.0
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _noautocompressdoc      *.qch
+
+%description
+QCustomPlot is a Qt C++ widget for plotting and data visualization.
+This plotting library focuses on making good looking, publication
+quality 2D plots, graphs and charts, as well as offering high
+performance for realtime visualization applications.
+
+%package        devel
+Summary:       Development files for %{name}
+Group:         X11/Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description    devel
+Header files for QCustomPlot library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki QCustomPlot
+
+%package        doc
+Summary:       Documentation and examples for QCustomPlot
+Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description    doc
+Documentation and examples for QCustomPlot
+
+%description doc -l pl.UTF-8
+Dokumentacja i przykłady biblioteki QCustomPlot
+
+%prep
+%setup -q -n qcustomplot
+install -p %{SOURCE1} CMakeLists.txt
+
+%build
+
+install -d build
+cd build
+%cmake \
+       ../
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} -C build install/fast \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc changelog.txt
+%attr(755,root,root) %{_libdir}/*.so.*
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/*
+%{_libdir}/*.so
+
+%files doc
+%defattr(644,root,root,755)
+%doc documentation examples
This page took 0.079918 seconds and 4 git commands to generate.