]> git.pld-linux.org Git - packages/PythonCAD.git/commitdiff
- new
authorradek <radek@pld-linux.org>
Tue, 15 Apr 2003 15:52:33 +0000 (15:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    PythonCAD.spec -> 1.1

PythonCAD.spec [new file with mode: 0644]

diff --git a/PythonCAD.spec b/PythonCAD.spec
new file mode 100644 (file)
index 0000000..5c9612a
--- /dev/null
@@ -0,0 +1,46 @@
+%include       /usr/lib/rpm/macros.python
+Summary:       An open-source CAD package built designed around Python
+#Summary(pl):  
+Name:          PythonCAD
+Version:       DS1_R5
+%define        _ver    %(echo %{version} | tr _ -)
+Release:       1
+License:       GPL
+Group:         Applications/Engineering
+Source0:       http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
+URL:           http://www.pythoncad.org/
+BuildRequires: python
+Requires:      python-pygtk-gtk >= 1.99.16
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+PythonCAD is an open-source CAD package built designed around Python. As
+such, it aims to be a fully scriptable and customizable CAD program. It
+is initially designed to run under Linux, one of the BSD flavors, or Unix.
+
+#%description -l pl
+
+%prep
+%setup -q -n %{name}-%{_ver}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+
+python setup.py install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README PKG-INFO NEWS
+%attr(755,root,root) %{_bindir}/*
+%{py_sitedir}/%{name}*
This page took 0.102207 seconds and 4 git commands to generate.