]> git.pld-linux.org Git - packages/PythonCAD.git/blob - PythonCAD.spec
- pl
[packages/PythonCAD.git] / PythonCAD.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        An open-source CAD package built designed around Python
3 Summary(pl):    Wolnodostêpny pakiet CAD oparty o Pythona
4 Name:           PythonCAD
5 Version:        DS1_R5
6 %define _ver    %(echo %{version} | tr _ -)
7 Release:        1
8 License:        GPL
9 Group:          Applications/Engineering
10 Source0:        http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
11 URL:            http://www.pythoncad.org/
12 BuildRequires:  python
13 Requires:       python-pygtk-gtk >= 1.99.16
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 PythonCAD is an open-source CAD package built designed around Python.
18 As such, it aims to be a fully scriptable and customizable CAD
19 program. It is initially designed to run under Linux, one of the BSD
20 flavors, or Unix.
21
22 %description -l pl
23 PythonCAD jest wolnodostêpnym pakietem CAD zbudowanym w oparciu o
24 Pythona. Dlatego ma byæ w pe³ni skryptowalnym i konfigurowalnym
25 programem CAD. Pocz±tkowo jest przeznaczony do uruchamiania pod
26 Linuksem, jedn± z wersji BSD lub Uniksem.
27
28 %prep
29 %setup -q -n %{name}-%{_ver}
30
31 %build
32 python setup.py build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_bindir}
37
38 python setup.py install \
39         --optimize=2 \
40         --root=$RPM_BUILD_ROOT
41
42 install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README PKG-INFO NEWS
50 %attr(755,root,root) %{_bindir}/*
51 %{py_sitedir}/%{name}*
This page took 0.101273 seconds and 4 git commands to generate.