]> git.pld-linux.org Git - packages/PythonCAD.git/blob - PythonCAD.spec
- BR: python-devel
[packages/PythonCAD.git] / PythonCAD.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        An open-source CAD package built designed around Python
3 Summary(pl):    Wolnodostêpny pakiet CAD oparty o Pythona
4 Name:           PythonCAD
5 Version:        DS1_R5
6 %define _ver    %(echo %{version} | tr _ -)
7 Release:        1
8 License:        GPL
9 Group:          Applications/Engineering
10 Source0:        http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
11 # Source0-md5:  418649c768dd721879905caedcd0dbeb
12 URL:            http://www.pythoncad.org/
13 BuildRequires:  python-devel
14 Requires:       python-pygtk-gtk >= 1.99.16
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 PythonCAD is an open-source CAD package built designed around Python.
19 As such, it aims to be a fully scriptable and customizable CAD
20 program. It is initially designed to run under Linux, one of the BSD
21 flavors, or Unix.
22
23 %description -l pl
24 PythonCAD jest wolnodostêpnym pakietem CAD zbudowanym w oparciu o
25 Pythona. Dlatego ma byæ w pe³ni skryptowalnym i konfigurowalnym
26 programem CAD. Pocz±tkowo jest przeznaczony do uruchamiania pod
27 Linuksem, jedn± z wersji BSD lub Uniksem.
28
29 %prep
30 %setup -q -n %{name}-%{_ver}
31
32 %build
33 python setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_bindir}
38
39 python setup.py install \
40         --optimize=2 \
41         --root=$RPM_BUILD_ROOT
42
43 install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README PKG-INFO NEWS
51 %attr(755,root,root) %{_bindir}/*
52 %{py_sitedir}/%{name}*
This page took 0.060758 seconds and 4 git commands to generate.