]> git.pld-linux.org Git - packages/PythonCAD.git/blob - PythonCAD.spec
- use only *.py[co] files, release 2
[packages/PythonCAD.git] / PythonCAD.spec
1 Summary:        An open-source CAD package built designed around Python
2 Summary(pl):    Wolnodostêpny pakiet CAD oparty o Pythona
3 Name:           PythonCAD
4 Version:        DS1_R16
5 %define _ver    %(echo %{version} | tr _ -)
6 Release:        2
7 License:        GPL
8 Group:          Applications/Engineering
9 Source0:        http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
10 # Source0-md5:  66a832ab278f2068ec5b0d26cb8438a1
11 URL:            http://www.pythoncad.org/
12 BuildRequires:  python-devel
13 Requires:       python-pygtk-gtk >= 1.99.16
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 PythonCAD is an open-source CAD package built designed around Python.
19 As such, it aims to be a fully scriptable and customizable CAD
20 program. It is initially designed to run under Linux, one of the BSD
21 flavors, or Unix.
22
23 %description -l pl
24 PythonCAD jest wolnodostêpnym pakietem CAD zbudowanym w oparciu o
25 Pythona. Dlatego ma byæ w pe³ni skryptowalnym i konfigurowalnym
26 programem CAD. Pocz±tkowo jest przeznaczony do uruchamiania pod
27 Linuksem, jedn± z wersji BSD lub Uniksem.
28
29 %prep
30 %setup -q -n %{name}-%{_ver}
31
32 %build
33 python setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_bindir}
38
39 python setup.py install \
40         --optimize=2 \
41         --root=$RPM_BUILD_ROOT
42
43 install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README PKG-INFO NEWS
51 %attr(755,root,root) %{_bindir}/*
52 %{py_sitescriptdir}/%{name}.pth
53 %dir %{py_sitescriptdir}/%{name}
54 %dir %{py_sitescriptdir}/%{name}/Generic
55 %{py_sitescriptdir}/%{name}/Generic/*.py[oc]
56 %dir %{py_sitescriptdir}/%{name}/Interface
57 %dir %{py_sitescriptdir}/%{name}/Interface/Gtk
58 %{py_sitescriptdir}/%{name}/Interface/Gtk/*.py[oc]
59 %dir %{py_sitescriptdir}/%{name}/Interface/Cocoa
60 %{py_sitescriptdir}/%{name}/Interface/Cocoa/*.py[oc]
61 %{py_sitescriptdir}/%{name}/Interface/*.py[oc]
This page took 0.087748 seconds and 3 git commands to generate.