]> git.pld-linux.org Git - packages/PythonCAD.git/blob - PythonCAD.spec
f6a1e0ec42283ddb36c50ae39bd585a07db2c9b9
[packages/PythonCAD.git] / PythonCAD.spec
1 Summary:        An open-source CAD package built designed around Python
2 Summary(pl):    Wolnodostêpny pakiet CAD oparty o Pythona
3 Name:           PythonCAD
4 Version:        DS1_R19
5 %define _ver    %(echo %{version} | tr _ -)
6 Release:        3
7 License:        GPL
8 Group:          Applications/Engineering
9 Source0:        http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
10 # Source0-md5:  3bfeb558044591c485fd569961d8b5a8
11 URL:            http://www.pythoncad.org/
12 BuildRequires:  python-devel
13 %pyrequires_eq  python-libs
14 Requires:       python-pygtk-gtk >= 1.99.16
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 PythonCAD is an open-source CAD package built designed around Python.
20 As such, it aims to be a fully scriptable and customizable CAD
21 program. It is initially designed to run under Linux, one of the BSD
22 flavors, or Unix.
23
24 %description -l pl
25 PythonCAD jest wolnodostêpnym pakietem CAD zbudowanym w oparciu o
26 Pythona. Dlatego ma byæ w pe³ni skryptowalnym i konfigurowalnym
27 programem CAD. Pocz±tkowo jest przeznaczony do uruchamiania pod
28 Linuksem, jedn± z wersji BSD lub Uniksem.
29
30 %prep
31 %setup -q -n %{name}-%{_ver}
32
33 %build
34 python setup.py build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_bindir}
39
40 python setup.py install \
41         --optimize=2 \
42         --root=$RPM_BUILD_ROOT
43
44 install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README PKG-INFO NEWS
52 %attr(755,root,root) %{_bindir}/*
53 %dir %{py_sitescriptdir}/%{name}
54 %dir %{py_sitescriptdir}/%{name}/Generic
55 %{py_sitescriptdir}/%{name}/Generic/*.py[oc]
56 %dir %{py_sitescriptdir}/%{name}/Interface
57 %dir %{py_sitescriptdir}/%{name}/Interface/Gtk
58 %{py_sitescriptdir}/%{name}/Interface/Gtk/*.py[oc]
59 %dir %{py_sitescriptdir}/%{name}/Interface/Cocoa
60 %{py_sitescriptdir}/%{name}/Interface/Cocoa/*.py[oc]
61 %{py_sitescriptdir}/%{name}/Interface/*.py[oc]
This page took 0.055875 seconds and 2 git commands to generate.