]> git.pld-linux.org Git - packages/PythonCAD.git/blame_incremental - PythonCAD.spec
- new
[packages/PythonCAD.git] / PythonCAD.spec
... / ...
CommitLineData
1%include /usr/lib/rpm/macros.python
2Summary: An open-source CAD package built designed around Python
3#Summary(pl):
4Name: PythonCAD
5Version: DS1_R5
6%define _ver %(echo %{version} | tr _ -)
7Release: 1
8License: GPL
9Group: Applications/Engineering
10Source0: http://www.pythoncad.org/releases/%{name}-%{_ver}.tar.bz2
11URL: http://www.pythoncad.org/
12BuildRequires: python
13Requires: python-pygtk-gtk >= 1.99.16
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17PythonCAD is an open-source CAD package built designed around Python. As
18such, it aims to be a fully scriptable and customizable CAD program. It
19is initially designed to run under Linux, one of the BSD flavors, or Unix.
20
21#%description -l pl
22
23%prep
24%setup -q -n %{name}-%{_ver}
25
26%build
27python setup.py build
28
29%install
30rm -rf $RPM_BUILD_ROOT
31install -d $RPM_BUILD_ROOT%{_bindir}
32
33python setup.py install \
34 --optimize=2 \
35 --root=$RPM_BUILD_ROOT
36
37install gtkpycad.py $RPM_BUILD_ROOT%{_bindir}
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42%files
43%defattr(644,root,root,755)
44%doc README PKG-INFO NEWS
45%attr(755,root,root) %{_bindir}/*
46%{py_sitedir}/%{name}*
This page took 0.053886 seconds and 4 git commands to generate.