]> git.pld-linux.org Git - packages/PyFileServer.git/commitdiff
- use setup.py to build and install (instead of %py_{,o}comp and cp)
authorradzio <radzio@pld-linux.org>
Sun, 19 Feb 2006 12:19:19 +0000 (12:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    PyFileServer.spec -> 1.3

PyFileServer.spec

index 32338eac0104e4e8a92c43e60e6ef10be40e5a16..fcd20ba2c7bf033ae4df01157f973a9edb987611 100644 (file)
@@ -6,7 +6,7 @@ Summary:        A WebDAV server in Python
 Summary(pl):   Serwer WebDAV napisany w Pythonie
 Name:          PyFileServer
 Version:       0.2.1
-Release:       0.1
+Release:       1
 License:       BSD
 Group:         Networking/Daemons
 Source0:       http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
@@ -52,18 +52,20 @@ udost
 %setup -q -n %{name}
 
 %build
-%py_comp pyfileserver/
-%py_ocomp pyfileserver/
+python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+python setup.py install \
+       --single-version-externally-managed \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_bindir}}
 
-cp -r pyfileserver $RPM_BUILD_ROOT%{py_sitescriptdir}
+
+install -d $RPM_BUILD_ROOT%{_bindir}
 echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
 cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
-
 %py_postclean
 
 %clean
@@ -75,3 +77,4 @@ rm -rf $RPM_BUILD_ROOT
 %doc THANKS.txt TODO.txt TUTORIAL.txt
 %attr(755,root,root) %{_bindir}/*
 %{py_sitescriptdir}/pyfileserver
+%{py_sitescriptdir}/PyFileServer*
This page took 0.076396 seconds and 4 git commands to generate.