]> git.pld-linux.org Git - packages/PyFileServer.git/blob - PyFileServer.spec
fcd20ba2c7bf033ae4df01157f973a9edb987611
[packages/PyFileServer.git] / PyFileServer.spec
1 #
2 # TODO:
3 # - check if PyXML is really required during build
4 #
5 Summary:        A WebDAV server in Python
6 Summary(pl):    Serwer WebDAV napisany w Pythonie
7 Name:           PyFileServer
8 Version:        0.2.1
9 Release:        1
10 License:        BSD
11 Group:          Networking/Daemons
12 Source0:        http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
13 # Source0-md5:  7a46d3f94e05d81b4110e6d0780c642b
14 URL:            http://pyfilesync.berlios.de/pyfileserver.html
15 BuildRequires:  python >= 2.3
16 BuildRequires:  unzip
17 %pyrequires_eq  python-modules
18 Requires:       python-PyXML
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PyFileServer implements up to Class 2 of the WebDAV specification,
24 including support for shared and exclusive write locking, and setting
25 arbitrary dead properties. It also implements HTTP user authentication
26 using both basic and digest schemes, HTTP single range retrievals and
27 conditional processing headers (If_Match, If_Modified_Since, etc).
28
29 PyFileServer also allows custom components to be developed easily by
30 having clear interfaces for:
31  - Resource Abstraction Layer
32  - Lock Manager
33  - Property Manager
34  - Domain Controllers
35
36 %description -l pl
37 PyFileSerwer implementuje specyfikacjê WebDAV do klasy 2 w³±cznie,
38 wraz z obs³ug± wspó³dzielonych i wy³±cznych blokad zapisu oraz
39 ustawianiem dowolnych martwych w³asno¶ci. Implementuje tak¿e
40 uwierzytelnianie u¿ytkowników po HTTP przy u¿yciu schematów basic i
41 digest, pojedyncze zakresy ¶ci±gania danych po HTTP oraz nag³ówki
42 przetwarzania warunkowego (If_Match, If_Modified_Since itp.).
43
44 PyFileServer pozwala tak¿e na ³atwe tworzenie w³asnych komponentów
45 udostêpniaj±c przejrzyste interfejsy do:
46  - warstwy abstrakcji zasobów (Resource Abstraction Layer)
47  - zarz±dcy blokad (Lock Manager)
48  - zarz±dcy w³asno¶ci (Property Manager)
49  - kontrolerów domen (Domain Controllers)
50
51 %prep
52 %setup -q -n %{name}
53
54 %build
55 python setup.py build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 python setup.py install \
60         --single-version-externally-managed \
61         --optimize=2 \
62         --root=$RPM_BUILD_ROOT
63
64
65
66 install -d $RPM_BUILD_ROOT%{_bindir}
67 echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
68 cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
69 %py_postclean
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt 
77 %doc THANKS.txt TODO.txt TUTORIAL.txt
78 %attr(755,root,root) %{_bindir}/*
79 %{py_sitescriptdir}/pyfileserver
80 %{py_sitescriptdir}/PyFileServer*
This page took 0.051399 seconds and 2 git commands to generate.