]> git.pld-linux.org Git - packages/PyFileServer.git/blob - PyFileServer.spec
- add BR: python-setuptools
[packages/PyFileServer.git] / PyFileServer.spec
1 #
2 # TODO:
3 # - check if PyXML is really required during build
4 #
5 Summary:        A WebDAV server in Python
6 Summary(pl):    Serwer WebDAV napisany w Pythonie
7 Name:           PyFileServer
8 Version:        0.2.1
9 Release:        1
10 License:        BSD
11 Group:          Networking/Daemons
12 Source0:        http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
13 # Source0-md5:  7a46d3f94e05d81b4110e6d0780c642b
14 URL:            http://pyfilesync.berlios.de/pyfileserver.html
15 BuildRequires:  python >= 2.3
16 BuildRequires:  python-setuptools
17 BuildRequires:  unzip
18 %pyrequires_eq  python-modules
19 Requires:       python-PyXML
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 PyFileServer implements up to Class 2 of the WebDAV specification,
25 including support for shared and exclusive write locking, and setting
26 arbitrary dead properties. It also implements HTTP user authentication
27 using both basic and digest schemes, HTTP single range retrievals and
28 conditional processing headers (If_Match, If_Modified_Since, etc).
29
30 PyFileServer also allows custom components to be developed easily by
31 having clear interfaces for:
32  - Resource Abstraction Layer
33  - Lock Manager
34  - Property Manager
35  - Domain Controllers
36
37 %description -l pl
38 PyFileSerwer implementuje specyfikacjê WebDAV do klasy 2 w³±cznie,
39 wraz z obs³ug± wspó³dzielonych i wy³±cznych blokad zapisu oraz
40 ustawianiem dowolnych martwych w³asno¶ci. Implementuje tak¿e
41 uwierzytelnianie u¿ytkowników po HTTP przy u¿yciu schematów basic i
42 digest, pojedyncze zakresy ¶ci±gania danych po HTTP oraz nag³ówki
43 przetwarzania warunkowego (If_Match, If_Modified_Since itp.).
44
45 PyFileServer pozwala tak¿e na ³atwe tworzenie w³asnych komponentów
46 udostêpniaj±c przejrzyste interfejsy do:
47  - warstwy abstrakcji zasobów (Resource Abstraction Layer)
48  - zarz±dcy blokad (Lock Manager)
49  - zarz±dcy w³asno¶ci (Property Manager)
50  - kontrolerów domen (Domain Controllers)
51
52 %prep
53 %setup -q -n %{name}
54
55 %build
56 python setup.py build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 python setup.py install \
61         --single-version-externally-managed \
62         --optimize=2 \
63         --root=$RPM_BUILD_ROOT
64
65
66
67 install -d $RPM_BUILD_ROOT%{_bindir}
68 echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
69 cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
70 %py_postclean
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt 
78 %doc THANKS.txt TODO.txt TUTORIAL.txt
79 %attr(755,root,root) %{_bindir}/*
80 %{py_sitescriptdir}/pyfileserver
81 %{py_sitescriptdir}/PyFileServer*
This page took 0.057226 seconds and 3 git commands to generate.