]> git.pld-linux.org Git - packages/PyFileServer.git/blob - PyFileServer.spec
32338eac0104e4e8a92c43e60e6ef10be40e5a16
[packages/PyFileServer.git] / PyFileServer.spec
1 #
2 # TODO:
3 # - check if PyXML is really required during build
4 #
5 Summary:        A WebDAV server in Python
6 Summary(pl):    Serwer WebDAV napisany w Pythonie
7 Name:           PyFileServer
8 Version:        0.2.1
9 Release:        0.1
10 License:        BSD
11 Group:          Networking/Daemons
12 Source0:        http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
13 # Source0-md5:  7a46d3f94e05d81b4110e6d0780c642b
14 URL:            http://pyfilesync.berlios.de/pyfileserver.html
15 BuildRequires:  python >= 2.3
16 BuildRequires:  unzip
17 %pyrequires_eq  python-modules
18 Requires:       python-PyXML
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PyFileServer implements up to Class 2 of the WebDAV specification,
24 including support for shared and exclusive write locking, and setting
25 arbitrary dead properties. It also implements HTTP user authentication
26 using both basic and digest schemes, HTTP single range retrievals and
27 conditional processing headers (If_Match, If_Modified_Since, etc).
28
29 PyFileServer also allows custom components to be developed easily by
30 having clear interfaces for:
31  - Resource Abstraction Layer
32  - Lock Manager
33  - Property Manager
34  - Domain Controllers
35
36 %description -l pl
37 PyFileSerwer implementuje specyfikacjê WebDAV do klasy 2 w³±cznie,
38 wraz z obs³ug± wspó³dzielonych i wy³±cznych blokad zapisu oraz
39 ustawianiem dowolnych martwych w³asno¶ci. Implementuje tak¿e
40 uwierzytelnianie u¿ytkowników po HTTP przy u¿yciu schematów basic i
41 digest, pojedyncze zakresy ¶ci±gania danych po HTTP oraz nag³ówki
42 przetwarzania warunkowego (If_Match, If_Modified_Since itp.).
43
44 PyFileServer pozwala tak¿e na ³atwe tworzenie w³asnych komponentów
45 udostêpniaj±c przejrzyste interfejsy do:
46  - warstwy abstrakcji zasobów (Resource Abstraction Layer)
47  - zarz±dcy blokad (Lock Manager)
48  - zarz±dcy w³asno¶ci (Property Manager)
49  - kontrolerów domen (Domain Controllers)
50
51 %prep
52 %setup -q -n %{name}
53
54 %build
55 %py_comp pyfileserver/
56 %py_ocomp pyfileserver/
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_bindir}}
62
63 cp -r pyfileserver $RPM_BUILD_ROOT%{py_sitescriptdir}
64 echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
65 cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
66
67 %py_postclean
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt 
75 %doc THANKS.txt TODO.txt TUTORIAL.txt
76 %attr(755,root,root) %{_bindir}/*
77 %{py_sitescriptdir}/pyfileserver
This page took 0.060374 seconds and 2 git commands to generate.