]> git.pld-linux.org Git - packages/PyFileServer.git/blame_incremental - PyFileServer.spec
BR: rpmbuild(macros) >= 1.710
[packages/PyFileServer.git] / PyFileServer.spec
... / ...
CommitLineData
1Summary: A WebDAV server in Python
2Summary(pl.UTF-8): Serwer WebDAV napisany w Pythonie
3Name: PyFileServer
4Version: 0.2.1
5Release: 1
6License: BSD
7Group: Networking/Daemons
8Source0: http://download.berlios.de/pyfilesync/PyFileServer-0.2.1.zip
9# Source0-md5: 7a46d3f94e05d81b4110e6d0780c642b
10URL: http://pyfilesync.berlios.de/pyfileserver.html
11BuildRequires: rpmbuild(macros) >= 1.710
12Patch0: %{name}-setup_py.patch
13BuildRequires: python >= 2.3
14BuildRequires: python-setuptools
15BuildRequires: unzip
16%pyrequires_eq python-modules
17Requires: python-PyXML
18BuildArch: noarch
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22PyFileServer implements up to Class 2 of the WebDAV specification,
23including support for shared and exclusive write locking, and setting
24arbitrary dead properties. It also implements HTTP user authentication
25using both basic and digest schemes, HTTP single range retrievals and
26conditional processing headers (If_Match, If_Modified_Since, etc).
27
28PyFileServer also allows custom components to be developed easily by
29having clear interfaces for:
30 - Resource Abstraction Layer
31 - Lock Manager
32 - Property Manager
33 - Domain Controllers
34
35%description -l pl.UTF-8
36PyFileSerwer implementuje specyfikację WebDAV do klasy 2 włącznie,
37wraz z obsługą współdzielonych i wyłącznych blokad zapisu oraz
38ustawianiem dowolnych martwych własności. Implementuje także
39uwierzytelnianie użytkowników po HTTP przy użyciu schematów basic i
40digest, pojedyncze zakresy ściągania danych po HTTP oraz nagłówki
41przetwarzania warunkowego (If_Match, If_Modified_Since itp.).
42
43PyFileServer pozwala także na łatwe tworzenie własnych komponentów
44udostępniając przejrzyste interfejsy do:
45 - warstwy abstrakcji zasobów (Resource Abstraction Layer)
46 - zarządcy blokad (Lock Manager)
47 - zarządcy własności (Property Manager)
48 - kontrolerów domen (Domain Controllers)
49
50%prep
51%setup -q -n %{name}
52%patch0
53
54%build
55%py_build
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%py_install \
60 --single-version-externally-managed \
61 --optimize=2 \
62 --root=$RPM_BUILD_ROOT
63
64
65
66install -d $RPM_BUILD_ROOT%{_bindir}
67echo "#!/usr/bin/python" > $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
68cat ext_wsgiutils_server.py >> $RPM_BUILD_ROOT%{_bindir}/PyFileServer.py
69%py_postclean
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%files
75%defattr(644,root,root,755)
76%doc ADDONS.txt DEVELOPERS.txt PyFileServer-example.conf README.txt
77%doc THANKS.txt TODO.txt TUTORIAL.txt
78%attr(755,root,root) %{_bindir}/*
79%{py_sitescriptdir}/pyfileserver
80%{py_sitescriptdir}/PyFileServer*
This page took 0.074926 seconds and 4 git commands to generate.