]> git.pld-linux.org Git - packages/PyCXX.git/commitdiff
- Release 2. Added memleak fix by Barry Scott. master auto/th/PyCXX-6_2_3-2
authorMateusz Korniak <matkor@pld-linux.org>
Tue, 26 Jul 2011 17:02:23 +0000 (17:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    PyCXX-memleak_fix.patch -> 1.1
    PyCXX.spec -> 1.2

PyCXX-memleak_fix.patch [new file with mode: 0644]
PyCXX.spec

diff --git a/PyCXX-memleak_fix.patch b/PyCXX-memleak_fix.patch
new file mode 100644 (file)
index 0000000..86d7d41
--- /dev/null
@@ -0,0 +1,48 @@
+--- ./CXX/Python2/ExtensionOldType.hxx-memleak_fix     2011-07-26 17:32:57.230429675 +0200
++++ ./CXX/Python2/ExtensionOldType.hxx 2011-07-26 17:34:05.384066472 +0200
+@@ -178,7 +178,7 @@ namespace Py
+             Tuple self( 2 );
+             self[0] = Object( this );
+-            self[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
++            self[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ), true );
+             PyObject *func = PyCFunction_New( &method_def->ext_meth_def, self.ptr() );
+--- ./CXX/Python2/ExtensionModule.hxx-memleak_fix      2011-07-26 17:34:21.287470428 +0200
++++ ./CXX/Python2/ExtensionModule.hxx  2011-07-26 17:35:49.331193448 +0200
+@@ -139,8 +139,8 @@ namespace Py
+                 static PyObject *self = PyCObject_FromVoidPtr( this, do_not_dealloc );
+                 Tuple args( 2 );
+-                args[0] = Object( self );
+-                args[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
++                args[0] = Object( self, true );
++                args[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ), true );
+                 PyObject *func = PyCFunction_New
+                                     (
+--- ./CXX/Python3/ExtensionModule.hxx.memleak_fix      2011-07-26 18:55:45.910115406 +0200
++++ ./CXX/Python3/ExtensionModule.hxx  2011-07-26 18:56:55.327162541 +0200
+@@ -137,8 +137,8 @@ namespace Py
+                 static PyObject *self = PyCObject_FromVoidPtr( this, do_not_dealloc );
+                 Tuple args( 2 );
+-                args[0] = Object( self );
+-                args[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
++                args[0] = Object( self, true );
++                args[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ), true );
+                 PyObject *func = PyCFunction_New
+                                     (
+--- ./CXX/Python3/ExtensionOldType.hxx.memleak_fix     2011-07-26 18:54:39.309749026 +0200
++++ ./CXX/Python3/ExtensionOldType.hxx 2011-07-26 18:55:25.346669091 +0200
+@@ -178,7 +178,7 @@ namespace Py
+             Tuple self( 2 );
+             self[0] = Object( this );
+-            self[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
++            self[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ), true );
+             PyObject *func = PyCFunction_New( &method_def->ext_meth_def, self.ptr() );
index b6610f4d0a1c14df52daaeaf508c5d204a145914..c172d78680aa2bbccdd649dd1bf1613203dc880c 100644 (file)
@@ -5,12 +5,13 @@ Summary:      Set of classes to help create extensions of Python in the C++ language
 Summary(pl.UTF-8):     Klasy C++ pomocne przy tworzeniu modułów Pythona
 Name:          PyCXX
 Version:       6.2.3
-Release:       1
+Release:       2
 License:       BSD
 Group:         Development/Libraries
 # http://prdownloads.sourceforge.net/cxx/pycxx-6.2.3.tar.gz
 Source0:       http://downloads.sourceforge.net/cxx/pycxx-%{version}.tar.gz
 # Source0-md5: 4e545ad225df9c14a3b344b1e6224661
+Patch0:         %{name}-memleak_fix.patch
 URL:           http://cxx.sourceforge.net/
 BuildRequires: python-modules
 Requires:      libstdc++-devel
@@ -30,6 +31,7 @@ modułów rozszerzeń Pythona.
 
 %prep
 %setup -q -n pycxx-%{version}
+%patch0 -p1
 
 %build
 
This page took 0.095526 seconds and 4 git commands to generate.